Jump to content
Angelo DiBraccio

Cakewalk won't start unless I set a Windows Display Custom Scaling value is set [SOLVED]]

Recommended Posts

Posted (edited)

Hi

I was having a problem of Cakewalk  shutting down when I launch it. I launched Cakewalk, the Cakewalk flash screen opened.  Then the application window opened then the Cakewalk immediately  shut  down. The problem occurred with Cakewalk and Sonar X3.  The problem didnot  occur with any other audio or windows applications.  This problem started right after i installed a new Dell Monitor  S Series 32"  (S3219D).  But I swapped the new Dell monitor with my old monitor and Cakewalk won't startup with the old monitor either.

I figured out a workaround which is to set a Windows Display Settings > Custom Scaling value.  If I don't set a Custom Scaling  value, Cakewalk shuts down after I attempt to start it.

So If I want to set the resolution to 2560 x 1440,  I must also set a Custom Scaling value of (100).

Kinda strange.

Does anyone know why this might be happening?

Update

Solved.

Set Calkwalk.exe compatibility.

Tick "Override high DPI scaling behavior. Scaling performed by" = Application

 

 

Edited by Angelo DiBraccio
  • Confused 1

Share this post


Link to post
Share on other sites

Hi @Angelo DiBraccio
Very strange. I'd like to investigate, but I need a bit more information.
Firstly, what version of Windows are you using?
Secondly, please would you attach screenshots of these three things:
1. Settings -> Display (the 'Scale and layout' section, in particular)?
2. Right click on Cakewalk.exe, choose Properties from the menu, then select the Compatibility tab.
3. Click the 'Change high DPI settings button'.
That might help me get to the bottom of it.
Many thanks!
Ben

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Ben 

Thank you for responding.

The problem that I described before the Update   section of my post has been completely solved by setting  the High DPI properties I mentioned in the  Update  section of my post.

So, in a nutshell,  the problem has been completely solved by the ticking "Override high DPI scaling behavior. Scaling performed by" and selecting "Application" in the combo box.  Cakewalk now launches consistently and I can set any resolution with or without a regular or custom scaling in Windows display settings.

If I untick "Override high DPI scaling behavior. Scaling performed by" or it it is ticked and I select anything  other than "Application" in the combo box, Cakewalk shuts down when I attempt to launch it. In this case, the first workaround I mentioned before the Update  section of my post still works, which is to set a custom scaling value. The custom scaling value can be any value from 100 to 500. This behavior is absolutely consistent.

Regards

Angelo

Display Settings.png

Cakewalk Compatitililty Settings.png

Cakewalk High DPI settings.png

Edited by Angelo DiBraccio

Share this post


Link to post
Share on other sites

@Angelo DiBraccio
Thanks for the quick response, Angelo, and for the extra info/screenshots.
By default, the 'Override high DPI scaling behavior' checkbox should be unchecked, but I realize that causes the startup problem in your case.
It's possible that checking it will cause some layout issues, but you might be OK because your 'Scale and layout' setting is 100%, so there's no scaling involved either way.
I've tried to reproduce without any success so far. I'll let you know if I figure it out, but I'm pleased to hear you're up and running anyway.

Share this post


Link to post
Share on other sites

Ben

I have no scaling problems with regular or custom scaling.  I want to point out that the problem of Cakewalk shutting down occurred immediately after I connected my new Dell monitor (s3219D) 32". Never had the problem before I used the new monitor.

Thanks again

 

 

Share this post


Link to post
Share on other sites

So you just launch Cakewalk and the app shuts down when in this state? Do you get a crash dialog - if so we'd like to look at the minidump file.
Are you using a different language setting in Cakewalk by any chance?

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Noel

The problem is solved by using the settings I described above, but without these settings, Cakewalk consistently shuts down.

The Flash Screen opens, then the application window appears  for about 2 seconds. Then Cakewalk shuts down. There is no crash dialog.  I am using English language..

Attached is a cakewalk .dmp file generated today, when I changed the DPI settings.

Regards

Angelo

Update

I have a different monitor that I am testing as a possible keeper.

It's Samsung 43" 7 Series 4k Smart TV. The problem exists with the new monitor.

As long as I tick  "Override high DPI scaling behavior. Scaling performed by" = Application,  no problems.

 

05122020_091125.dmp

Edited by Angelo DiBraccio

Share this post


Link to post
Share on other sites

@Angelo DiBraccio Thanks for the crash dump. That should pinpoint the code in question. Investigating...

Edit: The crash dump helped me find the cause. I'll try to fix for the next release.

Share this post


Link to post
Share on other sites
On 5/15/2020 at 6:10 AM, Ben Staton said:

@Angelo DiBraccio Thanks for the crash dump. That should pinpoint the code in question. Investigating...

Edit: The crash dump helped me find the cause. I'll try to fix for the next release.

That's good news that you found the cause. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...