Jump to content
Sign in to follow this  
cclarry

Xperiments FREE Kontakt Instruments

Recommended Posts

Thanks Larry.

The demos sound really nice. Worth a shot!

  • Like 1

Share this post


Link to post
Share on other sites

I can't subscribe to the get the freebies.  I put my email in, click submit..it says

"Sending" then does nothing.....😩

  • Sad 1

Share this post


Link to post
Share on other sites

Worked for me, you should get an email to confirm the subscription, then another one with the link to the downloads page. 

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, cclarry said:

I can't subscribe to the get the freebies.  I put my email in, click submit..it says

"Sending" then does nothing.....😩

Try a different browser. I got it work that way.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, cclarry said:

I can't subscribe to the get the freebies.  I put my email in, click submit..it says

"Sending" then does nothing.....😩

Same here. No matter what browser or email I use.

  • Sad 1

Share this post


Link to post
Share on other sites
Posted (edited)

Worked OK here using Chrome.

It said to allow 3 minutes for the download links to arrive and it took exactly 3 minutes for them to arrive.

Those who haven't received the email maybe check your Spam folder.

Edited by ZincT

Share this post


Link to post
Share on other sites
14 hours ago, Patrick Derbidge said:

Same here. No matter what browser or email I use.

I guess we should download more browsers until it works.  As one who has more than enough sounds I can't believe I'm going through a set of hoops for a free one.

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, ZincT said:

Worked OK here using Chrome.

It said to allow 3 minutes for the download links to arrive and it took exactly 3 minutes for them to arrive.

Those who haven't received the email maybe check your Spam folder.

I'm using Chrome.  Have done it a dozen times.  Never goes farther than to say "sending"
Did the same in Edge, and the same result.  I quit...not worth the effort.

  • Like 1

Share this post


Link to post
Share on other sites

I've tried FF, Chrome, and (gasp!) IE ... none worked.  I think we need the secret password.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)
55 minutes ago, cclarry said:

I'm using Chrome.  Have done it a dozen times.  Never goes farther than to say "sending"
Did the same in Edge, and the same result.  I quit...not worth the effort.

That's very strange Larry. 

I have contacted them to see if they can send you (and others) the links manually. I have pointed them to this thread so that they can see how many are having issues.  They are actually worth having for the small amount of space they occupy.

Edited by ZincT

Share this post


Link to post
Share on other sites
Posted (edited)

Hey guys. I'm the builder of these free instruments. Sorry for any issues you're having signing up to my website or receiving the download links.

For anyone having troubles – contact me through my support page:  https://www.analogueinstruments.com/getintouch/

Send me your email address and a request for the free instruments. I'll add you to my system manually, and you'll get the links for the instruments shortly after that. 

Many thanks for your patience.

Edited by David Hicks
  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)
3 minutes ago, David Hicks said:

Hey guys. I'm the builder of these free instruments. Sorry for any issues you're having signing up to the website or receiving the download links.

For anyone having troubles – contact me through my support page:  https://www.analogueinstruments.com/support/  

Send me your email address and a request for the free instruments. I'll add you to my system manually, and you'll get the links for the instruments shortly after that. 

Many thanks for your patience.

Thanks for your reply to my email David and for also posting here. I was just about to copy your email here so you saved me the need to. 

Hopefully this will get you and others sorted @cclarry

Edited by ZincT
  • Like 1

Share this post


Link to post
Share on other sites

Sent a support form David!  

Thanks for coming to the rescue!!!

Share this post


Link to post
Share on other sites
4 minutes ago, Matthew Sorrels said:

I couldn't get the subscribe option on the page with the free instruments to work.  But if you go to the main product page https://www.analogueinstruments.com

and scroll all the way down, that subscribe option did work for me.

That worked for me too.   Just waiting for the email now.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...