Jump to content
gstring

Can only record at 16-bit depth

Recommended Posts

I'm running Cakewalk Bandlab. My audio interface (NI Komplete Audio 2) is set at 24-bit 48KHz sample rate, but all audio records in CBL at 16-bit depth, yet when I record in Studio Lab or Project 5, the audio always records at 24-bit depth. The Audio Driver Bit Depth setting is grayed out in CBL Audio Driver Settings so I can't make any change there to the setting, but it displays as being 24. I'm using NI's ASIO drivers. Native Instrument's Komplete Audio Control Panel allows me to set the buffer size and sample rate, but there is nothing to set the bit depth. Windows 10 Sound Control panel has the interface set to play and record at 24-bit 48 KHz. I've tried deleting the aud.ini file and resetting to default values, but to no avail. 

This problem has only developed recently; when I open older projects, I see that all audio files are 24-bit. I'm stumped. Any ideas?

Share this post


Link to post
Share on other sites
26 minutes ago, gstring said:

he Audio Driver Bit Depth setting is grayed out in CBL Audio Driver Settings so I can't make any change there to the setting, but it displays as being 24.

Many ASIO drivers work at one bit depth. Most often 24 bit.

Share this post


Link to post
Share on other sites

My audio interface does record at 24-bit depth in other DAWs, but my tracks in CBL are being recorded at 16-bit depth. This is my problem.

Share this post


Link to post
Share on other sites

Understood, as the link above mentions, projects record using the record bit depth setting NOT the audio driver bit depth setting.

 

Share this post


Link to post
Share on other sites

The Audio Driver Bit Depth setting displays 24, but my recorded tracks are 16-bit resolution in CBL. I get 24-bit recordings in all other programs with the same audio interface. I've tried 3 different audio interfaces now with the same result. The problem seems to be in CBL.

Share this post


Link to post
Share on other sites

No amount of changing audio drivers or interfaces is going to matter.

If you have not changed the Record Bit Depth don't expect the program to record at a different bit depth.

Dialogs2.063.1.png

 

Share this post


Link to post
Share on other sites

My audio interface does record at 24-bit depth in other DAWs, but my tracks in CBL are being recorded at 16-bit depth. This is my problem.

Share this post


Link to post
Share on other sites

Thank you so much scook. I finally found that setting in your link, and indeed the record bit depth was somehow set to 16. I changed it to 24 and now all is good. You da man!!!

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...