Jump to content
Sign in to follow this  
zaquria

Click Dragging Clips in Project

Recommended Posts

Posted (edited)

There is a behaviour regarding click copy Clips that I would like to see changed please.

Normally, if you select a Clip, click and drag it elsewhere, the Clip is then moved to the postition you have choose.  If you choose Shift and click, then copy is used instead, pretty standard stuff and follows the 'norm'.

However, If I select All Clips in the project, click and move the Clip, we then get a totally different outcome from the one descrbed from above.  Intead of moving all the clips, they are copied instead. This goes against what I would expect with keeping to a 'standard' approach.

The same behaviour when copying or moving Clips should ahered too to keep some sort of standard. So if I select all Cips in my project and drag them elsewhere, they should be moved and not copied, as is done when it is a single Clip. (Note this only happens when I select All the clips in the project, and not multiple Clips).

Using Shift+click and drag doesn't always work for me when trying to move clips. I don't know if that is a bug or not?

Edit: It seems if I use hold Shift+click to move Clips, I have to click on Clip on the very last Track to get all the Clips to move. Not very helpful if I have 100's of tracks in a project. :(

Cheers.

Edited by zaquria

Share this post


Link to post
Share on other sites

Another issue moving Clips, If there are Envelopes at the start of a Track, I cannot move Clips Back towards the start because the Envelope prevents this happening.

As you can see from the image below,  I cannot move all the clips closer to the start because the Envelopes on a track prevent this from happening.  To allow me to move the Clip, I have to Delete the envelopes completely. I tried to create a new Node and delete the one at the start, but this didn't work either and I still couldn't move all the Clips Back to a point I wanted.

Envelope.jpg.b9d8bbdc5d933886c1eb6c80a4b4093b.jpg

Share this post


Link to post
Share on other sites

Shift-click-drag maintains time position when dragging vertically; ctrl-cick-drag does copy.  Not sure if that affects your findings.

  • Thanks 1

Share this post


Link to post
Share on other sites
28 minutes ago, Kevin Perry said:

Shift-click-drag maintains time position when dragging vertically; ctrl-cick-drag does copy.  Not sure if that affects your findings.

Still the same using ctrl-click unfortunately. :(

Share this post


Link to post
Share on other sites
2 hours ago, zaquria said:

Another issue moving Clips, If there are Envelopes at the start of a Track, I cannot move Clips Back towards the start because the Envelope prevents this happening.

After select all

  • move the Now marker to be beginning of the earliest clip on the timeline
  • Select From Now
  • Click-Drag clips as far left as 0.

Or select the blank measures on the timeline to remove, enable ripple edit all then delete

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...