Jump to content
Dave Maffris

Suddenly tracks being recorded w CC 24 and 25 events

Recommended Posts

Cakewalk user since 1993. This is a new one for me. Past couple of days I noticed my clips contained vertical lines that I determined (via event viewer) were either CC 24 or CC25, which to my knowledge are unassigned to any function. I have selected them by filter and deleted, but I'm wondering why this is happening now, and also how my clips suddenly started showing this, as I haven't seen a setting for this and never had this happen before. It's not causing any other problems, but it is annoying and I'm pretty sure it's something I can fix, if only I knew how. I have the latest version (not the new release candidate), and I am thinking of upgrading to the early release and see if that fixes it.

Any suggestions or knowledge about this? Thanks.

Share this post


Link to post
Share on other sites
Posted (edited)

The fact that a CC is undefined does not mean that it does not function--just that the function has to be defined for each instrument by the designer. You do not say how you are recording the affected tracks. If your keyboard is not sending the CC, then consider that one of your instruments or plugins may be doing so. Some synths have the ability to send as well as receive MIDI messages to coordinate with other instruments or effects. You may be able to check the source of the MIDI messages with MIDIOx. The keyboard will almost certainly show, and an instrument or plug-in might expose itself as a MIDI source as well. Otherwise you might need to do trial and error with plugs on the affected tracks to see if something is sending the unexpected messages. 

Edited by slartabartfast
  • Like 1

Share this post


Link to post
Share on other sites

Never known CbB or any prior version of SONAR to add CC events on their own.

If it is not coming from outside of the DAW, something MIDI-OX could determine, then it might be from a plug-in. By default, synths capable of generating or passing MIDI data thought them have "Enable MIDI Output" turned on.

This in combination with a recording track input set to Omni will pick up unexpected data.

The "Enable MIDI Output" option in on the Insert Soft Synth Options dialog and in the VST2/3 drop down above the plug-in UI

M9I2IRu.png

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Are you recording your MIDI track using a keyboard MIDI controller. 

Maybe some sliders are faulty and sending out the spurious CC data.   I had a PCR-800 do this until I squirted a bit of electrical contact cleaner in the slider and moved it around a bit......

Share this post


Link to post
Share on other sites

I had an M-Audio (aactually still have it), that suddenly started generating Pitch Bend events.

After digging into it on the web, apparently some of the potentiometers (pots) and other electrical components, can go bad after a few years, and that can result in things like generated midi messages, and such.

I went into the midi controller's settings, and turned off the Pitch Bend wheel altogether, and all was fine after that - but I did lose the Pitch Wheel for that controller.

I would imagine unwanted events could be filtered out, as well - maybe that would help your situation, if indeed the messages are being generated by an external device, such as a midi controller.

Bob Bone

Share this post


Link to post
Share on other sites

Yes, I am using a controller, actually two different ones, the same as always, however. And today I did some recording a new song and did not see any of the extraneous controller data, so maybe it was unique to this one project, and I may double check all my plug-ins on that one, but I generally use mostly the same stuff over and over, a lot of Kontakt VST's, some live recording of vocals, but at least it's not happening since I deleted the excess data and finished a project, plus recorded a new one.

Thanks for all who had suggestions, too. 

Share this post


Link to post
Share on other sites

Had this problem for 10 years...

If using a usb keyboard, plug it directly to usb computer port... not in a hub...

That caused me problem on my pc and on my mac. Now problem is gone !

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...