Jump to content
Meltopia

overcompensated latency issues

Recommended Posts

Hello anyone!

I've recently been trying to record from a softsynth to an audio track but the recording has been adjusted too much for latency.

Each beat of the recording is very slightly before the actual beat! I assume cakewalk is over compensating for latency.

The latency adjustment for recording live instruments is perfect, so I know it's not a problem with my machine.

I have found a couple of posts from people with the same problem but nobody seems to have an answer.

I'm assuming that cakewalk knows how much to adjust recorded audio from the inputs on my soundcard and makes the same adjustment when recording a softsynth, even though the softsynth doesn't do the round trip back into the sound card. Meaning that the recorded softsynth ends up being slightly before the beat. 

I've heard of the same issue in pro tools but you can turn of delay compensation individually for each track, which solves the problem.

I would love it if somebody had an answer for this, but It looks like nobody does!

Maybe somebody might have a good way of turning multiple softsynth outputs into separate audio tracks that I don't know about. I thought of freezing tracks and just pasting the frozen tracks to new audio tracks, which seems like a workaround I shouldn't have to do. But it does line up the tracks in the right place at least!

Has anyone got any ideas?

Share this post


Link to post
Share on other sites

Some audio interfaces don't report their record latency accurately.

 

Check the Record Offset for your audio interface.

  • Record a short high-transient spike signal (like an isolated click).
  • Now, take that single "Click" and rerecord it (physically patch an output to an input) to a second track.
  • Zoom way in... and measure the difference between the two clicks (in samples).

This is your audio interface's Record Offset.

In Sonar, under Preferences>Audio>Sync And Caching... enter the number of samples (Record Offset) in the "Manual Offset" box.

Newly recorded audio will now line up correctly.

Edited by Jim Roseberry
  • Thanks 3

Share this post


Link to post
Share on other sites

There can be a number of reasons for this, I have seen it reported in numerous forums and having different fixes, sometimes, in some DAW's, not fixable. It might be good to know what sound card you have, and at the risk of stating the obvious, which driver you are using (ASIO I assume) and is it the latest one from the manufacturer.

Share this post


Link to post
Share on other sites

Thanks for the input people.

My soundcard is the M-Audio 2496. I have the latest driver and can use it in ASIO or WDM. It's exactly the same in both. I checked the record delay settings but you can't do a negative adjustment. I was also wrong about the live instrument recording! It has the same problem. It doesn't seem to happen when it's an empty project. So I think Jim Roseberry is right in saying that  "Some audio interfaces don't report their record latency accurately". It's just weird that it  over compensates and puts the click slightly to the left of the beat. If it was the other way, then I could just type in the record delay adjustment!

Share this post


Link to post
Share on other sites

 

17 hours ago, Meltopia said:

I'm assuming that cakewalk knows how much to adjust recorded audio from the inputs on my soundcard and makes the same adjustment when recording a softsynth, even though the softsynth doesn't do the round trip back into the sound card. Meaning that the recorded softsynth ends up being slightly before the beat. 

It's not the same compensation as for  external audio input, but there is a bug that causes soft synth audio to be laid down early by exactly one ASIO buffer when the synth is driven by existing MIDI in the project. (Note that the opposite problem occurs when recording a soft synth driven by live, real-time MIDI input, but is expected because the audio isn't compensated for MIDI latency or the fact that the audio you're playing along with is delayed by output latency).

Workarounds are:

- Set a very small ASIO buffer (e.g. 32 samples), and ignore the error.

- Freeze or Bounce to Track instead of recording.

- Put a send on the Synth track to an Aux track, and record on the Aux track which won't have the compensation mis-applied.

  • Thanks 1

Share this post


Link to post
Share on other sites

Putting a send on the synth track works! Crazy stuff man! On a drum track with 8 outputs, I have to create a send for each one. What I really wanted to do was just create the instrument track with all outputs automatically assigned, arm the tracks, hit record and job done. But it looks like I either have to freeze all tracks and copy the frozen tracks to new tracks for editing, or create aux sends for them and record them that way. It seems a bit mental but at least the problem has a few workarounds. 

Thanks to everyone for contributing to this!

Share this post


Link to post
Share on other sites

Also, that sound card is getting a little old now. Which doesn't mean anything much, providing you use it with windows xp sp2 to windows 7 sp1. I used it for sometime and also the 192. Very stable and nice sounding cards for recording, work well with these operating systems.

The problem is there is no "Windows 7" driver for this card, I understand they stopped driver production at Windows 7 SP1. If you use it with any operating system after this there may be unpredictable results. Audio cards that are designed to work with Windows 7 SP1 may not work well with a fully updated installation of Windows 7 because there were many changes introduced into Windows 7 through its life. Windows 7 today would be like Windows 7 sp3.

Share this post


Link to post
Share on other sites

So I've been trying desperately to find the best way of converting a soft synth to multiple audio tracks. I don't mind freezing but I wanted the audio tracks to be unfrozen. I've found a way to do this operation very easily and thought I'd share it for anyone who wishes to do the same.  


Assuming that you have a softsynth setup already going to multiple tracks: 


1: Highlight all tracks and freeze them 


2: Highlight all frozen tracks you want, and go to:   tracks/Duplicate tracks...  (make sure events and properties are ticked) Click ok! 


You will then have: 


All your tracks created and named with the audio data in them to do with what you will. 


Obviously you can do whatever you like with the frozen tracks and softsynth.  


I've been banging my head against a brick wall about this and finally!  


I hope this is helpful for anyone looking to easily create multiple audio tracks from a softsynth. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...