Jump to content
Gabriel Gorman

Problem with recording MIDI from keyboard

Recommended Posts

When I try to record MIDI from my keyboard onto a virtual instrument it records the sound of the keyboard and not the virtual instrument. It records the midi notes fine but when I listen to it it makes the piano sound of the keyboard and not the high quality piano vst.

Share this post


Link to post
Share on other sites

The more details the better. In this case it may help to know how the keyboard is attached, audio interface, how the tracks are setup in the DAW. Additional stuff like make/model of keyboard may be useful. The plug-in being used sometimes helps. In short describing a problem without describing the environment in detail makes it difficult for those trying to imagine what the cause of the problem might be.

If you are not hearing the MIDI played through the plug-in it could be the MIDI track is not routed to the plug-in and/or the plug-in does not have an audio track setup t receive the audio from the plug-in.

If using an instrument track, it may be the MIDI is not being recorded on the instrument track but is recorded on a separate MIDI track.

A complete routing for a virtual instrument is EITHER an instrument track OR an audio/MIDI track pair.

 

 

 

Share this post


Link to post
Share on other sites

The keyboard is attached via usb, my audio interface is a SubZero AI2 and my keyboard make is yamaha psr e333. The midi seems to be recorded properly and sound does come out of the vst but it is the sound of the vst layered on top of the sound of my keyboard which distorts it oddly.  When I made the track I just dragged the plugin from the right into the tracks so I don't know what type it is. Thanks for your help

Share this post


Link to post
Share on other sites

Unfortunately

20 minutes ago, Gabriel Gorman said:

I just dragged the plugin from the right into the tracks so I don't know what type it is.

this method may be used to create either an instrument track or a audio/MIDI track pair. So really tells one nothing. By default this method displays a screen of options including tracks to create.

 

Regardless, it sounds like you are sending MIDI data back to the keyboard. This may only be done by setting MIDI track output to the keyboard. The easiest way to prevent MIDI from traveling back to the keyboard is turn off all MIDI output devices in preferences.

Share this post


Link to post
Share on other sites

Then again, I may be misunderstanding the problem. It could be an issue with local control on the keyboard.

If this is the case, there are two commands, SendLocalOff and SendLocalOn that go in the [Options] section of %appdata%/Cakewalk Core/TTSSEQ.ini

Read about them here https://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=INI_Files.5.html

Of course, to send command to the keyboard the advice about turning off all MIDI output devices must be ignored.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...