Jump to content
  • 0
India

How to connect MIDI keyboard to Cakewalk?

Question

I have an Alesis Q49 MIDI keyboard. My computer (Windows 10) is able to recognize the device just fine. The keyboard driver is up to date, as I checked the device manager.

In Cakewalk under Preferences > MIDI > Devices, the Q49 is listed there. However, I can't check the checkbox next to Q49 and instead, I get an error saying that the Q49 "doesn't have enough memory available" (Screenshot 1). I also get two other errors which I'm not sure are related or not; one says "Silent buses detected" and that silent bus is "master" (Screenshot 2). The other error I get before Cakewalk opens is "There are no audio devices for the current driver model on your system" (Screenshot 3) which I don't understand. I also have a microphone plugged into my computer (which Windows detects), and (not sure if this makes any difference) in Cakewalk audio recording preferences, I have the driver mode set to ASIO.

This is basically where I'm stuck with setting up the keyboard. Any help will be much appreciated, thank you.

- India

Screenshot 1.JPG

Screenshot 2.JPG

Screenshot 3.JPG

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

For the silent bus, that means that the master bus has not outputs to any active main outs. Is your audio interface profiled in cakewalk. So the master bus needs to be outputted to the main outs 1/2 of your audio interface. 

You may need to define your audio interface first, then hook up your MIDI Keyboard to Cakewalk/sonar/DAW

Share this post


Link to post
Share on other sites
  • 0

The first error is unrelated to the other two.

I have seen a few suggestions as to the cause of the "not enough memory" message. This thread contains a few idea. Not sure there is a single cause for this error.

Errors 2 and 3 are audio device related. In this case, it appears to be a usb connected microphone? The second message is the result of the third. The device either does not have an ASIO driver or the driver is not installed. As a result, Cakewalk cannot communicate with the device. To remedy the third message either chose a different driver mode in preferences ,install the manufacturer supplied ASIO driver or ASIO4All. Note: ASIO4All has been known to cause problems for some users. Problems that can only be fixed by removing ASIO4All from the machine.

Once Cakewalk can communicate with the audio driver, the silent bus error will probably go away.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'm going to guess that Q49 is using a class compliant USB MIDI driver that isn't multi-client.  I have a different Alesis keyboard, but there is a custom Alesis multi-client driver available for it at the Alesis website. I don't see a driver download available for the Q49, so by default it must be using the class compliant driver in Windows.

In that case, if something else on your PC has grabbed your MIDI driver first, you can get that memory error in Cakewalk because the USB MIDI class compliant driver cannot be shared by two applications on the PC at the same time.

Try rebooting your PC, and then don't start any other programs, not even a web browser.  Then start Cakewalk and try to assign the keyboard in Cakewalk preferences. That might work.

But if you still get the memory error, you will have to do some digging. Check in the Windows Task Manager on the "Startup" tab to see the list of programs that autostart when Windows boots. You might find a clue in there if you are not starting  any other programs manually.

http://forum.cakewalk.com/FindPost/3596618

Edited by abacab
  • Like 2

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...