Jump to content
Sign in to follow this  
bobernaut

How to use Numark Virtual DJ with cakewalk?

Recommended Posts

Hello everyone and thanks for reading this! I recently received a Numark Virtual DJ Partymix box as a gift, which is cool, but neither myself nor the tech advisor from Numark knows how to hook this device up to Sonar Professional or Reason. The advisor says he knows it can be done but doesn't know how to actually pull this off as of yet. I can return this to GC for a refund but I only have 9 days left before I am stuck with this thing.

So, I am terribly afraid of jacking around with my settings in Sonar and don't want to blindly mess with everything just to try to make this box work with my set up. BUT, maybe, just maybe, someone here knows how to alter settings in Sonar to allow this thing to be used as an instrument within the software...I hope.

Also, I received this message in my interface while trying to get this to work: Not enough memory. I don't get this because I have 16 GB, more or less and this Serrato lite software that comes with this can't possibly be that big.

I am hoping that someone can help me with some guidance or at least a jumping off point before I get stuck with this box.

Please advise if you can I will deeply appreciate it!

 

bob

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, bobernaut said:

Also, I received this message in my interface while trying to get this to work: Not enough memory. I don't get this because I have 16 GB, more or less and this Serrato lite software that comes with this can't possibly be that big.

I can't tell you anything about your specific hardware.

As for the "Not enough memory" message, I have gotten that many times when SONAR/Cakewalk cannot access a midi device because another program is using it.  In my case, it almost always happens when I an testing a midi device with midi-ox, forget that I didn't close that down, and then boot Sonar/Cakewalk. 

Are you trying to use the DJ hardware as a midi device in SONAR/Cakewalk while other midi software has control of it?  If so, does Cakewalk have the memory issue if you don't have the other software running first?

Maybe someone else has a Numark unit and can give you more thorough advice.  Good luck. 

 

UPDATES: I downloaded the Virtual DJ software and then booted MIDI-OX.  Here's what I got:

  image.png.ae598ca517dc404377fc3854f2d2b16a.png

Then I shut down MIDI-OX, and with the Virtual DJ software still booted, got this when I booted Cakewalk:

image.png.2cf72cad1a90828c7876ccb04010f636.png

Edited by User 905133
to add an update including an image of an error message.

Share this post


Link to post
Share on other sites

Thanks so much, user905133, I really appreciate your effort! Your second message is almost exactly what I got, minus the the device. How much memory does this thing require! No matter what I have tried thus far, which is everything that you mentioned, I still get the "not enough memory" message.

Yes, I am trying to see if either Reason or Sonar can run this as an instrument, I guess you would say. I don't have a great deal of experience or knowledge pertaining to the inner workings of sound cards or Sonar. I guess I am trying to do something which can't be done maybe but it sure seems to me like it ought to be workable.

As I had given up for today and began to shut down, a message popped up asking if I would like to add Virtual DJ to Sonar. After reboot I can detect no change.

Surprisingly, I was able to add the device to Reason but that's all.

Another odd thing is that when I plugged this in today, I was surprised when I heard audio for the first time. However, it is playing independently of Sonar and Reason--just in it's own display. So, the problem is still the same for me. I can't figure out how to get Sonar and Reason to actually "pick up" the Numark device although it did play at first, it now does not (after me messing around with it and trying to get it to run through Sonar and Reason).

Running out of time here to get a refund for this piece.

If you have any further suggestions about this I would love to hear it and thank you for trying to help because I'm not the sharpest with this kind of stuff.

bob

Share this post


Link to post
Share on other sites
Posted (edited)

I know someone who has a larger model and if I weren't hunkered down I'd ask if I can bring my laptop over to see if I can connect it to Cakewalk and try to figure it out.  (I wondered about the possibility after I saw the controller in action like 6 or 8 months ago, but they are out of my budget.)

I don't think the issue is lack of memory in your system. I don't know how that works, but I always assumed the issue was due to some sort of midi device conflict, as id the OS/Software is saying--"Some other software [possibly a device driver] has control of this device, I cannot access it."  

I will have to defer to others with more experienced with such things as control surfaces, devices, etc.

Maybe GC is extending their return policy to 90 or 180 days due to the worldwide pandemic?  

BTW, yesterday I tried the Virtual DJ software a second time, shut it down, and then had the same issue with Cakewalk and my usb keyboard. I did not see the Virtual DJ software in Windows' task manager, so I couldn't kill it to that solved the midi device lock up. I ended up rebooting my PC.

Hmmmm. As a followup test, I just booted the Virtual DJ 2020 software. I did not "Connect" online when it asked, but with the limited feature set, the free software works to play tunes. I then booted Cakewalk and got this:

image.png.ff140c3964682a824c190fd1d6b8d6b9.png

This tells me that the VirtualDJ 2020 software has control of those devices, just like MIDI-OX would--but only for those devices I have selected in MIDI-OX.  I think its a Windows/MIDI device thing. Again, maybe someone with more expertise can explain why and make suggestions.

The only thing I can suggest being totally unfamiliar with DJ devices as controllers (except for Midiman Dm2--something that last worked under Win98SE), is to try using the Numark unit from a PC reboot without running any other music software other than Cakewalk. 

PS: Please note that the memory message is being reported to Cakewalk by Windows.

ADDENDUM: With the free VirtualDJ 2020 software playing two tunes, I booted Cakewalk and had the three MIDI devices locked out. Using Windows' Device Manager, I killed VirtualDJ 2020 [End Task], went to Cakewalk Preferences  and had the usb keyboard locked up, not nanoKontrol.

After rebooting my PC, I tried another test: (1) got VirtualDJ 2020 playing two tunes, (2) started Cakewalk (and got the midi device lockout message), and (3) killed VirtualDJ 2020.  This time, I was able to select my three midi devices from Preferences.

BTW, maybe you can use the controller and software independently and use any audio output it has in Cakewalk.  I'm not sure if the device lockout also affects audio channels. 

Again, I defer to others to explain this and to offer possible suggestions. Maybe my experiences will be helpful. I would be interested in your results, because I have thought about saving up for one of those controllers myself.

image.png.2eceed70e23a539fee540809db5be30d.png

Edited by User 905133
to add the results of an additional test of VirtualDJ 2020 software.

Share this post


Link to post
Share on other sites

I can't thank you enough, User 905133. It seems that we are the only help that's coming I'm afraid. As you have some interest in this piece of junk, I will tell you what has occurred since last time. This won't make much sense but maybe it will help somehow.

Last night, I brought up all things--Sonar, Reason and the piece of junk. Expecting the usual, I hit the "cue" button (I think), and I heard files playing on both sides. It was wonderful. But, it gets better...without even being aware of what I was doing, I played with the jog wheel and it made a scratching sound. I could hardly believe this! I did my best to take notes so that I might discover, later, how I managed to get this to happen.

I unplugged the USB and then plugged it back in and I received a message in the bottom right corner telling me that "A new device has been detected" or something like this. Anyway, It told me that "Partymix" has been installed ( I think ) successfully. Now, that's weird--it actually was something positive in regard to all this. So, quickly, I looked over at the device with the stupid flashing lights and hit the play/pause button and it actually worked as in playing the wave file which was already loaded.

But, could there be more? I moved the jog wheel and it scratched.

Next, I brought up Sonar and as near as I can tell, this is when I lost control over the partymix box. Even after I closed out Sonar (with partymix still up), none of the buttons on the device were responsive. Now, in between and here and there, a variety of pop ups came up from Numark ( I was not online for any of the aforementioned things ). It might be looking like this company wants to lure you in on the cheap side and then, in order to actually use the device beyond just hitting the play button, you have to continue to buy license after license--and they ain't cheap, either. They say that i am a "professional" and therefore need to pay for these licenses because I guess, I am a rap or rock star, making tons of money. Maybe this is not the case but I believe this may be the reason why nothing works--they have disabled nearly everything until (hopefully), you start forking over money for these licenses which then magically enable my interface. Pretty pathetic.

I have not heard back from the so-called Numark tech advisor either. I honestly didn't think he knew anymore about the product than I did, anyway.

 

Thanks for your advice on the virus; you could be right and they may extend that but I don't think that I will hold my breath on this.

Basically, I think, maybe--this may be nothing more than a glorified MP3 player until you pay hundreds of dollars for licenses. And then, I think I might be willing to bet that it still won't work.  I hope you have success trying to figure this out and I do appreciate your help, but I wouldn't blame you if you've had enough. I'll continue to frustrate myself and waste time trying to get something to happen here for a while longer.

thanks,

bob

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...