Jump to content
  • 0
Justin P Brown

Cannot Move Notes

Question

I have recorded a MIDI hi hat track but cannot move the notes in the track pane. The tool will not show the + tool tip on the note, though all the other tools work okay. With the other two drum tracks I have created I am able to see the + tool tip & move notes okay. All the track settings seem to be the same.

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Perhaps a Clip Lock is engaged?  (right-click the clip or look in the Clip pane of the Inspector)

 

 

CL.png

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
5 minutes ago, winkpain said:

Perhaps a Clip Lock is engaged?  (right-click the clip or look in the Clip pane of the Inspector)

 

 

CL.png

The lock is set to Off.

Share this post


Link to post
Share on other sites
  • 0

In the track view to gain access to the notes in a MIDI clip change the edit filter ("A" in the image below) to Notes. This engages the inline piano roll view. When the edit filter is set to Clips, all operations are at the clip level.

Tools.03.1.png

Or use one of the other MIDI views such as the Piano Roll View.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

...Or perhaps you have a different tool selected. Hit "T" to engage Tool window and make sure Smart Tool (arrow on the left) or the Move Tool (crosshairs) are selected in order to move notes in PRV or inline PRV

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, scook said:

In the track view to gain access to the notes in a MIDI clip change the edit filter ("A" in the image below) to notes. This engages the inline piano roll view.

Tools.03.1.png

 

I have that filter set to Notes. I want to move the notes in the track view so I can visually align them with the kick drum track.

Share this post


Link to post
Share on other sites
  • 0

The the data is not locked and the edit filter is set to Notes, it could be the tool selected. I mostly use the smart tool. That said, I think it is easier to work in the full Piano Roll View than the inline view.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, winkpain said:

...Or perhaps you have a different tool selected. Hit "T" to engage Tool window and make sure Smart Tool (arrow on the left) or the Move Tool (crosshairs) are selected in order to move notes in PRV or inline PRV

I have the correct + tool selected. Also, the Smart tool has all selections checked, but doesn't show the move + tool tip when the cursor is hovered over the note, even though the other tool selections work okay.

Share this post


Link to post
Share on other sites
  • 0

Yes. I have found that if I select Fit To Content, where the grid in Inline PRV changes to a dual grey tone & the note lines enlarge to blocks, only then can I select the notes for movement. I don't find this view easy on the eyes though.

Edited by Justin P Brown

Share this post


Link to post
Share on other sites
  • 0

So I have found a work around, but not solved the issue:

I have found that if I select Fit To Content, where the grid in Inline PRV changes to a dual grey tone & the note lines enlarge to blocks, only then can I select the notes for movement. I don't find this view easy on the eyes though.

Thanks for your efforts guys.

Share this post


Link to post
Share on other sites
  • 0

I agree with scook in that I find it way easier to work in the full PRV rather than inline. It's easier to see everything.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Justin P Brown said:

I have recorded a MIDI hi hat track but cannot move the notes in the track pane. The tool will not show the + tool tip on the note, though all the other tools work okay. With the other two drum tracks I have created I am able to see the + tool tip & move notes okay. All the track settings seem to be the same.

Does NUDGE have any effect on the notes? This looks like a good use for it if it does.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

The Move tool will only appear when you hover over the middle third of the note; outside that area, you get tools to change the start and end time of the note. Possibly you're hovering over a different part of the note in this particular track because the notes are longer at the current horizontal zoom level, and when you zoomed vertically, you just happend to hover over the correct area...?

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
31 minutes ago, David Baay said:

The Move tool will only appear when you hover over the middle third of the note; outside that area, you get tools to change the start and end time of the note. Possibly you're hovering over a different part of the note in this particular track because the notes are longer at the current horizontal zoom level, and when you zoomed vertically, you just happend to hover over the correct area...?

It's a hi hat track. I've hovered over all areas of both horizontal & vertical parts; the movement tool tip does not appear, unless I change to Fit To Content. I am using the Inline PRV.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Chappel said:

Does NUDGE have any effect on the notes? This looks like a good use for it if it does.

Yes, NUDGE works okay thanks, but it's useful only for moving a whole clip of notes. Anyway I'm using the work around now, it's convenient enough. Thank you.

Share this post


Link to post
Share on other sites
  • 0

Nudge should also work on selected notes in the Inline PRV. Maybe try moving the clip to a new track; it seems like the existing one has gotten into a bad state somehow.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, David Baay said:

Nudge should also work on selected notes in the Inline PRV. Maybe try moving the clip to a new track; it seems like the existing one has gotten into a bad state somehow.

I tried it with a couple of new tracks & get the same result. There must be a setting I've accidentally changed somehwere.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...