Jump to content
Gill20

can the sensitivity of the SMART grid be adjusted

Recommended Posts

Posted (edited)

more often than not I'm finding myself wanting more or less definition on the grid when Smart Grid is enabled. at the zoom level I need to work at.

alternatively a QUICK way to manually swap from one definition to the next ( ctrl+1 ctrl+2 like in ableton live) would be welcome but this does't seen to be implemented?

Any help appreciated

Edited by Gill20
ommission
  • Great Idea 1

Share this post


Link to post
Share on other sites

p317 manual

"To use a secondary Snap to Grid resolution
By default, Cakewalk uses the global Snap to Grid settings when snap is enabled. However, you can also specify a secondary Snap 
to Grid resolution that is in effect when holding down the N key.
To assign the secondary Snap to Grid settings, hold down the N key while selecting the desired snap settings in the Control Bar’s 
Snap module.

To momentarily apply the secondary Snap to Grid resolution, hold down the N key while dragging or editing data that is snapping to 
the grid. When the N key is released, the main global snap settings are restored.
To swap the primary and secondary Snap to Grid settings, press CTRL+SHIFT+N."

 

Is this what you were looking for?

  • Thanks 1

Share this post


Link to post
Share on other sites
15 hours ago, LarsF said:

p317 manual

"To use a secondary Snap to Grid resolution
By default, Cakewalk uses the global Snap to Grid settings when snap is enabled. However, you can also specify a secondary Snap 
to Grid resolution that is in effect when holding down the N key.
To assign the secondary Snap to Grid settings, hold down the N key while selecting the desired snap settings in the Control Bar’s 
Snap module.

To momentarily apply the secondary Snap to Grid resolution, hold down the N key while dragging or editing data that is snapping to 
the grid. When the N key is released, the main global snap settings are restored.
To swap the primary and secondary Snap to Grid settings, press CTRL+SHIFT+N."

 

Is this what you were looking for?

Thanx for your input - it's not exactly what I'm looking for -

as it is, the settings behind the smart grid behaviour are just not working for me. seeing a 1/8th grid definition when being zoomed so far out is just waste

I would like to adjust how the smart grid operates/decides when to switch from a definition to the next

OR be able to quickly and manually go from one grid definition to the next, like in other daws

Share this post


Link to post
Share on other sites

even assigning ctrl-1 to 1/2
                                  ctrl-2 to 1/4
                                   ctrl3 to 1/8

no change to visible grid

and as a side bug, aim assist re-appears ( I have turned that thing off!)

 

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, Gill20 said:

even assigning ctrl-1 to 1/2
                                  ctrl-2 to 1/4
                                   ctrl3 to 1/8

no change to visible grid

and as a side bug, aim assist re-appears ( I have turned that thing off!)

 

I have not tried this, but maybe you could try switching grid configurations via Workspaces (or have you tried that)? I'd try but I am sorting out some of my own stuff.

EDIT:  references to and images showing a different grid removed to save space; evidently,  Workspaces cannot be used for this issue. See discussion below.

8 hours ago, winkpain said:

I believe this is one of those issues that just gets referred to the "feature request" bin.

There are no Smart Grid settings that I know of. I have brought up this same point here elsewhere sometime before and got no response leading me anywhere to change it.

 

Edited by User 905133
to remove content related to settings for the wrong grid

Share this post


Link to post
Share on other sites

no this is not what I'm refering to. Let's use images :

in arrangement view SMART grid is enabled.

in the first image to the left (4.jpg) I'm seeing the grid lines being at a resolution of a 1/4 note
in the second image I barelly zoom in, and SMART grid decides  to switch the grid lines to a resolution of 1/8th note, way way too early imho

there must be a way to adjust the sensitivity of the SMART grid no?

OR alternatively allow the user to, manually and dynamically, switch to whatever grid line definition, WITHOUT invoquing the snap menu wich is a total workflow killer

 

 

4.jpg

8.jpg

Share this post


Link to post
Share on other sites

Sorry. I was really just trying to suggest you try Workspaces if you haven't done that already. 

As an afterthought, I tried seeing if the grid resolution settings in the PRV would get saved to and restored from a customized Workspace.  It was just as a test-of-concept.  I have had success configuring many different settings. I have also had some settings that I couldn't get to work the way I wanted. 

However, now that I see what you want (thanks for the images; it helps!), I am not sure if switching Workspaces as needed would give you the sensitivity you want.

Maybe someone else knows of a setting or method that would work for you.

 

Share this post


Link to post
Share on other sites

I believe this is one of those issues that just gets referred to the "feature request" bin.

There are no Smart Grid settings that I know of. I have brought up this same point here elsewhere sometime before and got no response leading me anywhere to change it.

I absolutely agree: the "smart" grid changes snap/grid resolutions at very inappropriate zoom levels rendering it a hindrance rather than a help to workflow.  In any case, such a tool should have settings available for modification per user preference.  There's nothing smart about a one-size-(that doesn't)-fit-all tool

 

.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
10 hours ago, winkpain said:

I believe this is one of those issues that just gets referred to the "feature request" bin.

There are no Smart Grid settings that I know of. I have brought up this same point here elsewhere sometime before and got no response leading me anywhere to change it.

I absolutely agree: the "smart" grid changes snap/grid resolutions at very inappropriate zoom levels rendering it a hindrance rather than a help to workflow.  In any case, such a tool should have settings available for modification per user preference.  There's nothing smart about a one-size-(that doesn't)-fit-all tool

 

.

Agreed. More aggravating to this workflow killer is that one of the rare menus that doesn't seem to be bindable to a keyboard shortcut IS the Snap/Grid options menu.

This menu was bindable in prior versions of Sonar (i had it bind to B back in sonar 8.5) and I was using it a lot.

Without any options to manually & dynamically go back and forth from one grid definition to the next (ctrl+1 & ctrl+2 in Live for ex), workflow speed is greatly reduced

 

Share this post


Link to post
Share on other sites

I agree the Smart Grid goes to finer resolutions too quickly, and it would be really nice to be able to adjust the relationship of resolution to zoom level. That's one reason I've never used it much.

But I checked, and it is possible to disable snap in one or both  of the primary and secondary snap resolution settings, and use Ctrl+Shift+N  (or your preferred keybinding for 'Swap primary and secondary snap settings') to change between two grid resolutions while leaving snap disabled.

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, David Baay said:

I agree the Smart Grid goes to finer resolutions too quickly, and it would be really nice to be able to adjust the relationship of resolution to zoom level. That's one reason I've never used it much.

But I checked, and it is possible to disable snap in one or both  of the primary and secondary snap resolution settings, and use Ctrl+Shift+N  (or your preferred keybinding for 'Swap primary and secondary snap settings') to change between two grid resolutions while leaving snap disabled.

it's better than nothing thank you. Trully hopes this gets addressed though as it is really a nuisance over time

Share this post


Link to post
Share on other sites
3 hours ago, David Baay said:

I agree the Smart Grid goes to finer resolutions too quickly, and it would be really nice to be able to adjust the relationship of resolution to zoom level. That's one reason I've never used it much.

But I checked, and it is possible to disable snap in one or both  of the primary and secondary snap resolution settings, and use Ctrl+Shift+N  (or your preferred keybinding for 'Swap primary and secondary snap settings') to change between two grid resolutions while leaving snap disabled.

btw a prefered setting for the secondary snap setting doesn't seem to recall when closing and re-opening sonar

is this normal?

Share this post


Link to post
Share on other sites

Snap settings are project-specific unless you're using a Workspace. With Workspaces set to 'None', saving the project should preserve the settings for that project. I don't use Workspaces, so can't verify that's working.

Share this post


Link to post
Share on other sites
Posted (edited)
7 minutes ago, David Baay said:

Snap settings are project-specific unless you're using a Workspace. With Workspaces set to 'None', saving the project should preserve the settings for that project. I don't use Workspaces, so can't verify that's working.

thank you for the suggestion all in all it seems like an intricate workaround to address a simple problem, just allowing users to synamically change the grid on the fly  with TWO commands would just solve it all really

  and I tried to save a project with a specific secondary snap setting and then re-open it, same issue, secondary snap reverts to an oddly unusable "1tick" definition...

either way, thank you for the input.

 

Edited by Gill20
wording

Share this post


Link to post
Share on other sites

The first project I tried did have secondary snap defaulted to 1 tick, but after changing it to a 16th and saving/closing the project,  the setting was restored on re-opening. I even opened another project with different snap settings in between, and it worked as expected. You're certain you don't have a Workspace enabled.

Share this post


Link to post
Share on other sites
4 hours ago, David Baay said:

The first project I tried did have secondary snap defaulted to 1 tick, but after changing it to a 16th and saving/closing the project,  the setting was restored on re-opening. I even opened another project with different snap settings in between, and it worked as expected. You're certain you don't have a Workspace enabled.

when I press "workspace" on the top right of the UI, a dropdown menu appears with "none" ticked

Share this post


Link to post
Share on other sites
13 hours ago, David Baay said:

I'm attaching a project that has primary and secondary snap set at an 8th and 8th triplet. Snap is disabled for both, but the grid should change with Ctrl+Shift+N. Check if it works for you.

Primary-Secondary Snap Grid Demo.cwp 158.59 kB · 1 download

thanx for this

Yes, this one works

I don't know what I'm doing wrong on my end but I'll further experiment

Share this post


Link to post
Share on other sites

It occurs to me that the first step will be to disable the Smart Grid option if you haven't already done that.  It's enabled by default in the 'Basic' project template.

Share this post


Link to post
Share on other sites

Thank you sir I will try this

2 hours ago, David Baay said:

It occurs to me that the first step will be to disable the Smart Grid option if you haven't already done that.  It's enabled by default in the 'Basic' project template.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...