Jump to content
Jana Cole

A dropout has stopped the audio engine

Recommended Posts

I'm getting this error message:

"A dropout has stopped the audio engine. (1)"

At the link below, error 1 says: "Audio processing took longer than the buffers allotted time slice. Increase the Buffer Size value in Edit > Preferences > Audio - Driver Settings.
http://www.cakewalk.com/Documentation?product=Cakewalk&language=3&help=0x20280

The slider for that in Driver Settings is greyed out. I closed and restarted Cakewalk, it's still greyed out. So, what am I missing? I'm using Play (East West Composer Cloud). I'm trying to hear a violin sound. Cakewalk's synth piano sound works fine.

buffer size greyed out 1.png

 

buffer size greyed out 2.png

Share this post


Link to post
Share on other sites

I looks like your using the built in Realtek audio device.  You may have to go into the windows settings or the Realtek driver settings to adjust the buffer if it lets you do that. The built in audio devices are generally not very reliable for audio workstation stuff.

  • Like 2

Share this post


Link to post
Share on other sites
27 minutes ago, reginaldStjohn said:

I looks like your using the built in Realtek audio device.  You may have to go into the windows settings or the Realtek driver settings to adjust the buffer if it lets you do that. The built in audio devices are generally not very reliable for audio workstation stuff.

How could I set this up to make it the most reliable? There's a way I can change the audio device? What would I need to do?

Share this post


Link to post
Share on other sites

Hi Jana,

In order to make your DAW more reliable you will need to get a better sound card such as a Focusrite, Presonus, M-Audio, etc. 

Kind regards,

tecknot

  • Great Idea 1

Share this post


Link to post
Share on other sites

The Mixing Latency Buffer Size slider is greyed out because the selected driver mode does offer an adjustment.

If you are stuck with Realtek, try the other driver modes (except for ASIO). Finally could also try ASIO4All, a wrapper for the WDM driver.

 

Share this post


Link to post
Share on other sites

It's also worth investigating whether an ASIO driver is available for your Realtek sound card, sometimes it is. Check with Realtek.

Share this post


Link to post
Share on other sites

The only ASIO I know of from Realtek is a buggy mess. Can't recommend installing it.

 

  • Like 1

Share this post


Link to post
Share on other sites

I've got my orchestral instruments working now in Play. I installed ASIO4All.

I'm thinking, based on all your posts, that at some point I should invest in a high-end laptop designed for this kind of work. 

Thanks again for the help.

Share this post


Link to post
Share on other sites

First get a decent audio interface designed for DAW use with a factory supplied ASIO driver.

ASIO4All is loading the Realtek WDM driver (which you could run directly from CbB using driver mode WDM) with some extra buffers presenting it to the DAW as an ASIO driver.

If you do purchase an audio interface with a real ASIO driver you will need to uninstall ASIO4All to prevent conflicts with the real ASIO driver.

  • Great Idea 1

Share this post


Link to post
Share on other sites
On 3/5/2020 at 1:58 PM, abacab said:

 

On-board Realtek audio devices are not designed for audio recording.

 

The OP isn't having problems with audio recording. They're getting an audio engine stall with an error message while playing a VSTi.

Game audio is actually a demanding application for an audio CODEC, and the Realtek chip has a bit of a starting advantage hardware-wise by being directly connected on the motherboard rather than through a USB port.

There is no practical reason that Cakewalk should not be able to play a violin sound through a given sound device without crapping out when a game can play an explosion sound through the same device without crapping out.

In my opinion, unless someone is recording audio into their DAW computer, it is not strictly necessary to buy an external device which would be used only for sound playback. The biggest reason not to bother trying to use onboard audio facilities for DAW recording work is that the input is usually a flimsy unbalanced line level 1/8" jack. You'll spend all your time trying not to get it to hum, clip, hiss and cut out. But if you're not recording audio, and plenty of EDM and scoring music is made without ever touching a microphone, you don't need a fancy audio device.

I have some suggestions for changing the settings in Cakewalk to help it not drop out when playing virtual instruments.

Check in Audio/Playback and Recording and see what Driver Mode you are set to. Cakewalk only allows changing the buffers slider if you are in the WDM/KS or WASAPI/Exclusive modes, so if you are in WASAPI/Shared mode, yes, it will be greyed out. The best mode for running with a built-in sound device is WASAPI/Exclusive. You can achieve lower latency for soft synth playback in that mode, and you can also move the slider to set the latency a little higher to prevent Cakewalk from dropping out.

  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, Starship Krupa said:

The OP isn't having problems with audio recording.

My bad. Technically I should have said "real-time" audio recording. The mic input is designed for a mic (cheap), not an instrument. No decent preamp included.

I also realize the OP was attempting to use the East/West Composer Cloud for playback, so I was attempting to guide them to a better solution for their sound. Anybody expecting quality results from that probably should have a professional audio interface, rather than RealTek.

I use ASIO4ALL/Realtek on my laptop, so I am familiar with that, and I adjust my expectations accordingly. But would I recommend it to a serious user. No. (my main DAW is a desktop with pro interface.

Also game audio is not real-time. Unless you are talking player to player coms. The game audio is pre-recorded and buffered as needed for playback, so it should not have any interruptions.

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...