Jump to content
kevmsmith81

Audio dropouts making Cakewalk unusable.

Recommended Posts

20 minutes ago, abacab said:

Did you give LatencyMon a try yet?

I downloaded it, but I didn't get back to my PC until quite late last night so I've not done the test as yet.

Share this post


Link to post
Share on other sites

I have now done the test.   Apparently my system should be suitable for handling real time audio and other tasks without dropouts.

Share this post


Link to post
Share on other sites
8 hours ago, Rod L. Short said:

The Octopre is the master and the 18i20 is clocked to the Octopre. So, I'm wondering if my Rec and PB Timing need to be set to the ADAT inputs and outputs? Or, does any of this make any difference at all? 

The Octopre is a standalone pre-amp with no direct connection to the DAW, right? In that case you can only set Timing Masters to channels of the slaved 18i20. That's how I run my interface when slaving to an Alesis QSR  (because the Alesis didn't like being a slave) . Works fine. The only limitation is that Cakewalk can't force a clock rate change when you load a project that includes audio recorded at a different clock rate.

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, kevmsmith81 said:

I have now done the test.   Apparently my system should be suitable for handling real time audio and other tasks without dropouts.

How 'suitable'? IIRC, Latencymon labels anything under 1000-1500us (1-1.5ms) as 'suitable', though that's not ideal for a DAW that's running a buffer on the same order of magnitude. That said, moderately-high-but-stable (say 400-500) is better than usually-low-but-spiking (150 with spikes to 1000). And you need to let it run for a while to see if anything is causing spikes.

Did you try the Config File  reset?

  • Like 1

Share this post


Link to post
Share on other sites

On a laptop, some WiFi drivers really put a whammy on streaming audio proccessing. Try temporarily disabling WiFi while in Cakewalk.  Also, consider temporarily disabling antivirus during Cakewalk sessions.

  • Like 1

Share this post


Link to post
Share on other sites

I totally understand the advice about system tuning being given, as that is fundamental to good audio performance, and essential to any DAW.

But I am a bit cautious to rush to blame the hardware in this case, because the OP stated in the first post that it was only happening with Cakewalk, and not the other DAW he tested with.

Could something actually have changed in Cakewalk recently to affect performance? Just asking for a friend, so please don't flame me ... ;)

 

Share this post


Link to post
Share on other sites

For my part, there is no rushing to judgement. I'm just suggesting logical troubleshooting steps, including making changes to the Cakewalk configuration.

The current release is working too well for too many users to conclude that the update has an inherent issue that's independent of the environment it's running in or the configuration of Cakewalk or project files. 

Of course the ultimate troubleshooting step would be to roll back the update, but that isn't possible with the current installation model unless you've prepared in advance by backing up or using scook's utility for managing versions.

I believe there were some changes to WASAPI driver mode related to sharing drivers, but the OP is using ASIO.

I do see more dropouts on my laptop, but I attribute that to using WASAPI shared mode on a low-spec machine with years of accumulated software bloat (dual-core company Lenovo). And it's no worse in this release than it's ever been. It's fine if I only use it for playback with the buffer at 10-20ms, but down at 3ms where you would want it for real-time performance of soft synths or input monitoring , it's dropout city. But I can see the DPC spikes and CPU hits from other processes that cause it, and if I go out of my way to do a clean boot ith WIFI and Bluetooth disabled, and switch to WASAPI Exclusive mode, it's quite stable at 3ms.

This reminds me... there was a problem with WASAPI driver mode at 44.1 kHz in a release late last year that I never encountered because I run at 48kHz. There's no indication that anything like that has resurfaced, but it might be worth changing sample rates (in a project with no recorded audio) as another general troubleshooting step, regardless of what driver mode you use.

Share this post


Link to post
Share on other sites
24 minutes ago, David Baay said:

For my part, there is no rushing to judgement. I'm just suggesting logical troubleshooting steps, including making changes to the Cakewalk configuration.

The current release is working too well for too many users to conclude that the update has an inherent issue that's independent of the environment it's running in or the configuration of Cakewalk or project files. 

Of course the ultimate troubleshooting step would be to roll back the update, but that isn't possible with the current installation model unless you've prepared in advance by backing up or using scook's utility for managing versions.

I believe there were some changes to WASAPI driver mode related to sharing drivers, but the OP is using ASIO.

I do see more dropouts on my laptop, but I attribute that to using WASAPI shared mode on a low-spec machine with years of accumulated software bloat (dual-core company Lenovo). And it's no worse in this release than it's ever been. It's fine if I only use it for playback with the buffer at 10-20ms, but down at 3ms where you would want it for real-time performance of soft synths or input monitoring , it's dropout city. But I can see the DPC spikes and CPU hits from other processes that cause it, and if I go out of my way to do a clean boot ith WIFI and Bluetooth disabled, and switch to WASAPI Exclusive mode, it's quite stable at 3ms.

This reminds me... there was a problem with WASAPI driver mode at 44.1 kHz in a release late last year that I never encountered because I run at 48kHz. There's no indication that anything like that has resurfaced, but it might be worth changing sample rates (in a project with no recorded audio) as another general troubleshooting step, regardless of what driver mode you use.

Running Cakewalk in a recent laptop (i5 8250u, Mx150, 8 DDR4) under Win 10 in Wasapi Shared Mode (48 Khz, 24 bit). I am having tons of dropouts while testing VST plugins, no issues with other DAW on the same machine.  Sincerely and with no ranting, the audio engine in Cakewalk seems very fragile and unstable for me.

Share this post


Link to post
Share on other sites

What about WASAPI Exclusive? I can't vouch for Cakewalk's performance in WASAPI Shared mode in an otherwise ideally configured environment because I've never used it that way. When I wanted to see what WASAPI was capable of at low buffer sizes, I ran it in Exclusive mode. In fact, IIRC, the lowest buffer settings aren't even available in Shared mode...?

Share this post


Link to post
Share on other sites
1 hour ago, David Baay said:

For my part, there is no rushing to judgement. I'm just suggesting logical troubleshooting steps, including making changes to the Cakewalk configuration.

The current release is working too well for too many users to conclude that the update has an inherent issue that's independent of the environment it's running in or the configuration of Cakewalk or project files.

If I was going to judge the hardware being used, I believe that it is fair to say that starting with a mobile processor at 2Ghz core frequency definitely limits the possibilities. Could be that something in Cakewalk "slightly" tilted the performance margin in such a way that someone running a DAW at 3-4 Ghz wouldn't notice.

Share this post


Link to post
Share on other sites
1 hour ago, abacab said:

If I was going to judge the hardware being used, I believe that it is fair to say that starting with a mobile processor at 2Ghz core frequency definitely limits the possibilities. Could be that something in Cakewalk "slightly" tilted the performance margin in such a way that someone running a DAW at 3-4 Ghz wouldn't notice.

That is of course possible, and may explain why I get this issue with Cakewalk, but can use Reaper and Mixbus without issue.  Which I guess means I am going to have to seriously think about just switching to Reaper.

Not ideal, but buying a new computer isn't an option at this point.

Share this post


Link to post
Share on other sites

It might also be worth checking these values in your configuration:

image.png.ef2c694f26c6400a798b7a9a0b6fc2a4.png

 

  • Like 1

Share this post


Link to post
Share on other sites

Cakewalk seems to be the only DAW with this problem. I haven't had any problems on this topic with other DAW's. Yet, I still prefer Cakewalk over them probably because I'm that comfortable using it, and know my way around it. I'm just gonna throw it out there - I've come to realize that when ever I remove the "Help Module" from the bottom right screen, and totally get rid of it,  this problem becomes absolute my side.  It could be my system, I don't know (i7 4th Gen, 16Gig ram, 2TB hardrive,  4.2ghz quad-core intel core i7CPU.) So, this confuses me too. Could it be that there's too much clutter some where on it's engine in the workspace? Some sort of outdated file source? This often happens when the CPU or RAM get's overloaded and does not refresh quick enough. This only started happening with the 64bit version on my side.  I don't recall dealing with this in the 32it version. 

 

  • Like 1

Share this post


Link to post
Share on other sites

Just to explain a bit about some other daws

- Reaper adds asio buffer sizes to process as soon as any plugin latency is reported, multiple even, just add as plugins report. So having 128 or 256 samples that means first plugin with 1 sample latency or more add one more buffer.

- StudioOne the same, has minimum extra 64 samples processing buffer

You get longer roundtrip latency in these daws due to this, but maybe higher threshold to crackles.

 

First thing I noticed running Reaper 10 years ago - I had to go down to 64 samples to get acceptable roundtrip latency while recording.

So this could be one reason that margins are lower in Cakewalk - but get better roundtrip latency a lot of the time.

 

I tested various audio interfaces 10 years ago as I got my current daw computer - firewire as first.

Sonar freaked out with just one VST instrument unless I increased asio buffer size on step from what I used with rme.

Audio ran fine, just VST instruments seem to have some special routing going making it vulnerable.

But freeze in Cakewalk is the best implementation among all daws, giving you audio on all outputs etc - so no problem using that if project grows to crackles of some sort.

Having no crackle issues, RME HDSP 9632 64 samples asio buffer and i7-860 2.8 GHz, even with largest projects I have now 80-85 tracks - but run majority external midi gear since 6-7 years back. I just like hardware at my fingers more than mouse click-fest.

I just found that I don't need to run instruments live constantly - so over all tip is to test if freezing making audio of it all helps any crackles you have. Unfreezing and re-recording is so smooth in Cakewalk I would not think twice doing that if having problem.

 

So how much is due to VST instruments running live - just test if way forward freezing them changes anything - is my tip. Unless recording a specific instrument right now - no need to use resources on live - especially not in Cakewalk.

Share this post


Link to post
Share on other sites
8 hours ago, _Will_ said:

Cakewalk seems to be the only DAW with this problem. I haven't had any problems on this topic with other DAW's. Yet, I still prefer Cakewalk over them probably because I'm that comfortable using it, and know my way around it. I'm just gonna throw it out there - I've come to realize that when ever I remove the "Help Module" from the bottom right screen, and totally get rid of it,  this problem becomes absolute my side.  It could be my system, I don't know (i7 4th Gen, 16Gig ram, 2TB hardrive,  4.2ghz quad-core intel core i7CPU.) So, this confuses me too. Could it be that there's too much clutter some where on it's engine in the workspace? Some sort of outdated file source? This often happens when the CPU or RAM get's overloaded and does not refresh quick enough. This only started happening with the 64bit version on my side.  I don't recall dealing with this in the 32it version. 

 

"...this problem becomes absolute my side.."   Can I just clarify, do you mean that audio processing is not as good when you close the Help module?  Is that 100% the case every time you open CW and close the Help module?

Share this post


Link to post
Share on other sites

I feel the OP's pain. I love Cakewalk but I've always had occasional problems with dropouts and crashes and the latency at which I operate has always been higher than I wanted it to be. I have an old MOTU Firewire 8pre that I bought somewhere around 2005. The performance was such that I was forced to change how I record because input monitoring was a non-starter for me.  Since other people didn't seem to have these issues I always assumed it was my machine, an aging but oh-so-reliable  X58-based i7/970 system I built in 2011, and I just pressed on. I loved the sounds I got out of that thing though! The MOTU ran okay in Reaper, but I hate using Reaper. 

I never really solved the latency issue on that system, but I did discover through many Windows updates that Microsoft loves to reset all your carefully tuned system parameters to values they want them set to. Window sometimes (but not always!) likes to re-enable power management for USB and CPUs, and all the built in audio devices you don't use magically turned back on.  I also learned that I must uninstall and re-install the MOTU device drivers whenever the Windows runs an update. It was said that MOTU boxes were targeted at Mac's first and foremost and I don't know that for sure but I believe it. I dreaded both Windows and Cakewalk updates. They almost always introduced a new round of crashing and instability.

This last January I picked up a Ryzen 9 3950x and a Gigabty x570 AORUS Master and the parts to go with it and built a new system, but I kept  my old MOTU. Stability was good out of the box, but the latency issues remained. Maybe I could get a bit more juice out of the old girl, but not much. So I picked up a new Audient ID22 this week and got it yesterday. BLAM. All problems solved! I had never seen the heady heights of sub-64 sample settings before, such a pleasure to have everything work so well. Fast, stable, great sounding. No crashes. We'll see what the next update brings but I'm very happy with things right now.

Cakewalk isn't perfect but I've personally discovered that your interface hardware chain (firewire, tb, usb, etc)  and the quality of your drivers are an under-appreciated factor in your audio setup's stability and efficiency. I know the OP has ruled out new hardware, and I get that, it took me a long time to justify my recent hardware refreshes, but keep in mind that current software development is done in parallel with current hardware development and both sides of the equation matter.

 

  • Like 1

Share this post


Link to post
Share on other sites
14 hours ago, Skyline_UK said:

"...this problem becomes absolute my side.."   Can I just clarify, do you mean that audio processing is not as good when you close the Help module?  Is that 100% the case every time you open CW and close the Help module?

No, Absolute as in "Free of restrictions." Meaning, the problem goes away - as in no more audio dropouts. Like I said, it could be that my system or "O.S" don't read the file correctly. A few clutter sitting some where in the 64bit version of the DAW maybe. I don't know. That's why it is very important to make sure the "Use Analytics to improve Cakewalk" box is ticked under "Preferences."

Screenshot 03-03-2020 00.20.33.png

  • Like 2

Share this post


Link to post
Share on other sites

This new update is killing me. I have had dropouts before and they were all cured with the next upgrade. Absolutely nothing has changed. I use ASIO driver. It isn’t worth getting into. One day it will be cured. I never use a wireless router with this machine. It had been rock solid for a month before this update.

I don’t know why I’m complaining. Well, maybe my big mouth was telling everyone how rock solid Cakewalk has been. I agree with some of the people that said Reaper didn’t have this issue. 

Share this post


Link to post
Share on other sites

Buenas  activa la memoria cache  de lectura y ajustala  yo la puse a 1024 y perfecto

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...