Jump to content
  • 0
Jana Cole

There are no audio devices for the current driver

Question

I'm new to Cakewalk, but not to creating music or using apps. My challenge is setting up virtual instruments in Cakewalk. I know it's not set up right, because Cakewalk tells me every time I open it (screen shot below), and I'm getting no sound at all. For the last couple of weeks, I've been following instructions on various videos, and I've read the cakewalk documentation and followed those directions, and nothing is working.

I've used FL Studio, Sibelius and Mulab, but I don't remember having to do the type of settings as in Cakewalk, and I don't understand how this works. How do I know what resources on my laptop are available to Cakewalk? What's a "driver model" (first screen shot below)? Apparently, Cakewalk isn't seeing any audio devices (screenshot below). Does it have to, since I'm using only virtual instruments? 

I'm using EastWest Composer Cloud. I'm able to select instruments and open the instrument and click on the piano keyboard, but the keys don't move and there's no sound.

It's hard to know what to ask, but I have several screen shots below. I think I just need to know how to set this up. Thanks in advance for any help or suggestions you can offer.

I get this message every time I open Cakewalk

message on opening app - no audio devices.png

 

 

Preferences/Audio/Devices

audio devices.png

 

 

Preferences/Audio/Driver Settings

driver settings.png

 

 

Preferences/Audio/Playback and Recording

audio playback and recording.png

 

 

Preferences/Midi/Devices

midi devices.png

 

 

Preferences/Midi/Playback and Recording

midi playback and recording.png

 

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

It appears that CbB does not see any ASIO driver.

Usually ASIO drivers are supplied by the hardware manufacturer and must be installed before using the audio interface.

When using a device without an ASIO driver such as the internal sound chip in the PC (n.b. the RealTek ASIO driver is buggy and should be avoided) a differenT driver mode must be selected. This is set on in Audio > Playback and Recording preferences shown in the image above. For Win10, the WASAPI modes are best choice. For other OSes try WDM then MME.

 

Share this post


Link to post
Share on other sites
  • 0
36 minutes ago, scook said:

It appears that CbB does not see any ASIO driver.

Usually ASIO drivers are supplied by the hardware manufacturer and must be installed before using the audio interface.

When using a device without an ASIO driver such as the internal sound chip in the PC (n.b. the RealTek ASIO driver is buggy and should be avoided) a differenT driver mode must be selected. This is set on in Audio > Playback and Recording preferences shown in the image above. For Win10, the WASAPI modes are best choice. For other OSes try WDM then MME.

 

Thank you. I changed it to WASAPI shared, and the message is gone. I've got an instrument up with a couple of MIDI notes. When I play the track, the meter registers the notes, but I still don't hear them. So now I'll start working on how to route the output ...

Edited by Jana Cole

Share this post


Link to post
Share on other sites
  • 0

After you checked all the necessary boxes (driver mode, output driver, playback timing master, etc.) make sure that your Master Bus has its output set to your audio output device.

Kind regards,

tecknot

Share this post


Link to post
Share on other sites
  • 0
20 minutes ago, tecknot said:

After you checked all the necessary boxes (driver mode, output driver, playback timing master, etc.) make sure that your Master Bus has its output set to your audio output device.

Kind regards,

tecknot

I checked it all, I see how it all connects up. Finally !!!!! Some sound!!!!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...