Jump to content
  • 1
Sven

Volume problems with Bandlab using Kontakt

Question

I've seen other users ask about this but I haven't seen an answer that solves the problem.   When  I add a Kontakt plugin into Bandlab it works fine no matter what the particular plug is.   If I immediately record it in Bandlab all is fine.

Later it seems like all bets are off.  The playback of the original recording is generally fine but there are intermittent issues doing other tasks.  If I just click on the MIDI plug in again at a later point and play my input keyboard I may hear nothing.  I can increase the volume in the plugin and usually hear it again but then later the volume jumps up to an extremely loud volume.   Sometimes when you're playing a part the volume drops out but will sound fine again if your press "Play" in SONAR first.

I saw this listed as a solution in a couple of posts but it doesn't seem to solve the problem:

image.png.b6ce26e3f6b888e2c82833c02b20c3f5.png

Any thoughts?

 

  • Like 1

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

The above suggestion about disabling CbB's "Zero Controllers When Play Stops" behavior, deals with situations where for some reason, the instrument's volume is tied to the Mod Wheel, so when CbB zeroes out the controllers, after playback, the result for those situations is that the instrument volume goes down to nothing.

In regular situations, that issue would not arise - meaning that with Zero Controllers checked, for projects where instruments do NOT have volume tied to mod wheel, there is no issue.

Give the above a try, and see if it address your issues - just be aware that your controllers will all keep their last value when playback is stopped, once you remove that check for the Zero Controllers parameter.

Bob Bone

 

Share this post


Link to post
Share on other sites
  • 0

In addiiton to disabling Zero Controllers, proactively set a MIDI Volume level in the MIDI track (or on the MIDI tab of the Track Inspector for an Instrument track). By default MIDI volume is disabled, and the synth volume is free to change in response to CC7 messages from other sources like your keyboard controller. that can stil hapen, but every time you start playback, Cakewalk will reset it.

Also, to prevent stray MIDI messages from sources other than your controller from being echoed to Kontakt, always set the Input  of the track to the specific port and channel on which your keyboard is sending rather than Omni - All.

If all else fails, create flatline MIDI controller envelopes on the track for CC1 Modulation, CC7 Volume, and CC11 Expression.

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, David Baay said:

In addiiton to disabling Zero Controllers, proactively set a MIDI Volume level in the MIDI track (or on the MIDI tab of the Track Inspector for an Instrument track). By default MIDI volume is disabled, and the synth volume is free to change in response to CC7 messages from other sources like your keyboard controller. that can stil hapen, but every time you start playback, Cakewalk will reset it.

Also, to prevent stray MIDI messages from sources other than your controller from being echoed to Kontakt, always set the Input  of the track to the specific port and channel on which your keyboard is sending rather than Omni - All.

If all else fails, create flatline MIDI controller envelopes on the track for CC1 Modulation, CC7 Volume, and CC11 Expression.

 

 

 

 

I have never had occasion where any sort of midi bleed or errant echo has occurred between midi tracks on any of my computers, over the years, and I always have each midi track set to None (Omni), as the specification of the associated soft synth in the midi track's Output parameter sends any midi data for that midi track to that soft synth specified in the Output parameter.  When the desired midi track is in focus, and/or its Midi Echo Input is On, midi data for that track is properly sent to that soft synth.  If any additional midi tracks have their Midi Input Echo turned On, then with the Input set to None (Omni), then triggered notes from any midi controller will still properly be sent to each track's associated soft synth, as specified in each of those track's Output parameter.

The only time I would actually specify specific midi controllers for midi tracks, is if I were to be recording multiple midi controllers at the same time, such as simultaneously wanting to record my playing perhaps strings on one midi controller, and perhaps some sort of lead sound on a different midi controller, but ONLY if I were recording myself playing both midi controllers at the same time - which for recording I pretty much would never do.

There is nothing actually 'wrong' with specifying a specific midi controller in a midi track's Input parameter, I just do not find it necessary for proper recording of a single midi controller for any of my midi tracks. :) 

Bob Bone

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Robert Bone said:

There is nothing actually 'wrong' with specifying a specific midi controller in a midi track's Input parameter, I just do not find it necessary for proper recording of a single midi controller for any of my midi tracks.

Where people often get in trouble is when they using MIDI-generating plugins like Cthulu. If a track is set to Omni, it will respond to plugins generating or passing thru MIDI from the track driving them. Like you (apparently), I don't use such plugins, but I still consider it a 'best practice' to limit a track to respond to a specific source, and always make it a point to do that when setting up a new track.

Share this post


Link to post
Share on other sites
  • 0

I still haven't been able to solve this problem but I can at least say what doesn't work.  I tried any solution I've seen on forums or in this thread without success.  Here's what I do know:

This only happens with SONAR using Kontakt plugins.  It has the some same problem regardless of which plugin is used.  The volume suddenly disappears during playback or monitoring.

Unchecking  SONAR MIDI settings "Zero controllers when play stop" doesn't seem to change anything (or perhaps it does...please read on...).

I only use the KeyRig 49 as an input device and nothing else:

image.png.2504b0017f8446cef61eec1593106548.png

 

Changing the Kontakt instrument  Options to uncheck  the two controller options seems to have no effect.

It makes no difference if you use OMNI for the MIDI input channel or select a specific channel number.

When you first insert any Kontakt plugin everything sounds correct whether you use the mouse on the plugin's keyboard or use an external MIDI keyboard.    The volume disappear after a seeming random amount of time even if you don't start recording or move the transport.  It's like a time bomb waiting to create almost complete silence of anything you input.  If the master fader in Kontakt is at 1.76 you will not hear almost any volume.  If you turn the master fader up to 36.00 and do nothing else you will again hear the volume normally again.  It may sound extremely loud at some future point in time after doing this.

If you leave the volume after 1.76 but click 'X' to close the program and then immediately insert it in again the volume (usually) magically is restored to normal.  Again, all this happens without recording or using the SONAR transport.  

When it's "happy" the MIDI keyboard volume and the audio channel associated with it via "insert soft synth" show normal volume levels.  When it's quiet and "not happy" the MIDI input volume appears the same but now the audio channel shows a slight volume but it is now dramatically reduced.  Removing the plugin and inserting it again usually makes everything sound perfect again.  You can even record a track and freeze it if you're lucky.

This is the MIDI event list when it's not working:

image.thumb.png.772d00de5b7ec1972f4d3076e08850c5.png

 

I said that turning of the instrument Controller check boxes has no effect but that may not be true.  If I turn them off nothing happens immediately.  But if I remove the plugin and reinsert it again having unchecked those boxes it will sound okay again.  If I don't uncheck them you may not hear the normal volume after reinserting the plugin.

image.png.20524a95492e89774b6adbd7a67f2986.png

 

I'm not a MIDI expert but I gather there's a volume control request being sent to my MIDI input channel for some reason from some other place.   Perhaps someone can advice me where this might be coming from and how to prevent it?

Thanks again.

 

 

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Sven said:

This is the MIDI event list when it's not working:

image.thumb.png.772d00de5b7ec1972f4d3076e08850c5.png

 

Does it always seem to happen around the 40-45 range?  If so, perhaps its a dirty pot?  Just a guess because I have had something similar with one of my keyboards. On the other hand, if it only happens with some software synths, perhaps its not mechanical. Maybe it has to do with the software's mapping of CC7?

Edited by User 905133

Share this post


Link to post
Share on other sites
  • 0

It's an ancient keyboard but I'm not sure about a dirty pot being the problem.   I can try another MIDI input device leaving this keyboard out of the equation and report back.

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I actually don't think it's the keyboard.  Once the keyboard records a simple part such as a 'triangle' on 4 downbeats in a measure that records and sounds perfect it's no longer in the equation.  The playback mode through the Kontakt triangle VST that once sounded fine suddenly has no volume without any change to the original MIDI recording by the keyboard. 

 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Sports Update!

Things seems to get better when I changed SONAR to only record  MIDI "Notes" (see below).  I'm still testing this but turning off the Controller and other check boxes might be what's helping keep the volume consistent.  Film at eleven...

 

image.png.1c7de8ec1140e044ee7bf665ca636356.png

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

It makes sense that turning off the recording of CCs makes the problem go away.  If its not the keyboard causing the CC7 to be recorded, my guess is that something else is causing them to be recorded.  As long as you don't want to record CCs, your solution should work.

Share this post


Link to post
Share on other sites
  • 0

QUICK UPDATE:

  I haven't had any major problems with Kontakt plugins since I changed my MIDI settings as shown above  I'm using a keyboard MIDI OMNI input and not even assigning individual MIDI channels to the various Kontakt synth plugins.   

  What's strange is that occasionally I'll still see a MIDI synth input volume light up when my focus is on playing a new part.   All the other MIDI synth Kontakt inputs behave nicely and remain silent but one might perk up 'listening'.   I checked all the settings and it seems there's no difference between the 'listening' plugin and the well-behaved quiet plugins that also don't have the current input focus.   So I'm trying to add a new Kontakt synth and one older pesky channel is playing along also even thought I'm finished recording that part.

 The easiest way to fix this seems to be to insert the 'listening' plugin again and copy/paste it's MIDI data to the new channel.  Then it's well-behaved again.  I'm not sure what causes this behavior but it's a bit annoying.   Any suggestions are  appreciated.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...