Jump to content
G Randy Brown

(SOLVED) CW doesn't recognize Focusrite Scarlett 2i2 USB

Recommended Posts

I switched out my Presonus audiobox with the Scarlett and it states I have no audio devices.

Win 10 recognizes the Scarlett but nothing shows in prefs under devices...when I unplug the Scarlett it tells me it was disconnected.

Can someone tell me how to get CW to recognize it?

Thanks very much,

Randy

Share this post


Link to post
Share on other sites
16 hours ago, tecknot said:

uh, have you installed the driver(s)?  Had to ask.

 

What he said...

In short, did you do the following?

1) Download the latest 2i2 driver package from Focusrite.

2) With the 2i2 NOT connected to your PC  -- install the software. 

3) Reboot your system.

4) Connect the 2i2 via USB.   Allow a moment for 2i2 to load driver.

5)  Start up CbBL.

Share this post


Link to post
Share on other sites

I'm a Focusrite guy, and what's suggested is where I'd start, if you haven't. 

Share this post


Link to post
Share on other sites

Ohh man do I feel dumb?!

I guess my only excuse would be that I was running it on this PC a couple of years ago and forgotten that I uninstalled after switching to Presonus...sheesh, that was an easy fix thanks very much!

BTW, I didn't get any emails stating I had a reply to this...is there something I need to do besides check "Notify me of replies" in the bottom left?

Thanks again all!

Share this post


Link to post
Share on other sites

So apparently it's no longer a CW issue but after installing the drivers I get no sound at all.

I've uninstalled/reinstalled twice now and it does the same thing.

Uninstalled I get sound except in CW and Win 10 recognizes the device...installed I get no sound.

Any more advice other than buy something newer?

Thanks,

Randy

Share this post


Link to post
Share on other sites

What you are saying points to Windows is able to use the device possibly using generic drivers. 

Then you install the ASIO driver and Windows seems to not like this? 

With drivers installed what do you see when you hover the mouse over speaker icon in the lower right task bar of Windows? You should see a pop out window with something like 

" Line 1/2  Scarlett or Focusrite USB 100 % "  

If you left click the speaker icon and expand the dialog it will list the audio devices available. Choose the Scarlett. 

If it does not show then try reinstalling drivers and make sure you use a USB 2 port, I don't think 1st gen Focusrite supported USB 3. 

 

2020-02-03.png

Edited by John Vere

Share this post


Link to post
Share on other sites

Sorry for the delay, I'm not getting notification emails even with "Notify me of replies" checked.

Anyway, yes Scarlett 2i2 shows up in Sound Settings regardless of whether the drivers are installed or not.

After uninstalling I downloaded the drivers again (thinking maybe the last download got corrupted somehow) and installed.

I open CW and it acts like everything is normal and recognizes the drivers...I hit play and there's no sound from an existing project.

I close out and try to play a wav file with VLC media player and get no sound.

I uninstall the drivers, restart and CW reports no drivers.

I open VLC, play a wav file and it plays fine and Sound Settings (right click speaker icon in lower right and left click on Open sound settings) and it shows the device.

I'm biting at the bit because I have a subscription to Composer Cloud and they recently added "Hollywood Background Singers"

I would just buy a new interface but I just maxed out my credit card on camera equipment : (

Thanks very much for trying to help!

Randy

 

Share this post


Link to post
Share on other sites

Can't help with Focusrite specifically but I can help you understand a few things about Windows audio in general.

The audio interface shows up without the ASIO drivers because Windows has generic audio drivers. These drivers are used when selecting a driver mode other than ASIO in CbB and by most other Windows programs like VLC. The addition of ASIO driver by itself would not affect VLC.

When using the same audio interface for CbB and Windows make sure CbB and Windows are set to the same sample rate.

When testing CbB I would use something very simple like a single audio clip. One track to the master bus and out to the interface. Then concentrate on the audio preferences.

 

Share this post


Link to post
Share on other sites
47 minutes ago, scook said:

When using the same audio interface for CbB and Windows make sure CbB and Windows are set to the same sample rate.

ahh, I think you're onto something...it seems I use 48K in CbB because the music almost always winds up in a video.

I'll try to set CbB to 44K and see if that makes a difference.

Thanks very much,

Randy

Share this post


Link to post
Share on other sites

I thought I should follow up and let you know it has nothing to do with CbB.

When I install the drivers I get no sound period...Focusrite support opened a ticket on it so hopefully I'll get this resolved.

I'll try to add solved in the initial post.

Thanks,

Randy

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...