Jump to content
Magic Russ

VST Plugin Migration

Recommended Posts

I have a lot of projects with instances of Kontakt 5 loaded (and a few with K4).  Over the summer I will probably take advantage of the sale on Komplete upgrades and will find myself with Kontakt 6.

I remember hearing something about a feature that would let you replace older versions of a plugin with newer versions.  Did anything ever come of that, because it might be nice if I could effortlessly replace the K5 instances with instances of K6.

Share this post


Link to post
Share on other sites

Perhaps you are thinking of 'Replace if Possible on Project Load' in VST3 Migration in the VST settings of preferences?

That won't help here.

Oddly, while the Kontakt 5 VST is named 'Kontakt 5.dll',  Kontakt 6 is just 'Kontakt.dll'. Likewise, the new executable is just 'Kontakt.exe'. Perhaps you can make a copy of Kontakt 6's DLL and rename it or use a symlink or some such trick?

The older Kontakt 5 8 and 16 out DLLs are also now merged into the single new one.

Share this post


Link to post
Share on other sites

VST Persist Compatibility must be implemented by the plug-in manufacturer it is not something Cakewalk can do for the plug-in manufacturer.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...