Jump to content
C. A. Hamman

MIdi Tracks Volume drop... no automation and no volume events ?

Recommended Posts

Having a issues now in several of my projects - this has only been happening to me since the last update at the end of December. Indiscriminately a midi track (only Midi tracks - 'simple instrument track' as in when you load in a Instrument plugin) or two in any given project for no reason that I can find just looses volume. So Audio track are not affected. This is happening and seems to get worse as I continue through the project as I add Midi tracks and Instruments - the issue re-occurs. I have created new tracks with the same instrument, loaded the same preset and copied and pasted the midi from the original track - the new track has no issues and the volume is fine.

I have no automation lanes, and no volume settings on clips. I have no events showing volume changes. And zero controllers on stop disabled. 

This happens a lot now and had not been happening before. Even older projects start exhibit this problem.

Any thoughts?

Edited by C. A. Hamman

Share this post


Link to post
Share on other sites

If you aren't setting an initial MIDI Volume in the track to control the synth output level, you probably should. Or, conversely, you might have inadvertently pulled a MIDI Volume control down at some point.  For a Simple insturment track, access to MIDI Volume is via the MIDI tab at the bottom of the Event Inspector.  And if the MIDI is imported, check for Volume, Expression or other contorller messages in the clips themselves.

Also, make sure your MIDI/Instrument track Inputs are set to a specific port and channel (usually channel 1 of your keyboard controller) to prevent unintended response to MIDI messages being output by, or passed thru, some other source.

The ideal way to troubleshoot would be to throughly examine the settings of a low-level track/synth combo after replacing it with a new track and synth instance as you described, starting with a comparison of the output level of the synths, assuming the synth UI has a meter.

 

 

Share this post


Link to post
Share on other sites

I had this problem and I fixed it by selecting the track and changing all notes to midi channel 6.  The quiet notes were on channel 1.  Verify it with the midi inspector in the control bar.

Share this post


Link to post
Share on other sites

David Baay, yes much in the way of what I have checked to date.  I know Cakewalk well have been a user of it since Pro Audio 9 (20+ years ago) so yeah you right those are the obvious suggestions - checked all those and have done a thorough walk through of all the settings and comparisons per track. Fact is it is happening to Midi tracks only - Now in saying that perhaps my controller is sending signal that I'm not seeing - but I would expect to pick that up in Midi Events - but not seeing anything there either. Track for track comparisons show no such the same - setting the MIDI volume at the start of the project track makes no difference. As it is as if the setting is changing the Velocity... It is as I see - either a signal from a Virtual Instrument back out across the Virtual Omni or as you say me knocking something - but this is what gets me when I compare the tracks I can see zero differences in the tracks and settings of the VSTi's - no Midi change requests on Velocity or other  / no system messages or anything like that... but after a few plays and change even the new track has had same happen eventually.  So I think it is something I'm doing or something traversing the Virtual Omni - but I missing as it doesn't appear as a Midi Events. So it affects the plugin (VSTi) And once changed you cannot revert back. Midi Level and Velocity still at default no matter what as viewed from Cakewalk. Strange... again automation lanes etc etc nothing there. Not a peep.

David Deneau, that is a interesting observation - so you telling me that you think Omni signal is getting something via virtual controller if not physical and to stop that from happening you remove the channel from processing anything on Channel 1 or omni? (Picking Channel 6 is as far off field as any :)) I'll have a go - I have a Project at the moment with 2 Midi Instrument track exhibiting this issue - I'll have a look and try your suggestion. And see what I can observe. And get back to you in the next 24 hrs

Thanks guys for the help; not a back thing to go over the same information. I wonder would Cakewalk undo history note something? Not likely if a not noticeable from within the track. Got to spend more time getting this sorted. Again much appreciated!! Will get back to this post asap.

 

Share this post


Link to post
Share on other sites

Also, and I know you've been a Cakewalk user for years so sorry if this sounds like teaching you to suck eggs, do check you don't have a VSTi in the project(s) with MIDI out enabled (not that this would explain the sudden onset of the issue).

Share this post


Link to post
Share on other sites
1 hour ago, C. A. Hamman said:

As it is as if the setting is changing the Velocity...

I was going to mention checking for MIDI Gain (velocity offset) as well, but figured that would be fairly obvious.

It occurs to me that I had a somewhat similar situation recently, and found that Cakewalk was sending CC7=64 on starting a new project from a template that I use for simply playing and recording my digital piano. So it has just a single, empty MIDI track in it to echo and record real-time performances. I never did figure out why this template was doing this, but creating a new one eliminated the problem.  Since it involved hardware ports, I was able to see what as happening using MIDI-OX.

I didn't bother reporting it to the Bakers because I wouldn't be able to say what steps led to the state the template was in since it's been around and modified in various ways over a long period of time.

If you're creating a lot of projects from an old template, it might be worth creating a new one from scratch.

Share this post


Link to post
Share on other sites

GOT IT!! I know how and when it happens!

Right here it is lads, would appreciate if you could have a look and see if it's the same for you - it happens when in Staff View - if you edit notes in staff view in other words add note or move note or delete note - the volume of the track goes high or low or OFF - no settings anywhere in Midi / Audio / Automation of anything else is being touched - you cannot find it to fix it. So i do not know what is giving Cakewalk the idea that there is a volume / velocity change. Cannot even be sure that is what it is changing - because everything in event list show no changes and all Velocity and volume states are good??

But I can replicate this on any MIDI track now. I do loads of my composition work in Staff View this is why I see this!!!

Workaround

Finish the edit in Staff View as best you can. (you may need to do this a lot if in staff view) Cut all the events from the track. Create a new track by re-adding the Plugin VSTi - and paste in the Events - DO NOT RE-EDIT in staff view or the bug will return.

I can reproduce this on any new project or old projects. This is a Cakewalk Bug for sure, as it affects any VSTi so it is particular to Cakewalk (also same with TTS). I'll see how to report it.

Thanks all!!

Please give feedback if you can thanks!

 

Share this post


Link to post
Share on other sites

This interests me because I have been working on writing/tweaking in part via Staff View. I have not gotten to the point of using it in mixing, recording, etc., so have not considered the track level issue--yet.  Thanks for the clear steps in the Workaround section which seems to me to also serve as the steps to try to reproduce the issue. 

Share this post


Link to post
Share on other sites
On 1/23/2020 at 8:12 AM, C. A. Hamman said:

Create a new track by re-adding the Plugin VSTi - and paste in the Events

I will check this out, but am wondering if just using Replace Synth, and selecting the same synth would re-initialize it - or may even just re-load the patch.

Another thing you might try is hitting the MIDI 'panic' button in the Transport module. This sends controller reset messages to all channels of all ports.

A slight correction to what I wrote above about Cakewalk sending CC7=64: It was actually CC11 Expression, and hitting the MIDI Panic button would restore full volume by sending CC11=127. The only way to reset CC11 otherwise is to deliberately add a controller event to a track, which makes it somewhat of a 'mystery' volume control.

Share this post


Link to post
Share on other sites

I'm unable to reproduce this issue. Tried with TTS-1, TruePianos, and a hardware synth. None had any volume change after editing in the staff view.

Possibly your issue is related to a template as mine was. See if you can reproduce this in a new project started from the Basic template.

Share this post


Link to post
Share on other sites

Lads I always start from new template (blank) and add all my instruments as I need them.  I always begin on new canvas, I feel templates restrict instrument uses and very quick put you into a rut of same sound same writing. Not that that is not good, but for me I write for any number of person and reasons so I may need to do just about anything (Classical / Orchestral to Reggae and Pop).  It's just easier to me to work that way.

I've been composing in Cakewalk for 20+ years (Since Cakewalk Pro Audio 9) and this has never been an Instrument volume issue, that I can remember. I know MIDI since last 80's - I created a controller map for my old Fostex VM200 mixer back in 2001 for managing Cakewalk mixes - worked well until the mixer was replaced with some more proprietary. 

But now there's an issue and I'm at a loss to know where it comes from. But I can recreate it and it is not that it is random - it is does happen when I edit in Staff view, not after every note edit but certainly within a few edits, and all my edits would be note insertions, set position note length and velocity etc. After that the whole track either gets massive volume boost or low volume (very low).

I know a lot of folks using CbB product, they in the habit of a track freeze - just in case MIDI does some strange things, which can happen with Virtual Controllers and particularly old Keyboards if the I/O is not set correctly!

This was not happening through most of last year 2019. Only since December (and after Christmas to be exact) and I've not added any new gear to the setup? I'd think you all have something like this happening but perhaps have levelling plugins and Limiters setting fixed thresholds that you may not notice. Take a look again please - spend time composing in Staff View add and delete - change notes and values (just to one note at a time)... PLEASE.

I have a friend - we were able to replicate it on his system on Saturday. Not a song I gave him. It was from scratch on blank template on his system - I too have another system that I will try it with and see if it does it by the end of the week. But I need to install Cakewalk.

Also another fellow composer in my town here, wants me to check his issues - seems something similar, I'll see him at the end of the week. But I want to see if they continue to have the same issues. We, all of us, use Staff View extensively - almost exclusively. I REALLY appreciate you helping out - THANK YOU! I will try your ideas ALL again including creating a BLANK template - so thanks!

 

Edited by C. A. Hamman

Share this post


Link to post
Share on other sites

I have had similar issues with a few VSTi that use the mod wheel for volume and/or swells. When I record the track I also record the volume via the mod wheel.

When I come back to play the track it doesn't read the mod wheel. The only way I can make it work is by moving the mod wheel at the beginning of the track. If I don't do this, it won't see the control and I won't have volume. Also works if I take the mod wheel cc# out of the track, although then I no longer have the volume or swell control.

Share this post


Link to post
Share on other sites

Update:  If I reload the VSTi preset it goes back to expected / said volume. But after a few plays or edits the track (midi only) start to do the same - there is also an opposite happening too, where a MIDI track increases in volume. I have several project now where this happens - I find that I have to freeze the track as soon as possible to stop it from happening. I some cases I have to reset the Preset in the VSTi or create VSTi to new track and copy the MIDI. I then Freeze the track before playing the track because as soon as I stop playing the track drops volume. I have found this with several different Plugins and same with different Audio devices. I have this well tested now and it is Cakewalk and not other DAW's or the plugins.

Tried with Studio One - all ok / Waveform - all ok. But only have the full versions of those for a month of test. I just work around it now - I have also tested with deferent start templates / Blank / 4 track / 16 track etc etc. All have this issue at some point. I have review event lists for volume changes / automation and etc! See my comments below.

There is also a particular issue with komplete Komtrol and the reset / stop function which sets a setting in the plugin to zero - this is either a volume setting for a Cutoff setting or an A/B setting for the instruments I use.

It doesn't have Audio Effects plugin issues. It's only happening to VSTi's. In my case.

Audio Devices - Focusrite Solo Gen 2 / NI Maschine MK3 / M-Audio M-Track / ASIO4ALL - all tested with various Audio latencys too and same results.

Share this post


Link to post
Share on other sites

As noted earlier, I finally got to the bottom of my bad-template issue by using the hardware port monitor, MIDI-OX . You could do the same by routing a single misbehaving MIDI track out to a hardware MIDI loopback path and back in to another MIDI track that echoes to the VSTi. Then monitor the MIDI IN using MIDI-OX. One way or another, I think you will find some unexpected MIDI controllers in the stream, and will need to do further investigation to figure out where they're coming from. 

Share this post


Link to post
Share on other sites

Hi, I am having this exact same issue.  I am also a loooong time Cakewalk User - since Cakewalk 6!  It first happened after I downloaded a free instrument VST (Ample Precision Bass Lite II, to be exact.)  At the time, I thought it might either be a defective download, and/or also I was recording in 96K, which I rarely do.  I thought maybe the VST didn't like 96K so I changed the sample depth to 48K.  Still had the problem as described.  Plug in will play, then mysteriously the volume will drop to zero, but completely randomly.  For example, last night, I was using the TTS-1 plugin, which is actually a DX plugin.  (I like the synth brass settings...).  I recorded a whole midi track of brass parts, no problem - playback perfect.  This morning, I went into the studio to listen to what I laid down last night.  Get half way through the song, then nothing from the midi brass track.  No sound.  Check the slider on the TTS-1 channel I had the brass on, it's at zero.  I have been having this issue for about 2-3 weeks now.  You can actually play the track with the TTS-1 GUI open and see the volume slider suddenly zero out.  It can happen at totally different parts of the song.  I also checked the midi event list.  No clue there.  And it happens while playing live too, not just on playback.

Should mention that it's not just the Ample VST, or the TTS-1.  I've had it happen in this same song with the Dimension Pro synth and am also using the Cakewalk drum plug in just to keep time in the track - same problem.

I too downloaded the latest update to CbB about a month ago - maybe that has something to do with it.  I have also messed around endlessly changing midi inputs and outputs.  Nothing seems to fix this random problem.  One thing that is maybe worth mentioning and is different about my issue is that I do my midi track editing in Piano View (I'm a lousy keyboard player...) and that does seem to provoke the problem.  I also have an old Roland U-20 synth that I use as my midi controller.  Could be the old keyboard's midi out is causing it, but again, it seems to be related to editing in Piano view and since the problem is random, one would think the track wouldn't play at all if I had a wrong midi setting.

I can sometimes make the problem go away temporarily by replacing the synth, or shutting down Cakewalk and restarting the project, or sometimes even rebooting the 'pute, but it always comes back... 

Very frustrating.  I'm open to suggestions, guys.  Thanks!

Share this post


Link to post
Share on other sites
Posted (edited)

I've been having the same problem with several SI instruments but seem to have cured it by following David Deneau's advice to change channel in the instrument to anything but channel 1.  Thanks David.

For the record, I tried everything else.  Would only work properly if I closed the song and reopened it.  But would drop again if I stopped the playback and restarted.  I suspected some program or controller change.  Checked the event list across all channels and tracks, none there.  I unticked the search back for controllers and patch changes upon stop.  Wasn't that.  Forced it to load patch 1 (the cakewalk instrument patch) and wasn't that.

Seems like a bug but at least there's an easy workaround.

Ed

P.S.  Later found a couple of rogue volume fades at the end of the track. So think that was the initial problem.

Edited by Ed Manning

Share this post


Link to post
Share on other sites

I'm having the same issue. I disconnected all physical midi devices and started with an empty project with just a single simple instrument. In my case, I'm using the Aria Player with the Garritan instruments. This 4 minute video shows me reproducing the problem. Perhaps there will be clues captured in the video of the user interface that those of us experiencing the problem don't know to include in our description. 

https://www.screencast.com/t/sILbeXaSx4

Share this post


Link to post
Share on other sites
Posted (edited)

@Bradley Ross in your case Cakewalk may reset modwheel value to zero when you hit stop. If Aria is using modwheel for volume fades then this may be it, try go to Preferences>Project>MIDI and under Other Options uncheck "Zero controllers when play stops" and see if that helps

edit... this may be CC#7 Volume and/or CC#11 Expression as well

Edited by chris.r

Share this post


Link to post
Share on other sites
Posted (edited)

When I've had issues like this there's been some sort of hidden data that I cannot see in Cakewalks event list. Close inspection of the track inspector might reveal something. Like try re setting the volume slider or gain and see if it moves when you start the song. Someone mentioned Ample Bass and this will often happen where it will jump to 1.6  in the GUI. I have to lower the midi track level to 64 to re set it to my pre set of 1.0. Never had to do that with other VST's.  

Tricks I've also use were to change channels ( didn't always work) or slip edit to exact first midi event  or split and delete the " empty" data before the first note. 

Edited by John Vere

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...