Jump to content
Sign in to follow this  
Scott Reams

Audio glitches on laptop only when CPU load is low

Recommended Posts

This is an odd one. I have a Lenovo Core i7 laptop that I use to play software instruments for live performances. It seems that the more I load the CPU up, the more stable playback becomes. As an example... if I load a single instance of Lounge Lizard 4 or VB3, audio is severely glitchy to the point of sounding like a comb-filter is on it. If I load more plugins and instruments, playback improves with each one I add. After adding one or two more instruments, I hear the occasional click/pop. Add a few more... and playback is rock solid. I have made the habit of loading up extra instruments just to make playback glitch-free during a performance.

My initial though is that this is related to Intel's Speed-step technology, and that increasing the CPU load prevents the CPU from constantly down-clocking. I've been through the BIOS settings and don't see any way to disable it. I have the power plan set to "High Performance" in Windows Power Options, and I have Processor State set to 100% for both Min and Max. Any thoughts?

Edited by Scott Reams

Share this post


Link to post
Share on other sites

You can start by checking USB (and other devices) power options, but to get general picture check latency. There are many guides, my own is http://www.azslow.com/index.php/topic,395.0.html Search Latency Monitor spoiler. Here you will find names/links to some utilities. F.e. throttlestop will show you current frequencies and C states distribution.

Also check what is working in background, Windows is "smart" and can start some activity when it think the system is "idle". I have bad luck, APM staff on DELL notebooks can hang for several ms. But disabling all extra activity and disconnecting from the net allow using it with relatively low buffers.

You can also find guides how to enable "Ultimate Performance" plan. Note that in the standard "High Performance" plan many power saving options are still on (not only for CPU). And standard windows configuration does not show you all options in power plans (see the link toward the end of my list).

  • Like 1

Share this post


Link to post
Share on other sites

LatencyMon shows excellent results and Load Balancing is off. I'll give the "Ultimate Performance" plan a try.

Edited by Scott Reams

Share this post


Link to post
Share on other sites

On my mobile devices I can't get the best low latency performance unless I disable the ACPI Battery Control Method driver in Device Manager. Once I do that, my XPS18s and my Surface Pro 3s behave perfectly, running at 64 sample buffer sizes all day long.

 

R

Share this post


Link to post
Share on other sites

Wow thats bizarre. The Windows scheduler continues to confound me when it comes to real time performance :(
Could this somehow be related to hyper threading - perhaps threads are being assigned to virtual cores that have lower performance. Just hypothesizing I have no idea if that is true. Just for comparison do you see the same behavior in SONAR (in case you have it)

 

Share this post


Link to post
Share on other sites

Check to see if speedstep is set to on in the bios setup. How to get there varies from manufacture to manufacture.

This slows down the cpu when it thinks you don't need the performance. Mostly to save on battery.

Bad for DAW and happiness. 🙂

 

 

Edited by bitman

Share this post


Link to post
Share on other sites
On 1/14/2020 at 12:18 PM, Noel Borthwick said:

Wow thats bizarre. The Windows scheduler continues to confound me when it comes to real time performance :(
Could this somehow be related to hyper threading - perhaps threads are being assigned to virtual cores that have lower performance. Just hypothesizing I have no idea if that is true. Just for comparison do you see the same behavior in SONAR (in case you have it)

Yes. Same performance in Sonar Platinum

Edited by Scott Reams

Share this post


Link to post
Share on other sites
On 1/14/2020 at 1:06 PM, bitman said:

Check to see if speedstep is set to on in the bios setup. How to get there varies from manufacture to manufacture.

This slows down the cpu when it thinks you don't need the performance. Mostly to save on battery.

Bad for DAW and happiness. 🙂

 

 

I mentioned in my original post that I suspected SpeedStep, but that there are no settings in the BIOS for it on this machine.

Share this post


Link to post
Share on other sites
8 hours ago, Scott Reams said:

I mentioned in my original post that I suspected SpeedStep, but that there are no settings in the BIOS for it on this machine.

The notation name of SpeedStep differs depending on the BIOS, it's sometimes called EIST (Enhanced Intel SpeedStep Technology).
Other things to try, also set C1E (Enhanced HALT State, C-STATE Tech, etc.) disabled.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...