Jump to content
jono grant

Using cakewalk track volume for synths

Recommended Posts

Hey there, I can never seem to figure out why sometimes cakewalk track volume will control a synth and other times it won't, many times I have to use the volume in the soft synth. Kontakt does this all the time. I have to learn a control and automate it.

Is there a way to force synths to only follow cakewalk's track volume and automation on that track rather than the synth itself? Or, follow cakewalks volume AND also allow an overall volume change from the synth. (like keep CW's volume automation and also be able to apply a global volume change to it.)

Thanks

Jono

Share this post


Link to post
Share on other sites

Yes, it's irritating.     I use  NI's SampleTank3 and Steinberg's HALIONsonic.     The  former needs to   do the  learning thing (which I can never get work properly)  and the latter properly obeys   volume and  panning  instructions from  the  CW track with no  problems.    (Thinks:  I wonder if  SampleTank 4 behaves   better?)

John

 

Share this post


Link to post
Share on other sites

It seems random too, like sometimes the synth won't obey CW volume and other times it will.

Sometimes I just want to turn up the volume slide on the kontakt track, but if I hit play and it immediately changes back to whatever it was, even though whatever it was doesn't relate to anything in the cakewalk track. 

Must be a setting somewhere that will alter this behavior.  Not sure what.

 

Share this post


Link to post
Share on other sites

The only things I can think of to make a track volume unresponsive is if you have volume automation on the track, Offset Mode engaged or you're tweaking the Midi velocity, not volume

Share this post


Link to post
Share on other sites
9 minutes ago, Bristol_Jonesey said:

The only things I can think of to make a track volume unresponsive is if you have volume automation on the track, Offset Mode engaged or you're tweaking the Midi velocity, not volume

I wonder if this is why I have this same problem. I use automation a lot. I too find that the midi track volume will and won't work. I never understood why.

Share this post


Link to post
Share on other sites

Kontakt, and Battery (and possibly their other engines), have a couple of parameters - one is a default volume setting, normally set to -6 dB, and the other that is turned by default - that tells the engine to accept standard parameter for volume change.

It seems to be set at the instrument level, because that is how you get to it.  Load up an instrument, in Kontakt, for example, and then click on the wrench icon, to go into the internal settings for that instrument.

Once in the instrument's settings, click on the Instrument Options button, and then click on the Controller button.  There, you will see a parameter - set to on by default, labeled: "Accept standard controllers for volume and pan".  If you remove that check (it shows as a white filled in box, rather than an actual 'x'), and then close you way back out, and you will have severed that connection between that loaded instrument, and it reacting to getting reset every time you hit Play/Record.

Please note that since this is at the instrument level, you will need to save that instrument, to preserve that setting for future loads of the instrument into Kontakt or Battery, or whatever NI engine you are in.

Here is the snapshot of that Instrument Options dialog box I refer to above:

image.png.9f98206b83ceb14eb3d9fc89a8291bea.png

 

And, here is a snapshot of the other parameter, which sets the volume for a loaded instrument to -6 dB by default.  This is a global option, which in Kontakt, you can get to by clicking on the gear-shaped settings icon at the top-center of the Kontakt UI window, and it is under the 'Engine' category:

image.thumb.png.fdb1a10370a9a1b913aca971fd9c2b8a.png

Share this post


Link to post
Share on other sites

Regarding my above post - I used to set the instrument-level setting to sever that acceptance of standard controllers for volume and pan, however I no longer do that.

The REASON I used to change that parameter to stop Kontakt from resetting to that -6dB, was that every time I had dropped the Kontakt instrument output volume level - in the Kontakt UI, as soon as I would hit play, it would instantly jump back to a level of -6 dB, which infuriated me.

So, while changing that Instrument Options Controller setting DOES stop that from happening, there is a different way to get that to stop happening, without having to change that setting.

NOW, I leave that setting alone completely, and instead, when I load an instrument into Kontakt, I know that by default, it will have an initial setting of -6 dB, because of that global option I mentioned in my first post.  Since I want to drop that level by a bunch, to meet my gain staging neighborhood prior to recording, (which I used to do with the audio track gain knob), I now instead drop the midi track's volume fader down to a pretty low level, usually around a midi volume setting of 64, which if you were to pull the fader down to that level, then click and hold on the volume fader in the Kontakt UI - Kontakt will then display the current volume setting in terms of dB, and a midi track midi volume fader level of 64 corresponds to a Kontakt UI master volume fader value for the instrument, of around -17.8 dB.  )I usually set instruments to around -18 dBFS as a starting point.  I am not going to get into a whole gain staging approach discussion here.  I just illustrate that this method eliminates that 'jumping' of volume back to a value of -6 dB, which is what was driving you nuts, and me too prior to incorporating this alternative technique of stoppinf that behavior.

With using the midi track fader to pull down Kontakt (and Battery, and likely their other engines too), volumess upon instrument loading, I no longer have that issue of the volume instantly jumping back to -6 dB, and I don't have to alter and save every loaded instrument, AND, by it working in this manner, it seems obvious to me that this is the methoed they kind of intended for the manner of controlling it, otherwise every instrument would not have that setting set to 'On' for accepting standard controllers for volume and pan, so I decided to go ahead and start controlling volumes using the midi track fader instead, and it works wonderfully that way.

I sincerely HOPE that I have made some sense with both my first post, and this rather confusing attempt at explanation.  I think that once you get used to it, this method works well, and has completely eliminated what was a maddening and baffling, and unwanted, instant change of instrument volume to a setting WAY higher than wanted.

Bob Bone

Share this post


Link to post
Share on other sites
On 1/8/2020 at 4:03 PM, Robert Bone said:

Regarding my above post - I used to set the instrument-level setting to sever that acceptance of standard controllers for volume and pan, however I no longer do that.

The REASON I used to change that parameter to stop Kontakt from resetting to that -6dB, was that every time I had dropped the Kontakt instrument output volume level - in the Kontakt UI, as soon as I would hit play, it would instantly jump back to a level of -6 dB, which infuriated me.

So, while changing that Instrument Options Controller setting DOES stop that from happening, there is a different way to get that to stop happening, without having to change that setting.

NOW, I leave that setting alone completely, and instead, when I load an instrument into Kontakt, I know that by default, it will have an initial setting of -6 dB, because of that global option I mentioned in my first post.  Since I want to drop that level by a bunch, to meet my gain staging neighborhood prior to recording, (which I used to do with the audio track gain knob), I now instead drop the midi track's volume fader down to a pretty low level, usually around a midi volume setting of 64, which if you were to pull the fader down to that level, then click and hold on the volume fader in the Kontakt UI - Kontakt will then display the current volume setting in terms of dB, and a midi track midi volume fader level of 64 corresponds to a Kontakt UI master volume fader value for the instrument, of around -17.8 dB.  )I usually set instruments to around -18 dBFS as a starting point.  I am not going to get into a whole gain staging approach discussion here.  I just illustrate that this method eliminates that 'jumping' of volume back to a value of -6 dB, which is what was driving you nuts, and me too prior to incorporating this alternative technique of stoppinf that behavior.

With using the midi track fader to pull down Kontakt (and Battery, and likely their other engines too), volumess upon instrument loading, I no longer have that issue of the volume instantly jumping back to -6 dB, and I don't have to alter and save every loaded instrument, AND, by it working in this manner, it seems obvious to me that this is the methoed they kind of intended for the manner of controlling it, otherwise every instrument would not have that setting set to 'On' for accepting standard controllers for volume and pan, so I decided to go ahead and start controlling volumes using the midi track fader instead, and it works wonderfully that way.

I sincerely HOPE that I have made some sense with both my first post, and this rather confusing attempt at explanation.  I think that once you get used to it, this method works well, and has completely eliminated what was a maddening and baffling, and unwanted, instant change of instrument volume to a setting WAY higher than wanted.

Bob Bone

Very helpful to know, thanks! 

I've actually now been using the amplifier volume in Kontakt. It seems to act as an overall volume, sort of like offset mode in cakewalk. Retaining the automation or DXF but globally setting the volume for that track. This works for me!

 

Amp vol Kontakt.jpg

Share this post


Link to post
Share on other sites
2 hours ago, jono grant said:

Very helpful to know, thanks! 

I've actually now been using the amplifier volume in Kontakt. It seems to act as an overall volume, sort of like offset mode in cakewalk. Retaining the automation or DXF but globally setting the volume for that track. This works for me!

 

Amp vol Kontakt.jpg

Yeah, but I think you can avoid having to even go into the instrument, by simply adjusting the midi track fader for the instrument.

Bob Bone 

Share this post


Link to post
Share on other sites
5 minutes ago, Robert Bone said:

Yeah, but I think you can avoid having to even go into the instrument, by simply adjusting the midi track fader for the instrument.

Bob Bone 

Okay, thanks, I'll check that out!

Cheers

J

Share this post


Link to post
Share on other sites
34 minutes ago, jono grant said:

Okay, thanks, I'll check that out!

Cheers

J

Kewl - yeah, because the Kontakt default is to set each instrument up to a -6 dB level, which is usually WAY too hot for recording, you can take advantage of its default checked parameter telling each instrument to respond to standard controllers for volume and pan, by adjusting the instrument volume using the midi track fader, stops it from making the volume jump back to that default -6 dB level.  It will just stay on whatever level you set on the midi track fader.  

The only thing with that, is that the scale on the midi track fader is from 0-127 - the midi scale, and that doesn't correspond to a dBFS value, so to get around that, try the following steps:

1) As soon as a Kontakt instrument gets loaded, drop its midi track fader to zero.

2) Alternate between moving the midi track fader up, and playing some notes on that instrument, so that you move up into the range you like to record at (for me that is around - 18 dBFS.  (so as you play some notes, every time you move that fader up, look at the associated audio track(s) for that instrument, to see the peak.  

Doing it the above way, keeps the volume from being insanely loud to begin with, (even if you have a limiter on your Master Bus to prevent speaker or ear damage), and only takes a few seconds to do.  After you do this a few times, you will get a feel for approximately where the midi track fader needs to be to result in a peak of around -18 dBFS, or whatever you generally use.  If you use VU Meters instead, shoot for around 0 dB VU, which is usually calibrated to be at -18 dBFS - but if you use VU Meters for gain staging, there are a couple considerations: 1) make sure nothing peaks (on the Peak meter) above -6 dBFS, and also, if you have an instrument with sharp transients (like drums), you are better off setting that instrument using the Peak Meter (dBFS) , because the slow reaction of VU Meters could result in clipping.

Bob Bone

Share this post


Link to post
Share on other sites
55 minutes ago, Robert Bone said:

Yeah, but I think you can avoid having to even go into the instrument, by simply adjusting the midi track fader for the instrument.

Bob Bone 

Actually, I think your method of changing the default instrument volume to 0 instead of -6 will work great for me.  My issue is usually wanting more volume so this should work great. It's global so I can set it and forget it as well.

Cheers and thanks again!

J

Share this post


Link to post
Share on other sites
1 minute ago, Robert Bone said:

Kewl - yeah, because the Kontakt default is to set each instrument up to a -6 dB level, which is usually WAY too hot for recording, you can take advantage of its default checked parameter telling each instrument to respond to standard controllers for volume and pan, by adjusting the instrument volume using the midi track fader, stops it from making the volume jump back to that default -6 dB level.  It will just stay on whatever level you set on the midi track fader.  

The only thing with that, is that the scale on the midi track fader is from 0-127 - the midi scale, and that doesn't correspond to a dBFS value, so to get around that, try the following steps:

1) As soon as a Kontakt instrument gets loaded, drop its midi track fader to zero.

2) Alternate between moving the midi track fader up, and playing some notes on that instrument, so that you move up into the range you like to record at (for me that is around - 18 dBFS.  (so as you play some notes, every time you move that fader up, look at the associated audio track(s) for that instrument, to see the peak.  

Doing it the above way, keeps the volume from being insanely loud to begin with, (even if you have a limiter on your Master Bus to prevent speaker or ear damage), and only takes a few seconds to do.  After you do this a few times, you will get a feel for approximately where the midi track fader needs to be to result in a peak of around -18 dBFS, or whatever you generally use.  If you use VU Meters instead, shoot for around 0 dB VU, which is usually calibrated to be at -18 dBFS - but if you use VU Meters for gain staging, there are a couple considerations: 1) make sure nothing peaks (on the Peak meter) above -6 dBFS, and also, if you have an instrument with sharp transients (like drums), you are better off setting that instrument using the Peak Meter (dBFS) , because the slow reaction of VU Meters could result in clipping.

Bob Bone

I just saw this. yeah, with the default set to 0, when I load a synth I can just decrease the volume in cakewalk and proceed with automation is what I'm thinking. Anyhow, you gave me a few ideas here. Cheers

J

Share this post


Link to post
Share on other sites
1 minute ago, jono grant said:

Actually, I think your method of changing the default instrument volume to 0 instead of -6 will work great for me.  My issue is usually wanting more volume so this should work great. It's global so I can set it and forget it as well.

Cheers and thanks again!

J

Wow - you bring Kontakt instruments in at 0?  I cannot imagine being that hot on input.  How could you not end up clipping?

Bob Bone

Share this post


Link to post
Share on other sites

If I could ask a question  in this thread, as I'm having a heck of a time with my KK A61 and getting a decent volume level. I have the NI Gentleman piano loaded. I hit a note on the keyboard on the instrument with my mouse & it's quite loud, maybe set at 127 at default. I hit a key on the KK A61 and it's very low. I checked this "Accept standard controller.. " option. It's set at -6 dB. I have the box checked (filled in white as you say).. Right now I'm playing Kontakt player as a standalone, trying to solve this volume issue,

Any input would be most appreciated. Still waiting to hear back from NI support.

Share this post


Link to post
Share on other sites
Just now, Nobletonmusic said:

If I could ask a question  in this thread, as I'm having a heck of a time with my KK A61 and getting a decent volume level. I have the NI Gentleman piano loaded. I hit a note on the keyboard on the instrument with my mouse & it's quite loud, maybe set at 127 at default. I hit a key on the KK A61 and it's very low. I checked this "Accept standard controller.. " option. It's set at -6 dB. I have the box checked (filled in white as you say).. Right now I'm playing Kontakt player as a standalone, trying to solve this volume issue,

Any input would be most appreciated. Still waiting to hear back from NI support.

I suggest using the midi track fader associated with the loaded Gentleman instrument, to bring its volume down (check the actual dBFS level shown on its audio track(s), for the actual gain level, because the midi track fader is using midi volume (0-127), rather than the audio gain level shown in the Peak Meter for its audio tracks.

For the instrument that is too quiet, I would just use that instrument's associated track's Gain knob, to add some gain there, again observing the Peak dBFS shown on the audio track(s) for that instrument.  If you have two audio tracks for that instrument (left mono and right mono), you can select both tracks, then hold CTRL while adjusting the Gain, to move the Gain knob for both tracks at the same time, as that will make both tracks move in the identical amount.

The reason I suggest using the midi track volume to bring an instrument down in volume, rather than the Gain knob for the associated audio track(s), is because the Kontakt default volume setting is -6 dBFS, which is still quite loud for recording purposes, and the Gain knob may not allow enough gain reduction to get you to whatever level you prefer to record at.  (I use -18 dBFS for sharp-transient instruments, like drums, and a VU Meter setting of 0 dB VU and a peak dBFS of no louder than -6 dBFS).

Bob Bone

Share this post


Link to post
Share on other sites
43 minutes ago, Robert Bone said:

Wow - you bring Kontakt instruments in at 0?  I cannot imagine being that hot on input.  How could you not end up clipping?

Bob Bone

Just tested it at zero with a few beat driven synths like Damage and Signal, the loudest peak was about -1 db. I'm sure if I held my hand down on a bunch of loops at once I could make it peak but it's easy for me to turn stuff down. The issue is when I have a lot of automation etc. but then need additional volume. If my volume automation is already at the highest level and the sound still isn't loud enough, that's what happens most of the time. 

I have no other controls set to diminish the volume, everything is at zero. Not sure why you would get peaks at zero. Perhaps related to our sound controllers. I'm using UAD.  I'm very careful with gain staging, I won't let a peak go by anywhere. Always checking my reverbs etc. for that sort of thing.  

My original post had to do with other synths doing this as well. Like Omnisphere for instance. It doesn't seem to respond to any cakewalk automation unless I learn the volume control in Omnisphere. Perhaps it's a setting in there somewhere.

Thanks

J

Share this post


Link to post
Share on other sites

Appreciate the response, I don't think I was clear enough on the problem. I can find ways to increase the volume. I'm concerned about the velocities I'm seeing in the Event View. For the life of me I can't figure out why they are so low and what I can do to increase them when I play a track in. It's affecting the articulations on something like the Kontakt The Gentleman piano, and on my XLN Addictive Keys. The nuances of the instrument are not there when I getting 30 - 90 as the velocities. Especially on the SG - Acoustic Guitar, where slides into notes, hammer-ons and pull-off are based on differences in velocity. Not getting those functions in Acoustic Picked.

There are no velocity curve options on the NI Komplate Kontakt controllers both A & S- Series. The MFX velocity plug-in seems to work to lift velocities, after I have records them in at lower levels. Maybe I'm not seeing a way to put that into the track before I play in any notes. Someone else in the CbB forum sent a link to a velocity curve I could add.  But why the hell do I have to do all that to get a decent velocity for instruments I'm playing through the KK A61?

It seems the velocities produced differ from instrument to instrument. I use the KK A61 to enter a drum track, using XLN Addictive Drums and no problem. I hit the C3 for the kick, with a good hit and get 127 velocity no problem.

Share this post


Link to post
Share on other sites
5 hours ago, jono grant said:

Just tested it at zero with a few beat driven synths like Damage and Signal, the loudest peak was about -1 db. I'm sure if I held my hand down on a bunch of loops at once I could make it peak but it's easy for me to turn stuff down. The issue is when I have a lot of automation etc. but then need additional volume. If my volume automation is already at the highest level and the sound still isn't loud enough, that's what happens most of the time. 

I have no other controls set to diminish the volume, everything is at zero. Not sure why you would get peaks at zero. Perhaps related to our sound controllers. I'm using UAD.  I'm very careful with gain staging, I won't let a peak go by anywhere. Always checking my reverbs etc. for that sort of thing.  

My original post had to do with other synths doing this as well. Like Omnisphere for instance. It doesn't seem to respond to any cakewalk automation unless I learn the volume control in Omnisphere. Perhaps it's a setting in there somewhere.

Thanks

J

The clipping may not occur on the individual track you are recording with peaks hitting -1 dBFS, but that is almost certainly going to be too hot for many of your plugins to process properly - particularly those that emulate analog gear - as those plugins are designed to work best with an input level at 0 dB VU (which is an average, and they calibrate most VU Meters to -18 dBFS, using a 1k pure sine wave).

In addition, if you start running your tracks to various buses, that feed additional busses, you will end up with the signal clipping, eventually.

I think it far better to record at lower levels, so that there is a good bit of headroom left for mastering.  I believe you would end up with a cleaner and better sound, by lowering your recording levels right from the start, and then if too quiet, simply raising the speaker volume would get it loud enough for your listening, while keeping enough room for a proper mix and master.

Don't take my word for it - do a little digging on the internet, and while there are numerous opinions on what a proper recording level is, I would bet you wouldn't find much, if any, guidance that would suggest recording with peaks hitting -1 dBFS.

For whatever the worth, I set track gain at or near 0 dB VU, with no peaks louder than -6 dBFS.  That gives me an average level that leaves me around 18 dB of headroom, with room for sharp transients to get up to, but not exceding, -6 dBFS.  I also have a limiter on the Master Bus set to -1dBFS, to prevent speaker or ear damage.  I also make sure that each plugin is gain-neutral , meaning the output volume of any plugin is adjusted to it matches its input gain, through either makeup-gain or gain reduction.  I try to run all the way through each channel and its plugins, at that 0 dB VU target, except drums - which I use a target of somwhere between -18 dBFS and maybe -14 dBFS, with no drum peaks above -6 dBFS.

Best of luck to you, in any case.   :)

Bob Bone

Share this post


Link to post
Share on other sites
10 hours ago, Robert Bone said:

The clipping may not occur on the individual track you are recording with peaks hitting -1 dBFS, but that is almost certainly going to be too hot for many of your plugins to process properly - particularly those that emulate analog gear - as those plugins are designed to work best with an input level at 0 dB VU (which is an average, and they calibrate most VU Meters to -18 dBFS, using a 1k pure sine wave).

In addition, if you start running your tracks to various buses, that feed additional busses, you will end up with the signal clipping, eventually.

I think it far better to record at lower levels, so that there is a good bit of headroom left for mastering.  I believe you would end up with a cleaner and better sound, by lowering your recording levels right from the start, and then if too quiet, simply raising the speaker volume would get it loud enough for your listening, while keeping enough room for a proper mix and master.

Don't take my word for it - do a little digging on the internet, and while there are numerous opinions on what a proper recording level is, I would bet you wouldn't find much, if any, guidance that would suggest recording with peaks hitting -1 dBFS.

For whatever the worth, I set track gain at or near 0 dB VU, with no peaks louder than -6 dBFS.  That gives me an average level that leaves me around 18 dB of headroom, with room for sharp transients to get up to, but not exceding, -6 dBFS.  I also have a limiter on the Master Bus set to -1dBFS, to prevent speaker or ear damage.  I also make sure that each plugin is gain-neutral , meaning the output volume of any plugin is adjusted to it matches its input gain, through either makeup-gain or gain reduction.  I try to run all the way through each channel and its plugins, at that 0 dB VU target, except drums - which I use a target of somwhere between -18 dBFS and maybe -14 dBFS, with no drum peaks above -6 dBFS.

Best of luck to you, in any case.   :)

Bob Bone

Thanks man. Appreciate you spending all sorts of time telling me how to record levels. I've been doing it for 35 years and am well aware how it works. Sometimes you're playing a flute sound and need a little more juice, that's all. Nobody's peaking anything, I said that previously.  Thanks for the tip on turning the default up in Kontakt, even though it will destroy everything I'm recording forever!!! LOL   

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...