Jump to content

Ben Staton

Staff
  • Content Count

    107
  • Joined

  • Last visited

Everything posted by Ben Staton

  1. There's actually a 64 bit version of Spy++ in the same folder as the 32 bit version. Visual Studio opens the 32 bit one by default (via Tools -> Spy++). Since CbB is a 64 bit application, you need to run the 64 bit version of Spy++. On my PC it's here: C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\Tools\spyxx_amd64.exe Give that a go and you should be able to view messages.
  2. Very strange! I pinged Fractal Audio tech support and asked for a dev to contact me. Maybe we can work together to figure out what's going on.
  3. Great, thanks for letting us know. I think it's time to remove that setting. It was only ever meant to be experimental/opt-in anyway, and yours isn't the first issue we've seen with it.
  4. Aha! That might explain it. Please try removing the 'EnableWin10DPIAwareness' setting in Preferences -> File -> Initialization File, and then restart Cakewalk.
  5. Thanks for the report. I can't repro @ 300% here though (on a 4K monitor), so some more info would be useful please. Does it always happen, even if you restart Cakewalk/Windows? Are you using the latest version of Cakewalk? What's your monitor's native/current resolution? Which version of Windows are you using? Do you have a custom theme enabled? Are you using any 3rd party apps that customize the appearance of Windows (some are known to cause issues)? Do you have any special options enabled in Preferences -> File -> Initialization File? Are your graphics drivers up-to-date? A screenshot of your entire desktop might also be helpful. Edit: It might also be worth reinstalling PC2A just in case.
  6. Thanks for the report. I'm working on some fixes in that area, so I'll PM you to discuss shortly.
  7. Thanks for verifying. Please would you try adding the following option in Preferences -> File -> Initialization File: EnablePluginMenuFix=1 Then restart Cakewalk and let me know if your plugin menus look any better. To be clear, that option should be enabled by default, so I'm not expecting it to make any difference, but I want to make sure it's enabled to rule out anything unexpected. Many thanks!
  8. @Glenn Stanton If you start Cakewalk up with a custom theme that is out of date, two things should happen: 1. You should get a warning message telling you that your theme is out of date. 2. If you choose to continue with the out-of-date theme, then Cakewalk will look incorrect even if you switch to Mercury afterwards. IOW, to fully rectify the problem, switch to the Mercury or Tungsten factory themes and then restart Cakewalk. After that, if you wish to continue using a custom theme, you should open it in Theme Editor and resave it before attempting to use it in Cakewalk again. If you do that and it still looks wrong, then please (a) let me know if you saw the theme warning message, and (b) PM me a copy of your custom theme if you're using one (the screenshot you posted on Saturday shows the Smart Tool button in the Control Bar with a different background color compared to both Mercury & Tungsten, which suggests you are). We're unable to reproduce the problem, so your assistance would be much appreciated.
  9. Thanks. Clearly there are still some issues to work out. I'll keep investigating.
  10. Thanks for the report. Please confirm which build version you are using by going to Help -> About Cakewalk. It should say something like "Version: 2021.04 (Build 155, 64 Bit)". If the build number is less than 155 then you aren't running the latest version. You can download the build 155 installer here:
  11. Glenn, it looks like you're using a custom theme. It probably needs updating. You should get a warning message when you start Cakewalk or select the theme in Preferences, saying that your theme may be incompatible and it might need to be updated in Cakewalk Theme Editor. If you're not seeing that warning, please PM me a copy of your theme file and I'll look into it. Edit: You may also want to confirm you're running build 155 by checking the version number shown in Help -> About Cakewalk.
  12. Thanks for the report. Have you installed the latest hotfix early access build (build 155)? It should address that problem. You'll need to install it manually (you won't get a notification to update in CbB). You can find the installer here:
  13. @MrJackBarton Thanks for the report. We've been doing some more work on plugin menus and will shortly be releasing another build which will hopefully resolve your issues. Stay tuned!
  14. Hi Glenn, Thanks for the report. My immediate thought was that it looks like a custom theme issue. I realize you're using Mercury, but can I ask if you were using a custom theme before that? Nothing wrong with that, but if Cakewalk starts up with a custom theme that isn't up-to-date, it's possible you could run into this issue even after switching back to Mercury. One way to find out is to set Cakewalk to the original Mercury theme and then restart it. If that solves your problem, then you probably need to update your custom theme. We also introduced a theme compatibility warning in the latest release, which you should see on startup if your custom theme needs updating. Thanks, Ben
  15. FWIW, we can't reproduce it here. I also checked the code and it doesn't seem to be doing anything unusual or CPU intensive at all when moving the mouse over track names. Indeed, moving the mouse over track names actually does significantly less than moving it over some of the other controls nearby. Are there any other clues you can give us?
  16. @torhan Thanks for the report. Unfortunately, we can't reproduce it here, but we're aware that issues like this do happen in rare circumstances. If you see it again, please would you post a screenshot showing the entire Cakewalk window? That can often give us clues that a more localized screenshot can't, such as the general layout of all views at the time it occurred. Thank you! In the meantime, resizing the window (or un-maximizing it and then maximizing it again) usually fixes it.
  17. @Herve Maratrey I just PM'd you a link to a new installer. Hopefully, that will fix your problem. Please let us know how it goes. Thanks again, Ben
  18. @Herve Maratrey We're currently testing a fix for this, which looks very promising. Is it OK if we send you a new build to test?
  19. I'd also like to know which languages you have Windows and Cakewalk set to. It may be relevant.
  20. @Herve Maratrey Please would you also check the Arranger by opening the 'View' menu in the Track View, and then choosing 'Arranger Track Show/Hide'? We're wondering if that also causes a crash for you. Thanks!
  21. Hi @Herve Maratrey, Thanks for the report. The crash dump suggests there might be an issue with DirectX on your PC. Firstly, I would make sure that your graphics driver is up to date. If that doesn't fix the problem, you could try running dxdiag, which is the 'DirectX Diagnostic Tool' that comes with Windows 10. It might highlight any DirectX problems and help you to resolve them. Failing that, dxdiag has a 'Save All Information...' button at the bottom that will save a file containing information about your DirectX installation. If you send that file to us, it might give us some clues (check it first, to make sure you're OK with us seeing the information it contains). Please let us know how you get on. Thanks again, Ben
  22. Thanks for the report. This bug has been reproduced and logged. No guarantees, but hopefully we'll get to it soon.
  23. Hmm, this is a tricky one. Cakewalk literally does nothing at all to change or ignore the Windows scaling setting. It neither opts in nor out of it. Essentially, it just throws its hands in the air and says "Hey Windows, I know nothing about high DPI, so you take care of it!". Do you by any chance have multiple monitors? If so, do they have different resolutions? Do you always run Cakewalk on the same monitor? Do you ever run Cakewalk on another display, whether it's temporarily plugging in a different monitor/TV, or by running it remotely (via Remote Desktop or similar)? Do you change the Windows scaling setting occasionally (nothing wrong with that, but it might be a factor)? I'm also wondering why you're running Cakewalk with admin permissions all the time, which shouldn't be necessary. If Cakewalk is somehow affecting it (again, I fail to see how, but stranger things have happened), running it without admin permissions might prevent it from doing so. If anyone else is running into this, please let us know. I'd like to get to the bottom of it.
×
×
  • Create New...