Jump to content
Sign in to follow this  
Morten Saether

[CLOSED] Cakewalk 2019.12 Early Access

Recommended Posts

2019.12 Early Access installer now available!

We're pleased to announce the Early Access for 2019.12, which is a stability update in keeping with our goal of making Cakewalk as reliable and enjoyable as possible.

We'd love for you to check it out before we drop the official public version.

Please note that Early Access installers are update installers, which only update from a specific version. To install the 2019.12 Early Access build, you must be on the latest public release of 2019.11.

Download Cakewalk 2019.12 EA installer

If you haven't already done so, please read about the Early Access Program before participating.

Thanks again for your participation!
The Bakers

 


 

2019.12 Highlights
 

Behavior changes & optimizations

  • Improved audio resampling quality in WASAPI Shared mode.
  • The default MIDI Prepare Buffer size has been changed to 200 msec. Limitations preventing the MIDI buffer from being set lower have been removed. There should be no need to change the buffer size from the new default value anymore, since the engine automatically raises the internal size when necessary. 
  • On first launch, Cakewalk will reset the MIDI buffer size to the new default value of 200 msec (Preferences > MIDI - Playback and Recording > Prepare Using n Millisecond Buffers).

 

Bug fixes

  • Opening Cakewalk in WASAPI Shared mode stops audio in other apps that share the audio device(s).
  • Potential crash when changing audio configuration settings (Preferences > Audio - Configuration File) during playback in ASIO driver mode.
  • Deleting data clears the selection.
  • In rare cases, Input Echo could not be disabled in Instrument tracks.
  • Reassigning a synth output track's Input control to None no longer disables the Input Echo control.
  • When doing a real time export of a project (Fast Bounce disabled), the project no longer scrolls.
  • Now time in musical time (H:M:S:F or any time based format) doesn't update to reflect new time when changing tempo.
  • PreSonus Studio 192 crashes when changing buffer size.
  • Playback distortion at certain buffer sizes with some ASIO drivers after 2019.11 update.

 

  • Like 5
  • Thanks 6

Share this post


Link to post
Share on other sites
21 hours ago, Morten Saether said:

Deleting data clears the selection

Thank you. this works now. However, now undo (cntrl-z) clears the selection. Makes me think of the rhino in "The Gods Must be Crazy" running around stomping out fires.

Share this post


Link to post
Share on other sites

Base 57 -
Can you clarify, I just ran a bunch of ctrl-z tests and none of them deleted anything, unless it was a track just recorded.  

I just want to make sure I am not missing anything.

Share this post


Link to post
Share on other sites

In the previous build, if you deleted a clip the selection range would be cleared (from and through would both be set to the Now time). This EA build fixes that. but now the selection range is being cleared by Undo.

12 minutes ago, Robert Lackey said:

unless it was a track just recorded

This is how I noticed it.  I made a mistake while recording an audio clip. Hit cntrl-z and the selection range was cleared along with deleting the new clip.

 

20 minutes ago, Robert Lackey said:

I just ran a bunch of ctrl-z tests and none of them deleted anything

This is not deleting data. it is only clearing the selection range.

Share this post


Link to post
Share on other sites

This is an tiny cosmetic issue I have noticed for a while now.  However, it might be such as easy fix I thought I might report it while an early release is out and actively been looked at.

As you know, In the staff view, there is a lyrics mode.  When one clicks on the "Lyrics" button (under the "view" menu item), the staff view enters Lyrics mode and the "Lyrics" button changes colour to indicate you're in lyrics mode.

However, on my machine, I have the L key bound to enter lyrics mode.  This works and it does puts me in lyrics mode and I can enter lyrics. 

However, when entering lyrics mode using the keybinding (L key in my case), this does not change the colour of the lyrics button even thouh I am in Lyrics mode. Clicking on the "Lyrics" button does change the colour of the "Lyrics" button.

This also occurs in CbB 2019.12 Build 23

A small cosmetic thing yes, but maybe a really quick fix while we are in early release phase and the code is being actively examined.

  • Like 1

Share this post


Link to post
Share on other sites

HI:)

 

>>>Full Screen mode now persists globally instead of per project. Closing or opening projects or switching Workspaces will no longer exit Full Screen mode.

How can I get CbB to start with FullScreenMode?

On every Start FSM is deactivated. Every Time I Exit CbB, Full Screen Mode will be exited. 

 

Bassman.

 

Share this post


Link to post
Share on other sites
8 hours ago, Promidi said:

This is an tiny cosmetic issue I have noticed for a while now.  However, it might be such as easy fix I thought I might report it while an early release is out and actively been looked at.

As you know, In the staff view, there is a lyrics mode.  When one clicks on the "Lyrics" button (under the "view" menu item), the staff view enters Lyrics mode and the "Lyrics" button changes colour to indicate you're in lyrics mode.

However, on my machine, I have the L key bound to enter lyrics mode.  This works and it does puts me in lyrics mode and I can enter lyrics. 

However, when entering lyrics mode using the keybinding (L key in my case), this does not change the colour of the lyrics button even thouh I am in Lyrics mode. Clicking on the "Lyrics" button does change the colour of the "Lyrics" button.

This also occurs in CbB 2019.12 Build 23

A small cosmetic thing yes, but maybe a really quick fix while we are in early release phase and the code is being actively examined.

Early access releases are to validate specific fixes. We typically do not add new ones to that release.

Share this post


Link to post
Share on other sites

im getting a lot more random cakewalk crashes where theres no prompt or error message and it just closes

Share this post


Link to post
Share on other sites
On 12/28/2019 at 10:27 PM, Max Arwood said:

Does freeze synths reset gain to 0?

Or is it just me??

 

Max Arwood

Max . . . I've found something similar, but can't confirm freezing synths exactly resets "gain to 0" . . . but I have noticed when I freeze a synth it becomes noticeably louder in my mix, and have to trim it slightly to blend in and sound as before the freezing.

  • Sad 1

Share this post


Link to post
Share on other sites
8 hours ago, noynekker said:

Max . . . I've found something similar, but can't confirm freezing synths exactly resets "gain to 0" . . . but I have noticed when I freeze a synth it becomes noticeably louder in my mix, and have to trim it slightly to blend in and sound as before the freezing.

This is worrying. Is this with 2019.11? Can you go back to 2019.09 and see if the problem goes away?

Share this post


Link to post
Share on other sites
On 12/29/2019 at 4:57 PM, Max Arwood said:

Does freeze synths reset gain to 0?

Or is it just me??

 

I tried it here as well on 2019.12 Build 26.  The gain resets to zero here as well.

There is no mention of this behaviour in either the online manual or the update notes.

The same behaviour does not occur with the latest Sonar Platinum.

I have sent a ticket to Cakewalk support asking whether this is a bug or a feature.

Share this post


Link to post
Share on other sites
25 minutes ago, Promidi said:

I tried it here as well on 2019.12 Build 26.  The gain resets to zero here as well.

There is no mention of this behaviour in either the online manual or the update notes.

The same behaviour does not occur with the latest Sonar Platinum.

I have sent a ticket to Cakewalk support asking whether this is a bug or a feature.

I've tried this with 2019.09 and gain is set to 0 after a freeze.

However, the gain setting is applied as part of the freeze so setting it to zero keeps it at the same level as it was prior to bouncing - at least this is what I'm hearing in my projects (i.e. if I set my gain to -15 prior to freeze, the frozen audio is much quieter).

As for comparing it with Platinum... if you're using simple instrument tracks, remember that the Gain, Volume & Pan knob's refer to MIDI trim, volume & pan, NOT the audio gain - which is why you're not seeing a change.

 From 2019.07, Cakewalk shows the audio gain, volume & pan when the Audio tab is selected in the inspector, and the MIDI equivalent (like Platinum) when the MIDI tab is selected.

 

Share this post


Link to post
Share on other sites
19 minutes ago, msmcleod said:

However, the gain setting is applied as part of the freeze so setting it to zero keeps it at the same level as it was prior to bouncing - at least this is what I'm hearing in my projects (i.e. if I set my gain to -15 prior to freeze, the frozen audio is much quieter).

I did notice this as well (and I refereed to this in my support question)

Personally, I am thinking this is a feature rather than a bug.

Share this post


Link to post
Share on other sites
Posted (edited)

Yes thanks - Checked all volumes with LUFS meter.  They are all correct pre and post freeze.

Max Arwood

Edited by Max Arwood

Share this post


Link to post
Share on other sites

I'm getting the Melodyne error again with this new update. Everytime I create a FX Region, Melodyne doesnt display the notes. I have to close the window and open it again to see them.

Share this post


Link to post
Share on other sites
1 hour ago, Apeirofobia said:

I'm getting the Melodyne error again with this new update. Everytime I create a FX Region, Melodyne doesnt display the notes. I have to close the window and open it again to see them.

Are you using the latest version of Melodyne?  (Which is 4.2.4.001)

If so, then you might want to get on to CbB support

https://help.cakewalk.com/hc/en-us/requests/new?ticket_form_id=360000025633

Or Celemony support:

http://helpcenter.celemony.com/hc-2/support

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...