Jump to content
Justin

Reason 10 does not show up as a Rewire device in Cakewalk

Recommended Posts

Hello everyone,

I'm setting up a new system with Cakewalk by Bandlab.  I'm running into an issue where with Cakewalk under "rewire devices" Reason 10 does not show up.  I remember having this issue on my old computer and somehow I fixed it, but I can't for the life of me remember what I did.  I can't find much documentation on rewiring Reason with Cakewalk by Bandlab.  Most of what I find has to do with old Sonar.  Any help would be appreciated.

I'm running Windows 10 Pro,  with CbB (latest update) and Reason 10 lite. 

edit: just after posting I read in another forum that Reason lite doesn't support Rewire.  Looks like I need to have the full version of Reason and that must be the problem.  Leaving this for anyone else that runs into the issue. 

Edited by J_P

Share this post


Link to post
Share on other sites
15 minutes ago, Matthew Sorrels said:

I think for Reason 11 they removed rewire completely.

Yes indeed. Wish they hadn't, not so much because you can't do most of what ReWire could do with a plug-in, but because when the originators of something turn their back on it, that doesn't bode well for companies that still use ReWire. I wonder if anyone is going to maintain the .dll 

Share this post


Link to post
Share on other sites
1 hour ago, Matthew Sorrels said:

I think for Reason 11 they removed rewire completely.

Yep, I ended up buying Reason 11 Intro today.  It loaded right up as a vst.  I did like the rewire format because I could work exclusively in Reason then easily sync with Cakewalk when time to record vocals Or guitars.  But now I will just write all in cakewalk.  Will make me a beast at the cakewalk midi editor which I could use some practice on. 

Share this post


Link to post
Share on other sites

Just discovered my reason 10 no longer shows up as rewire device in Cakewalk.  That stinks.

Share this post


Link to post
Share on other sites
7 hours ago, Alan said:

Just discovered my reason 10 no longer shows up as rewire device in Cakewalk.  That stinks.

Regular Reason 10 should work. Just not the lite version.

Share this post


Link to post
Share on other sites

I have the regular Reason 10.5 and it is not showing up as a reworn device.  Is there anything I need to change in settings?  I really miss using it via retire.

 

thanks,

Alan

Share this post


Link to post
Share on other sites
On 12/27/2019 at 8:47 AM, Alan said:

I have the regular Reason 10.5 and it is not showing up as a reworn device.  Is there anything I need to change in settings?  I really miss using it via retire.

 

thanks,

Alan

There was a 10.5 ? 

I'm running Reason release 10.4d4 and it ReWire's to Cakewalk version 2020.1 just fine. It appears in the right side menu in CW. 

But yes, as mentioned, they have scrapped ReWire in version 11

Share this post


Link to post
Share on other sites

I'm trying the same thing, too. Indeed, reason 10 Lite does not appear in the Rewire section of the CbB Browser, I can only see Melodyne 4.

This is strange to me because in C:\Program Files\Common Files\Propellerhead Software\ReWire... ReWire.dll is installed.

Why?

Share this post


Link to post
Share on other sites

Has anyone solved this problem?  I've been trying to use Reason 5 with CbB, same issue-Reason is simply not recognized by CnB. I saw that Craig Anderton suggested getting the correct rewire library.dll, but does anyone know where to find it (If indeed thats the issue)? Thanks!

Btw, I have the same issue with Studio One 5.

Share this post


Link to post
Share on other sites
11 minutes ago, spankygtr said:

Has anyone solved this problem?  I've been trying to use Reason 5 with CbB, same issue-Reason is simply not recognized by CnB. I saw that Craig Anderton suggested getting the correct rewire library.dll, but does anyone know where to find it (If indeed thats the issue)? Thanks!

Btw, I have the same issue with Studio One 5.

Maybe you're running a 32 bit version of Reason?  AFAIK for Rewire to work, both apps need to be the same bitwise. 

Share this post


Link to post
Share on other sites
21 hours ago, msmcleod said:

Maybe you're running a 32 bit version of Reason?  AFAIK for Rewire to work, both apps need to be the same bitwise. 

Also, the .dll library needs to be same, bitwise. You can't use a 32-bit ReWire dll, even if Reason and your host are 64-bit.

Apple Silicon kind of sealed the fate for ReWire because there's no ReWire library for it, and there probably never will be. Such a shame. I use ReWire a lot.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...