Jump to content
sparticus

SOLVED - Issue with all non-sonitus plugins distorting...

Recommended Posts

Hey there,

We've been having some recent trouble with plugins. Everything has been working fine for a long time and have been finding Cakewalk to be great. However recently we noticed a distorted sound while playing back sessions.

This only occurs when certain plugins are enabled. All sonitus plugins work without issue. However any other plugin immediately introduces a crackly distortion when turned on. In the plugin library, the plugins coloured white (sonitus) are working. But the plugins coloured yellow (all others and all default effects in Pro Channel, including plugins I've sourced myself) introduce the distortion.

This only seems to effect playback within Cakewalk. If I export the session, the exported file doesn't have any issues. This issue occurs on all sessions, both newly created sessions as well as sessions created before the issue. Also occurs regardless of the number of tracks... even a single track session will be effected.

Could you please advise on possible steps to correct?

So far we've reset windows (10), reinstalled sound drivers, and reinstalled bandlab and cakewalk. Tried without any anti-virus, run as administrator etc.

I've make a support ticket for this but thought I ask here as well in case anyone else has come across this issue.

Thank you for help!

Mark

Edited by sparticus
Changing title to solved

Share this post


Link to post
Share on other sites

Please detail which precise plugins are loaded into any of these problematic projects.

Are you using an audio interface?  If so, what driver mode are you using? (ASIO?)  What are the ASIO Buffer Size and Sample Rate as set while in one of these problematic projects?

Thanks, 

Bob Bone

 

Share this post


Link to post
Share on other sites

Thanks Bob,

The plugins of issue are all the plugins that come with the latest standard installation of cakewalk (except for the sonitus plugins), all of the pro channel plugins, and it also has the same issue with TDR Nova EQ plugin. 

We don't record with it so no interface. We're using simply mixing the various stems we've recorded separately in the studio.

Mark

Share this post


Link to post
Share on other sites

The 'Internal' clock source setting in Cakewalk means the PC system clock, and is only applicable to pure MIDI projects driving direct-monitored, external hardware synths. Any audio in the project (including the audio metronome) will automatically force the clock source back to Audio, meaning Cakewalk is using the sample clock from the interface drivers specified as Playback and Record Timing Masters in Preverences > Audio > Drivers.  So the first thing to do  is make sure those are referencing the correct interface drivers. The Hotfix mostly affected systems using WASAPI driver mode, but you should definitely install that in any case as Steve suggested.

Sometime the quickest way to get the audio setup into a happy state when you've been tweaking things is to rename AUD.INI, and let Cakewalk build a new one with default settings. If that fixes the problem, you can compare the renamed one to the new  one to see what changed.

C:\Users\<username>\AppData\Roaming\Cakewalk\Cakewalk Core

Sonitus FX are DX plugins whereas the ones you're having problems with will likely all be VST plugins, so there's a key difference there, but I can't say I've heard of issue affecting only VST plugins before.

 

Edited by David Baay

Share this post


Link to post
Share on other sites
On 12/7/2019 at 12:52 PM, scook said:

Using 2019-11 build 54? Install the hotfix

 

Thank you! The hotfix corrected this issue.

  • Like 1

Share this post


Link to post
Share on other sites

I just stated using SSL EQ and SSL Comp. These two plugins are creating distortion as well.  Odd thing is, I used these on a different Cakewalk project just yesterday with no issues using these two plugins. But on this newest project bada bing...there it is. I just exported the track to give an sample of what I'm hearing. The exported track does not have the distortion on it. Odd.

I'm running Windows 10

Cakewalk By Bandlab 2021.12 (Build 102, 64 bit)

 

**** Note: Well I experimented after posting this.   I changed my buffer size and it cleared up the issue.

Edited by Dana Elston

Share this post


Link to post
Share on other sites
7 hours ago, Dana Elston said:

I just stated using SSL EQ and SSL Comp. These two plugins are creating distortion as well.  Odd thing is, I used these on a different Cakewalk project just yesterday with no issues using these two plugins. But on this newest project bada bing...there it is. I just exported the track to give an sample of what I'm hearing. The exported track does not have the distortion on it. Odd.

I'm running Windows 10

Cakewalk By Bandlab 2021.12 (Build 102, 64 bit)

 

**** Note: Well I experimented after posting this.   I changed my buffer size and it cleared up the issue.

Glad you got it sorted out.  I always record with my ASIO Buffer Size set to 128 samples, or 64 samples, or 32 samples.  Then, when I have finished tracking/recording, and move on to mixing/mastering, I always up my ASIO Buffer Size to either 1024 or 2048 samples, depending on which of my audio interfaces I am using.

Mixing/Mastering is not adversely affected by the latency incurred from the larger buffer size(S) I set it to, for mixing/mastering, and there are multiple plugins that use Linear Phase or "Look-Ahead Processing", where having a large ASIO Buffer Size gives those more 'robust' plugins enough 'room' (buffer size) to properly do their processing.

Pretty much until the end of time, you will do best by recording with an ASIO Buffer Size of 128 or less, and then when mixing/mastering, set the ASIO Buffer size to a large value, and if additional recording needs to occur, you will change the buffer size up to either 1024 or 2048.  It is simply part of the regular processing , generally speaking, to switch between small and large buffers.

Bob Bone

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
On 2/10/2022 at 1:18 AM, Robert Bone said:

Glad you got it sorted out.  I always record with my ASIO Buffer Size set to 128 samples, or 64 samples, or 32 samples.  Then, when I have finished tracking/recording, and move on to mixing/mastering, I always up my ASIO Buffer Size to either 1024 or 2048 samples, depending on which of my audio interfaces I am using.

Mixing/Mastering is not adversely affected by the latency incurred from the larger buffer size(S) I set it to, for mixing/mastering, and there are multiple plugins that use Linear Phase or "Look-Ahead Processing", where having a large ASIO Buffer Size gives those more 'robust' plugins enough 'room' (buffer size) to properly do their processing.

Pretty much until the end of time, you will do best by recording with an ASIO Buffer Size of 128 or less, and then when mixing/mastering, set the ASIO Buffer size to a large value, and if additional recording needs to occur, you will change the buffer size up to either 1024 or 2048.  It is simply part of the regular processing , generally speaking, to switch between small and large buffers.

Bob Bone

 

 

Thank you for that sir. I had not heard of this before. I really appreciate this info!

  • Like 1

Share this post


Link to post
Share on other sites
18 hours ago, Dana Elston said:

Thank you for that sir. I had not heard of this before. I really appreciate this info!

I rather poorly worded my earlier comments on how to set the ASIO Buffer Size, so let me try again:

1) When recording, set the ASIO Buffer Size to 128 or less

2) When mixing/mastering, set the ASIO Buffer Size to 1024 or 2048 *

*  When you find out, in mixing, that you have to go back and do some additional recording, you will want to set the ASIO Buffer Size back down to 128 or less, HOWEVER, there is a potential challenge when you do that.  IF you have inserted any effects plugins that are designed to work with large ASIO Buffer Sizes, then trying to record with a small buffer size may cause audio issues.  You can temporarily turn off individual effects that require large buffers to work, such as those plugins that use Linear Phase processing, or ones that use "look-ahead" processing (convolution reverb effects, for example), and then turn them back on when you are done with the additional recording and ready to resume mixing/mastering.  You can also temporarily bypass ALL effects, by clicking on the FX button (to the right of the Transport Module).  Clicking the FX button will bypass all effects, and clicking it again, after completing the additional recording, will engage all plugins again.  A third option would be to temporarily turn off the effects that require a large buffer size for their processing, and if needed, insert some kind of similar effect(s) to the ones you turned off, then delete them when done with the additional recording.

Sorry for any confusion at all, with the above explanation, or my earlier one.

Best of luck to you having smooth recording sessions - if you have any additional questions abou this, I will keep an eye for for them, and will respond as quickly as I can. :)

Bob Bone

 

  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...