Jump to content
Morten Saether

2019.11 Feedback

Recommended Posts

Further to an earlier post about playback latency since 2019.11,in my case this involves the use of certain T-Racks5 plugins,where about 1/2 a beat's worth of playback latency has been introduced that was not apparent on 2019.09.Worst offender is the T-Racks5 Linear Phase EQ which when temporarily disabled in the FX bin removes any additional latency.Has anyone else observed this effect? The issue is there on both legacy and new projects containing this plugin.Are there some settings that need to be reset? Audio interface is a Focusrite Solo 3rd generation,which was functioning without issue before the new build.

Thanks again,

Neil

Share this post


Link to post
Share on other sites

Hi Neil.

As far as I know, any Linear Phase EQ introduces extra (and mos of the time, no minor) latency . That's the cost of avoiding the phase shifting.

I use the Fab Filter Pro 3  EQ, and in the documentation this  is clearly said . And I also read the same advice related to the Linear Phase principle itself. So...what I want to mean is that this is not a bug or defect of the plugin, but the way it is supposed to be and work.  

  • Like 1

Share this post


Link to post
Share on other sites
On 11/26/2019 at 9:29 PM, Morten Saether said:

Hi all - please use this topic to post feedback specific to 2019.11. Release-specific feedback is valuable to us, and consolidating it in a single topic is extremely helpful. Thanks in advance!

2019.11 Highlights

2019.11 Release Notes

Online documentation of new features

The hot fix did nothing to fix the freezing issue, I had to go back to the previous version.

Share this post


Link to post
Share on other sites

I usually skip hotfixes and wait for regular update but...

There's something funny going on with my project tempo.

When i open a project with recorded midi clips the tempo says 240. I've never saved anything with that tempo. I test the 240 tempo sometimes on clips as experiment. I suspect it could be stuck from what i did before opening the project but...

When i play my midi clips at 120 tempo it annoys me because i don't remember i played it so slow.

When i play my midi clips at 240 tempo it annoys me because it goes just a tiny bit too fast.

Apart from that it seems fine,though i haven't recorded anything in the last month.

Share this post


Link to post
Share on other sites

@HeatherHaze @jesse g as you probably have discovered by now the reason for the display changes were because you had a workspace set that was globally overriding your settings. We're going to be doing some video's on workspaces to help explain this better as well.

Regarding full screen mode, we're planning on disconnecting that completely from workspaces or the project settings. FS mode should be only controlled by the button in the UI. Not sure if we will get to it for the hotfix but its on the radar.

This happened because on some systems  the installer and app got confused into thinking it was a first time install and launched the onboarding process which suggested the "Basic" workspace as well as may have defaulted to WASAPI.  As a result of this after installing  the  .11 release  the app was set up to run the basic workspace which sets up the initial view of the app. The user could have changed it in the onboarding process but if you zipped through it without reading the text then this is likely what happened.

I wanted to clarify that this was not intentional and we have fixed this for the upcoming hotfix, so very sorry for the inconvenience and confusion.   After installing .11 it should have been set to exactly the way you had Cbb set up. i.e if you had no workspace to start with it should have been left the same way. To go back to your preferred settings you have two choices. Either save versions  of a workspace that fits your workflow OR set the workspace to none, in which case it will no longer override settings. You can always go back and tweak a custom workspace later. 

 

Share this post


Link to post
Share on other sites
11 hours ago, kagunmarx said:

The hot fix did nothing to fix the freezing issue, I had to go back to the previous version.

@kagunmarx what freezing issue? I don't see any post from you describing this.

Share this post


Link to post
Share on other sites

I did the update about a week ago.  I've taken notice that the "S" timeline problem kind of went away.  I was doing some editing a few days ago and I still saw the "S" on the timeline, but it didn't seem to get in my way anymore, like it used to.  I don't know whether you improved that or I'm just subconsciously doing things differently, but for me it's no longer an issue.

Early in this thread there was a point brought up about the MIDI buffer size.  Mine has been set to 50 since I ran the update.  I recently upgraded my RAM from 8GB to 16 and haven't since heard the dreaded "clicking" sound, even when running as many as 11 plugins.  Immediately after running the update to 2019.11 I ran a project that only had 4 VSTis and heard a bit of clicking.  Keep in mind that I didn't reboot the PC after the update.  I just went into the project.  I since ran the 11 plugin project and that still ran fine.  All I can say is that I'll keep my eyes on this.  If it happens again, I'll notify you.

Thank you so much!

:)John B

Share this post


Link to post
Share on other sites
On 12/1/2019 at 9:12 PM, TheSteven said:

I've been having ASIO problems since installing the 2019.11 update.  I later installed the HotFix and but still having same issues.

Before installing I had my latency set somewhere over 20msec and rarely had dropout issues.
Now Cakewalk is almost unusable - even with Buffer Size/Latency maxed (as shown below) I can play some projects and not others.
Case in point - I've got one project that has one audio track (electric guitar) that has IK Multimedia's Amplitube 4 loaded using the "Live Magic 1986" patch from the Brian May Collection and it won't play for over a second without stopping due to 'Audio Engine Dropout'. 
This wasn't an issue before the 2019.11 update, I could use any patch in the BM Collection with no dropouts.

@TheSteven Some follow up questions.

  1. Have you confirmed that you were using the exact same audio latency as the prior release?
  2. What driver mode were you using in both .9 and .11
  3. What dropout code is being reported when you see the dropout message. In .11 it automatically restarts playback after a dropout by default so I'm curious why you got the dropout message, unless you explicitly set RestartEngineAfterDropout to False in preferences / configuration file.
  4. If the dropout code is 9 then please try raising your MIDI buffer size (prepare using xxx millisecond buffers) in preferences MIDI | playback and recording, to a value of 100. Retest your project after that. My hunch is that this is your issue.

 

Share this post


Link to post
Share on other sites
34 minutes ago, Johnbee58 said:

I did the update about a week ago.  I've taken notice that the "S" timeline problem kind of went away.  I was doing some editing a few days ago and I still saw the "S" on the timeline, but it didn't seem to get in my way anymore, like it used to.  I don't know whether you improved that or I'm just subconsciously doing things differently, but for me it's no longer an issue.

Early in this thread there was a point brought up about the MIDI buffer size.  Mine has been set to 50 since I ran the update.  I recently upgraded my RAM from 8GB to 16 and haven't since heard the dreaded "clicking" sound, even when running as many as 11 plugins.  Immediately after running the update to 2019.11 I ran a project that only had 4 VSTis and heard a bit of clicking.  Keep in mind that I didn't reboot the PC after the update.  I just went into the project.  I since ran the 11 plugin project and that still ran fine.  All I can say is that I'll keep my eyes on this.  If it happens again, I'll notify you.

Thank you so much!

:)John B

@Johnbee58 yes the select cursor was improved in this release.
Regarding the MIDI buffer size please raise it to 100 msec. We've been experimenting with ideal default that isnt too big and I now think that 100 might be a better default.

Share this post


Link to post
Share on other sites
On 12/3/2019 at 3:29 AM, HeatherHaze said:

You're welcome.  I recently found a new problem, with a new solution.  The problem is that even though I managed to get my workspace looking more or less right, all my track icons have reset.  What a pain in the  *****!  So the new solution is to set my workspace to "none" and it appears that my projects load in normally without trying to apply a new workspace.  Much better and simpler solution.  Unfortunately I've already resaved a couple projects with tons of track icons, so now I have to go reset all those.  Oh well...

@HeatherHaze thanks for all your feedback. What did you mean by "all my track icons have reset"? Do they get hidden or changed? We haven't been able to reproduce this so if you can give us a recipe it would be useful. Over time we're working on making workspaces and the rest of the user interface more fluid and intuitive so keep the feedback coming.

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, huviolan said:
22 hours ago, Neil Cummins said:

Further to an earlier post about playback latency since 2019.11,in my case this involves the use of certain T-Racks5 plugins,where about 1/2 a beat's worth of playback latency has been introduced that was not apparent on 2019.09.Worst offender is the T-Racks5 Linear Phase EQ which when temporarily disabled in the FX bin removes any additional latency.Has anyone else observed this effect? The issue is there on both legacy and new projects containing this plugin.Are there some settings that need to be reset? Audio interface is a Focusrite Solo 3rd generation,which was functioning without issue before the new build.

Thanks again,

Neil

Hi Neil.

As far as I know, any Linear Phase EQ introduces extra (and mos of the time, no minor) latency . That's the cost of avoiding the phase shifting.

I use the Fab Filter Pro 3  EQ, and in the documentation this  is clearly said . And I also read the same advice related to the Linear Phase principle itself. So...what I want to mean is that this is not a bug or defect of the plugin, but the way it is supposed to be and work.  

True and valuable info about linear phase eqs introducing more latency, question is what has been changed that it was not apparent in in pre-2019.11 releases, only now?

Edited by chris.r

Share this post


Link to post
Share on other sites
Just now, chris.r said:

True and valuable info about linear phase eqs introducing more latency, question is what has been changed that it was not apparent in in pre-2019.11 releases, only now?

@chris.r we need to make sure that you are actually experiencing different latency from 09.
There can be different causes for latency: 

  1. PDC in plugins
  2. audio latency as set in the driver panel in ASIO
  3. MIDI buffer size (prepare using xxx millisecond buffers) in preferences MIDI | playback and recording
  4. If PDC override is off on the toolbar then you wont hear PDC delay when playing. Make sure you are comparing with that on.

You should confirm that 1 and 2 are the same in your test. 3 was changed in this release but that only impacts how often MIDI data is prebuffered for playback. It will not affect realtime MIDI performance or audio performance in any way.

Share this post


Link to post
Share on other sites

Hi @Noel Borthwick I was only replying in reference to @Neil Cummins's issue. I didn't update to 2019.11 yet but I use T-RackS plugins and that made me feel involved with the issue. But since I'm still on the previous release I can check T-Racks' Linear Phase EQ now and after updating Cakewalk and give back the results. Stay tuned.

Just waiting for all fixes to get backed in... my presonal awkward approach that saved me lot's of trouble over the years ;).

Share this post


Link to post
Share on other sites
On 12/2/2019 at 3:55 PM, Zaquria said:

I am having issues with playback since updating.

This seems to happen with Audio or Instruments. When playing back, the audio on a single instrument or audio track with plugins will intermittently cutout at certain points and start playing again after a few seconds. Normally this would suggest that I either have a bad plugin or a plugin which uses a lot of CPU (Mastering EQ type), but in these cases these are plugin which I use daily and wouldn't cause this issue.

I also get a lot of intermittent cracking when playing as well.

I then recreated the same song in Reaper, with the settings (Sample Rates etc), same Audio stems, instruments, midi, and plugin without any issues, no drop-out's in audio or cracking at any part of play back.

I use Pre-Sonus AudioBoxiTwo interface, i7 8700k overclocked at 5g, 48 gigs memory, and my projects are on a SSD drive (If that means much).

Any help appreciated. :)

@Zaquria this symptom seems to indicate that the system is dropping out and restarting. In 2019.11 by default the application will restart playback automatically if it senses certain kinds of dropouts. Please try turning off the restart engine after dropout option and see what dropout code gets reported - assuming that it drops out after that. One thing to also try is raising your MIDI playback buffer size to 100.

cfg.PNG

Share this post


Link to post
Share on other sites
3 minutes ago, chris.r said:

Hi @Noel Borthwick I was only replying in reference to @Neil Cummins's issue. I didn't update to 2019.11 yet but I use T-RackS plugins and that made me feel involved with the issue. But since I'm still on the previous release I can check T-Racks' Linear Phase EQ now and after updating Cakewalk and give back the results. Stay tuned.

Just waiting for all fixes to get backed in... my presonal awkward approach that saved me lot's of trouble over the years ;).

@chris.r thanks for helping out. I understand wanting to wait. If you would like to try a more recent build of the hotfix contact me. We should be pushing out another build in a day or so. To try the .11 release assuming you are running .9 you can just back up the "C:\Program Files\Cakewalk\Cakewalk Core" programs folder and restore it if you need to go back after installing. Thats the easiest way to A/B the two.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Noel Borthwick said:

@HeatherHaze thanks for all your feedback. What did you mean by "all my track icons have reset"? Do they get hidden or changed? We haven't been able to reproduce this so if you can give us a recipe it would be useful. Over time we're working on making workspaces and the rest of the user interface more fluid and intuitive so keep the feedback coming.

Hey Noel.  They all reverted to their default icons.   For example, I have projects with full orchestra sets, and  each track had been set up with the appropriate track icons.  After updating, when  the workspace came up all the icons had been reset to default.  I discovered if I set the workspace to "none" and then bring up the project, everything looks as expected (including track icons).    I assume the track icons are  being saved as part of a workspace.    

Share this post


Link to post
Share on other sites
4 minutes ago, HeatherHaze said:

Hey Noel.  They all reverted to their default icons.   For example, I have projects with full orchestra sets, and  each track had been set up with the appropriate track icons.  After updating, when  the workspace came up all the icons had been reset to default.  I discovered if I set the workspace to "none" and then bring up the project, everything looks as expected (including track icons).    I assume the track icons are  being saved as part of a workspace.    

What view's track icons are you seeing missing? Track View, Console View? 

Share this post


Link to post
Share on other sites
1 hour ago, Noel Borthwick said:

@Zaquria this symptom seems to indicate that the system is dropping out and restarting. In 2019.11 by default the application will restart playback automatically if it senses certain kinds of dropouts. Please try turning off the restart engine after dropout option and see what dropout code gets reported - assuming that it drops out after that. One thing to also try is raising your MIDI playback buffer size to 100.

cfg.PNG

I'm sorry, maybe I wasn't clear enough in my issue description. The issue I am having is not that the whole song is cutting in or out, this is happening only to certain instruments within the song, while all the other instruments are play, one will cut-out for a couple of seconds  and then just start playing again.

I can replicate this behaviour by simply adjusting a clips length, by moving a clip while the song is playing.

I will certainly try your suggestions to see if these make any difference and let you know.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...