Jump to content
Sign in to follow this  
petemus

[SOLVED] Exporting suddenly started crashing CbB with the latest version

Recommended Posts

I'm suddenly experiencing constant crashes with exporting, also with projects that have been exporting ok earlier. Playing back the entire project works always ok, but export shows an error, sometimes in Windows components and sometimes plugins, but there seems to be no pattern to this. Also, trying to freeze instrument tracks might succeed, but there's a crash after that trying to freeze more instruments, or just starting playback. Sometimes CbB just quits with no error message box, sometimes it shows a message box.

I took a look at the debug dumps with WinDbg and the cause of every crash was "heap corruption". 

@Noel Borthwick, what do you need for checking it out? The debug dumps and the project file? Does audio need to be included as well?

Thanks,

        -Pete

Edited by petemus
Title change

Share this post


Link to post
Share on other sites

If you are getting heap corruption it's likely one of your plugins corrupting memory. So not something we can solve necessarily. 

Try and isolate which plugin causes it be removing plugins one by one and exporting after each step.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the reply, Noel! I suspected it would be some plugin myself as well. I had added a couple of instances of MCabinet by Melda, but their stuff has never given me any problems. It's a new one though, so you never know.

I'll go through the process of elimination for the latest plugins added and see what I find.

    -Pete

  • Like 1

Share this post


Link to post
Share on other sites

Just FYI, I got the export working again:

I'd changed the BounceBufSizeMsec in the configuration file to value 100 at some point "to improve export speed". The export speed was fast after that, alright, because the export crashed for whatever reason pretty fast right after starting it.

I set the value back to 0 which seemed to remedy the situation. Two bounces got right to the end as usual. I needed to disable no plugins in the process.

     -Pete

Share this post


Link to post
Share on other sites

Interesting. Thanks for troubleshooting, @petemus. All that setting does is set the buffer size to that prior to the bounce and then restore it post bounce. Can you try and set your audio device to the same latency if it goes that high and retry the bounce? This should do essentially the same thing so it will be interesting to know if the problem recurs.

Share this post


Link to post
Share on other sites
2 hours ago, Noel Borthwick said:

Interesting. Thanks for troubleshooting, @petemus. All that setting does is set the buffer size to that prior to the bounce and then restore it post bounce. Can you try and set your audio device to the same latency if it goes that high and retry the bounce? This should do essentially the same thing so it will be interesting to know if the problem recurs.

Thanks again for the reply, @Noel Borthwick!

I noticed I said "two bounces got to the end" when I meant "two exports".

I can try to fiddle with the settings. The buffer size of my Scarlett 2i2 3rd Gen was set to max (1024 samples), when BounceBufSizeMsec was 100. That buffer size is in milliseconds and the Focusrite's is samples - isn't the max audio device latency then much less tham 100 ms at 1024 samples?

image.png.89ee47f24c0cdb0949743323c90f4e1c.png

When the export was crashing, I noticed that before there was any progress shown on the "Mixing down audio" indicator, Cakewalk took a couple of seconds seconds as if it was allocating a big chunk of memory or something. When BounceBufSizeMsec was back to 0, there wasn't such a phenomenon and the mixdown began right away - and progressed to the end.

 

Share this post


Link to post
Share on other sites

100ms is a lot although I recall Noel recommending an upper limit of 200ms at one time. Mine's been at 20ms for years without issue.

Share this post


Link to post
Share on other sites
2 hours ago, David Baay said:

100ms is a lot although I recall Noel recommending an upper limit of 200ms at one time. Mine's been at 20ms for years without issue.

It might just be that I didn't have the slightest clue about what I was doin' with it...  😊   No touchy-touchy, if no understand!

Share this post


Link to post
Share on other sites

100 ms isn't that much for bounce. Plugins should be able to tolerate any buffer size.  I suspect one of the plugin's in the project has a bug with large buffer sizes and is corrupting memory when its set high.  
Since your audio interface won't go higher than 20 msec you can try switching to WASAPI exclusive or MME. Both those modes allow the audio buffer size to be set as high as 200 msec. If the export crashes with those settings then we know that its related to some plugin in the project..

Share this post


Link to post
Share on other sites
2 hours ago, Noel Borthwick said:

100 ms isn't that much for bounce. Plugins should be able to tolerate any buffer size.  I suspect one of the plugin's in the project has a bug with large buffer sizes and is corrupting memory when its set high.  
Since your audio interface won't go higher than 20 msec you can try switching to WASAPI exclusive or MME. Both those modes allow the audio buffer size to be set as high as 200 msec. If the export crashes with those settings then we know that its related to some plugin in the project..

I think I'll leave it at zero now that it works again. Export can take as long as it likes if it just doesn't crash. 😁 There were no problems before I started to adjust the buffer value, so I don't think tinkering with switching driver modes is necessary. I might still check again with the larger buffer, if it crashes in ASIO mode.

Thanks!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...