Jump to content
Sign in to follow this  
jono grant

Plugin Delay Compensation issue

Recommended Posts

2 hours ago, jono grant said:

Thanks!

In my preferences, the option "Always echo current midi track" was enabled. 

Is that likely the issue then? I've turned it off, will see if the problem persists and report back I guess.

PS. Yes, if I need to punch in a lot, I'll set up the midi track twice, so I can record to the PDC override track and move the recorded midi onto the 2nd track that has no live input button selected.

It would be great if they could figure out a way to only apply the PDC override on the input itself, rather than the track so that already recorded data would play in sync and only your live instrument would have the PDC override on it.

I'm still not 100% sure why "Always echo current midi track" is needed in the first place.

J

 

"Always echo" is a kind of useful when there are several instruments, for fast switching between them using the only MIDI keyboard. Changing the instrument is a matter of selecting another track then and that can be easily automated.

Usually proposed way is avoiding plug-ins with delays till the end phase of mixing or even till mastering, so auto echo is normally not an issue. Some plug-ins have really huge delays, up to 1 second. Mixing in such environment is almost impossible, any parameter in the chain before such plug-in takes 1 second before it is audible.

I was so used to this option that I was missing it in other DAW. Especially when achieving the same effect requires 3 different track options  set, for each track in question.

Share this post


Link to post
Share on other sites

Logically, PDC can only work by adding delay. So, conversely, overriding it can only work by subtracting delay. It's not possible to subtract delay from  a real-time input, so PDC and PDC override have to work at the output. But the issue with existing vs. real-time MIDI could potentially be handled better by delaying the output of existing  MIDI to the synth rather than delaying the audio output from the synth.

'Aways Echo Current' facilitates the composing process by allowing a user to switch instruments simply by changing track focus. In conjunction with 'Allow MIDI Recording without an Armed Track', the creative process can proceed very quickly.  A major downside of this feature, however, is that a MIDI track that initially has no input assigned will default to All Inputs - Omni when it gets auto-echoed, which can cause a lot of unexpected problems if you don't realize it. Personally, I just don't work fast enough for it to be of much value to me, and I like to have control over what's being echoed at any given moment, regardless of where the focus is.

 

Share this post


Link to post
Share on other sites

I do not know how delaying MIDI an help with PDC. MIDI is bound to input audio. "Precalculating" not live tracks with delays is from my knowledge the only know way to deal with PDC better (eliminates the problem almost completely, except open question what to do when live track has a send to delayed bus).

No possibility to permanently set MIDI input to "None" and no possibility to permanently disabled VST MIDI output (or at least not include it into "All" stream) are 2 from many long standing bugs...

"Allow MIDI Recording without an Armed Track" (record arm by echo) sounds as logical as "Record arm but don't record" (monitor without recording) in one another DAW 😀

Share this post


Link to post
Share on other sites

"Always echo current midi track" doesn't seem to fix or relate to this. I think that just automatically makes a midi track live when you click on it. When I turned that feature off, it just made it so that when you click a midi track it didn't go into live input and you had to click the input monitoring button manually. But the sync issue still persisted.

Gotta be something causing the random "mid track out-of-sync when PDC override is engaged on another live input track...

Anyone?

Thanks

Share this post


Link to post
Share on other sites

The bottom line here is that PDC override works as it should on a live input track, but something is causing an unrelated midi track to also act as if it's also set to have a live input and it doesn't.

I'm becoming more confident this is a bug in CBL.

Believe me, I know the work-arounds, I'm just tired of using them. The PDC button itself says when you hover over it: "override automatic plugin delay compensation on live inputs" therefore if you only have one live input, it should be the only one affected by PDC override and it isn't.

(Edit) I should also mention that I do realize the PDC override button affects the entire instrument, so, if it were Kontakt for instance, and you had 16 channels going in Kontakt, they would all have the override even if you only had one midi track with a live input. (which also kinda sucks...) :( 

Edited by jono grant
added text

Share this post


Link to post
Share on other sites

EDIT: Nevermind. Had missed the first of your two updates.

Edited by David Baay

Share this post


Link to post
Share on other sites
5 hours ago, azslow3 said:

I do not know how delaying MIDI an help with PDC. MIDI is bound to input audio. "Precalculating" not live tracks with delays is from my knowledge the only know way to deal with PDC better

Maybe more precise to say say 'offset' the existing MIDI. In other words, 'lie' to the synth, making the timestamps later so the audio renders later without actuallly delaying the audio output. So you could offset the existing MIDI while passing live input MIDI through immediately, and have both in sync with plugin-delayed tracks.

 

Edited by David Baay

Share this post


Link to post
Share on other sites
1 hour ago, jono grant said:

"Always echo current midi track" doesn't seem to fix or relate to this. I think that just automatically makes a midi track live when you click on it.

Well, this option automatically makes one MIDI track live.  In my tests always. Without clicking on anything.

If you have no difference between this option on and off, something is really broken.

If you try the test I have described before, with 3 tracks, do you get expected result? If yes (so no problem), there is probably some fancy routing in your project.

Share this post


Link to post
Share on other sites
5 minutes ago, David Baay said:

Maybe better more precise to say say 'offset' the existing MIDI. In other words, 'lie' to the synth, making the timestamps later so the audio renders later without actuallly delaying the audio output. So you could offset the existing MIDI while passing live input MIDI through immediately, and have both in sync with plugin-delayed tracks.

 

Got it. So opposite idea from "early" processing, with "late" processing for the content in live track.

But if CbB developers will manage to calculate correct delay difference between live and other, why not do "early" processing and remove PDC button (since there will be no need for it)? 😉

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...