Jump to content
cclarry

Waves Black Friday Early Access Deals

Recommended Posts

1 hour ago, cclarry said:

There is the Dave Clarke Bundle that has Aphex for $83.51 with code YNY23
Your upgrade price from Koby should be cheaper.  Better than spending $27 on WUP
and there are also some other decent plugins in the bundle

Thanks, Larry.

The problem is I already have plugins from this bundle I am interested in. So anyway it would cost me more than pricey WUP (as nothing new what I would want to use :(

Sorry, I was not precise enough in pointing out my concerns.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, cclarry said:

Ok, if you want to WUP ALL of your current plugins, buy a new, cheap plugin, then
go to your Waves account, select all of your plugins, including the NEW one.  This way WUP is
renewed for 1 year, for ALL of your plugins from the LAST WUP expiration date, that
being the expiration date of the NEW plugin.  THIS gives you 2 years of WUP for the 
price of ONE, plus the cost of the new plugin, but it saves you LOTS of money!!!

Larry,

 

I tried this, but the there is a cap at $240.00 so when I get to that amount, it won't allow me to WUP past that with all of my plugins.   Maybe I am doing something wrong.

I need a WUP Video on how this is done.  (I learn best by seeing) 😎 Sorry lady  🐴 am I in your way?

Share this post


Link to post
Share on other sites
45 minutes ago, jesse g said:

Larry,

 

I tried this, but the there is a cap at $240.00 so when I get to that amount, it won't allow me to WUP past that with all of my plugins.   Maybe I am doing something wrong.

I need a WUP Video on how this is done.  (I learn best by seeing) 😎 Sorry lady  🐴 am I in your way?

At the top there is a check box for "Select All", which should select all of your plugins. 
Once that has been selected the MAX you can pay is $240, but that $240 should 
cover all of your plugins.  Also, remember, you get a Waves Voucher for the full
dollar amount you spend.

Edited by cclarry
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, cclarry said:

At the top there is a check box for "Select All", which should select all of your plugins. 
Once that has been selected the MAX you can pay is $240, but that $240 should 
cover all of your plugins.  Also, remember, you get a Waves Voucher for the full
dollar amount you spend.

It looks like they're on to that loophole.  Out of curiosity, I tried it in my account and got this...  WUPping has never looked so unappealing... 

 

 

WUP-01.jpg

WUP-02.jpg

  • Sad 1

Share this post


Link to post
Share on other sites
33 minutes ago, mibby said:

It looks like they're on to that loophole.  Out of curiosity, I tried it in my account and got this...  WUPping has never looked so unappealing... 

Mine looks very similar.  However, this includes WUPing plugs that are currently covered.  If you de-select these and choose only those expired , it will cap at $240.  I'll wait patiently for the WUP sale (if and when...)

  • Like 2

Share this post


Link to post
Share on other sites

They obviously have figured out my "secret" and put the kabosh on it...

Another ding against them!  LOL

  • Like 2
  • Haha 1
  • Sad 3

Share this post


Link to post
Share on other sites

Yep Larry, they are on to ya. I can select as many expired WUP plugins as I want and it all caps at $240. Select one that is still current and up it goes!! 

It was good while it lasted!!

  • Like 1

Share this post


Link to post
Share on other sites
Just now, Grem said:

Yep Larry, they are on to ya. I can select as many expired WUP plugins as I want and it all caps at $240. Select one that is still current and up it goes!! 

It was good while it lasted!!

It was indeed!   Well...at last I can stop typing all of that...so there's that 😜

  • Haha 5

Share this post


Link to post
Share on other sites

Despite all this WUP stuff, I still love Waves plugins. I can't even remember ever trying one that I didn't like. And I can't remember how many times I was surprised when I opened a fugly plugin to find out just how damn good it was. C1 reminds me of this everytime I use it. 

  • Like 2

Share this post


Link to post
Share on other sites
3 hours ago, cclarry said:

Also, remember, you get a Waves Voucher for the full
dollar amount you spend.

I was going to ask this because I always forget. This makes it a lot easier to take.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Piotr said:

The is one reason for me unfortunately. It is annoying factor...

I would like to have more compact and simpler environment without V9 shells, and easier management having only V10 (and maybe V11)

I'd just go to VST settings, and change the Scan Options to Manual, then you scan only when you add something new.

There is always the chance that if you do the update you will switch to a more annoying v9 shell failure (what I have to deal with everytime I scan the plugins) where it fails 3 times due to v9 (which do not work at all).  

 

Grass isn't always greener.  Only advantage there would be customer support might actually walk you through it if you pay them  to get you to v11 across the board.  

 

If you do WUP, you don't have the option to get Aphex v10, which would put you into both v10 and 11 territory unless you went all in with WUP of everything to 11.  ☹️

 

Edited by Brian Walton
  • Like 1

Share this post


Link to post
Share on other sites
10 minutes ago, Brian Walton said:

Only advantage there would be customer support might actually walk you through it if you pay them  to get you to v11 across the board.  

That's the most annoying part about WUP to me. I have never and will never use customer support but they want me to pay for it anyway. That's why I pay for the internet.

Share this post


Link to post
Share on other sites
2 minutes ago, RSMcGuitar said:

That's the most annoying part about WUP to me. I have never and will never use customer support but they want me to pay for it anyway. That's why I pay for the internet.

The only time I've needed customer support was when the v9 to v10 update screwed up all my plugins.  Admittedly, they DO make some good plugins though...  🤔

  • Like 1

Share this post


Link to post
Share on other sites

There is a Version Compatibility tool in the new WC. Has anyone having trouble with V9 and V10 plugins tried that?  

 

[edit]

The latest WC version is 11.0.41 and it's called Version Organizer under: Settings/Maintenace/Version Organizer.

Reading on Waves site I see that trouble can come from any two versions from V9, V10, V11 of the same plugin being installed. IOW if you have C1 V9 and C1 V11 installed it will give you trouble.

From what I can understand the Version Organizer takes the older plugin out of the scan path, or something like that.

Edited by Grem

Share this post


Link to post
Share on other sites
1 hour ago, RSMcGuitar said:

That's the most annoying part about WUP to me. I have never and will never use customer support but they want me to pay for it anyway. That's why I pay for the internet.

That is easy when things actually work, like most VST providers.

However, WAVES is the only VST maker I've ever needed legitimate customer support to get them to actaully install and authorize properly.  v9 + v10 still do not properly co-exist on my machines so I just treat v9 as abandonware.  

While software instaliation isn't my specific area of expertise, I manage a fleet of computers as part of my day to day job, so I'm not exaclty a novice in the area.  

Share this post


Link to post
Share on other sites
5 hours ago, Fwrend said:

Mine looks very similar.  However, this includes WUPing plugs that are currently covered.  If you de-select these and choose only those expired , it will cap at $240.  I'll wait patiently for the WUP sale (if and when...)

I guess I will just wait until all of my Waves plugins expire and then,  I will WUP them all for just $240.00.  This will do me just fine unless Waves change their policy and present me with a WUP limit on expired plugins. 🥴

  • Like 3

Share this post


Link to post
Share on other sites
4 hours ago, Grem said:

Version Organizer

They introduced that after v10 was released for obvious reasons. If I recall, it didn't work reliably either.  I didn't get back up and running until a knowledgeable Tech Support guy told me some folders to delete, then run something or other.  Hmmm... maybe I deteted the folders then ran the Version Organizer??  I forget now, especially with all the myriad of different things I tried at the time.  I think I posted the solution on here at some point... 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...