Jump to content
josecneto

Korg NanoKONTROL2 - Sonar does not recognize volume faders anymore

Recommended Posts

Hi,

I use a Korg NanoKontrol2 with Sonar X2 for a long time with no issues. Recently I disconnected the gadget to try some Ipad tweaking, and when I connected back to my pc I discovered that the faders will not be recognized anymore by Sonar. I reset the device, connect as Mackie control surface as before and noticed in Console View that all pan pots, transport, mute/solo buttons are working fine but the faders not.

I checked the Kontrol with MIDI-OX and the faders are sending messages. I also tried to reset the device to factory settings and re-install Korg drivers and software but I´m getting the same issue.

Has anyone experienced this weird thing? Thanks

 

 

Share this post


Link to post
Share on other sites

Yesterday I finally got my nanoKontrol2 fully working again. I simply did the same steps I tried several times before and don't know exactly why but it's now working fine. 

Here's what I did for future reference in case someone needs it:

1- Open Sonar and remove nanokontrol2 input/output ports and delete surface control reference

2- Clean uninstall Korg NanKontrol2 driver and device

3- Uninstall Korg Kontrol Software

4- Install driver and software (in this order), shutdown windows

5- Connect and power on all my USB devices (keyboards, modules, interfaces etc) and start windows

6- Connect nanoKontrol2 pressing SET and RECORD buttons (as user manual)

7- Open Sonar and select nanoKontrol2 input and output MIDI ports

8- Start a new Sonar project and record a midi track with nanokontrol as input; move every fader/pot/button to verify some midi data is being recorded by each one

9- Close Sonar and re-open it

10- Create a new control surface using 'Mackie' to nankontrol2

11- Open a project and verified that everything is working fine.

 

Thanks for all your help. 

 

  

  • Thanks 1

Share this post


Link to post
Share on other sites
On 29/10/2019 at 20:18, Robert Bone said:

Não sei se isso ajudaria:

 

E isso é de Sweetwater:

https://www.sweetwater.com/sweetcare/articles/nanokontrol2-setup-in-sonar/

E a partir do manual do usuário para o NanoKontrol 2:

image.png.90e7891904528bcea466c211f712cdfb.png

Alguma coisa do que precede ajuda?

Bob Bone

Hello !! I have a similar problem. I did all these steps mentioned here and even then it doesn't answer either faders or knobs ... Anything else I can do to make it work?

Share this post


Link to post
Share on other sites

Sorry - I do not know - I have no familiarity with the nanoKontrol2, and all I did for my earlier post, was to pull up the blurb I posted - from the manual.

Did you read the earlier post(s) with steps to follow?

The only other thing I can think of is for you to contact Native-Instruments support.  In the past, I had called them on 2-3 occasions, and they helped me right out.  I called the main tech support in Germany, but there was one time where I called Native-Instruments in the states - might have been California, but the info for contacting them is on their web site - or at least it used to be. :)

Bob Bone

Share this post


Link to post
Share on other sites
19 hours ago, Robert Bone said:

Sorry - I do not know - I have no familiarity with the nanoKontrol2, and all I did for my earlier post, was to pull up the blurb I posted - from the manual.

Did you read the earlier post(s) with steps to follow?

The only other thing I can think of is for you to contact Native-Instruments support.  In the past, I had called them on 2-3 occasions, and they helped me right out.  I called the main tech support in Germany, but there was one time where I called Native-Instruments in the states - might have been California, but the info for contacting them is on their web site - or at least it used to be. :)

Bob Bone

I doubt if Native Instruments support would help...  the nanoKontrol 2 is a KORG product, not a Native Instruments product :)
 

On 2/19/2021 at 11:15 AM, JAMERSON JOSÉ RODRIGUES said:

Hello !! I have a similar problem. I did all these steps mentioned here and even then it doesn't answer either faders or knobs ... Anything else I can do to make it work?

Can you post a screen shot of your Control Surfaces page in preferences ( use ALT + PrtSc with the dialog up) ? e.g.:

image.png.8532db88a623c9b961f5d2febb387b07.png
 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...