Jump to content

Question

I am completely new to the world of DAWs so apologies in advance for sounding clueless.

I have just installed Cakewalk and I essentially cannot use it at all due to extreme lag with the UI. Anytime I click anything or even try to adjust the window, there is a 4-5 second delay before the action is registered. I am not sure how to fix this or even what settings I should begin to look into. To the best of my knowledge, all settings are at default, and my audio drivers are up to date. Does anyone have any idea what I might try to fix this issue?

In case it is helpful, here are the relevant specs of my PC:

  • CPU: AMD Ryzen 7 2700
  • RAM: 16 GB DDR4 3200 MHz

Like I said before, I am completely new to this stuff so please let me know if there is any other information I can provide to help diagnose the issue.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 1

What graphics card do you have? Are you using the latest drivers.

Also, with a DAW software like Cakewalk by Bandlab, you will generally get the best performance using an external audio interface.  Sure, you can use onboard sound in WSASPI mode, but a card or external audio interface that comes with its own ASIO drivers will give better performance.

Also 4-5 seconds seems a really long time (was this actually measured?).  That to me seems like a system issue that's nothing to do with Cakewalk.

What Operating system.  Is it fully patched.  Are you using the latest drivers for all of your hardware.  Actually visit the manufacturer's web sites to verify this. Don't rely on automatic driver update software.

Share this post


Link to post
Share on other sites
  • 0

After looking through the forum a bit, I wonder if I might be experiencing the same issue as in this post. 

If this is in fact the case, is it possible to resolve the issue without an external sound card? I don't have a sound card; I was hoping to be able to use the software with just on-board sound.

Edited by Evan Thomas
typo

Share this post


Link to post
Share on other sites
  • 0
4 minutes ago, Promidi said:

What graphics card do you have? Are you using the latest drivers.

Also, with a DAW software like Cakewalk by Bandlab, you will generally get the best performance using an external audio interface.  Sure, you can use onboard sound in WSASPI mode, but a card or external audio interface that comes with its own ASIO drivers will give better performance.

Also 4-5 seconds seems a really long time (was this actually measured?).  That to me seems like a system issue that's nothing to do with Cakewalk.

What Operating system.  Is it fully patched.  Are you using the latest drivers for all of your hardware.  Actually visit the manufacturer's web sites to verify this. Don't rely on automatic driver update software.

GPU is RTX 2060 8GB. OS is Windows 10 64 bit. All drivers are up to date.

I haven't experienced any issues with any other software at all (games, etc.)

I think you hinted at the solution in your post. I tinkered with the settings a little bit and found the following to fix the issue:

In preferences I changed Audio >> Playback and Recording >> Driver Mode from the default ASIO to WASAPI Shared and all of the UI latency is gone.

Just for fun, I reverted the settings back and recorded the latency times. Clocked in between 3.6 and 4.4 seconds for any action.

Share this post


Link to post
Share on other sites
  • 0
24 minutes ago, Evan Thomas said:

GPU is RTX 2060 8GB. OS is Windows 10 64 bit. All drivers are up to date.

In preferences I changed Audio >> Playback and Recording >> Driver Mode from the default ASIO to WASAPI Shared and all of the UI latency is gone.

Just for fun, I reverted the settings back and recorded the latency times. Clocked in between 3.6 and 4.4 seconds for any action.

Unrelated to your issue but Nvidia released version 440.97 a few days ago...

Looks like the issue is sorted with the driver set to WASAPI mode.

Mind you, you should plan on an external audio interface some time in the future.

Share this post


Link to post
Share on other sites
  • 0

GPU Acceleration also seems to be turned off by default.  You need to change a registry setting to enable it, unless that entry is vestigial.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Some Guy said:

GPU Acceleration also seems to be turned off by default.  You need to change a registry setting to enable it, unless that entry is vestigial.

Do you have a source for that. 

If you have a supported Graphics card (which I am sure the RTX 2060 is) then Windows 10 enables Hardware acceleration by default.  I have never had to go to the registry to enable it - even when I had a lowly GTX650ti

Just to confirm, I checked my registry and Hardware acceleration is enabled on my Windows 10 PC

Share this post


Link to post
Share on other sites
  • 0

I just wiped out the registry entries for Cakewalk and reinstalled.  GPU Acceleration in the registry is set to 0 (Disabled) by default.

Older versions of SONAR had an entry in the Preferences to Enable this.  Cakewalk may have migrated this setting on your computer if you upgraded from SPLAT or a previous version.

Unless that Registry Setting is vestigial (and, thus, ignored by the software), that is the T. 😉 

Edited by Some Guy

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...