Jump to content
Apeirofobia

Audio glitches

Recommended Posts

Hi guys.  Today I opened a session I was working on and now I'm having a lot of glitches I hadnt had before. I tried to increase the buffer size(2048) but its still happening. Any suggestions?

 

Thanks in advance

Voz 005.m4a

Edited by Apeirofobia

Share this post


Link to post
Share on other sites

A "glitch" is a buffer-starvation issue. IOW, your computer isn't able to fill the output buffers fast enough to maintain uninterrupted output. That's because it's busy doing something else.

If you can't get around it by increasing the buffer size, you need to figure out what other process is monopolizing your CPU. Unfortunately, that can have a great many causes. However, because your project played fine yesterday but not today, you have an important clue. Namely, something is different today. Determine what that is and you've solved the mystery.

Start with Task Manager and see if there are any background processes eating up CPU. If Microsoft is force-feeding updates to your computer, that can certainly do it. If there's a scheduled backup or defrag going on, that'll do it too. Anything that keeps the network interface or your disk drives busy can do it. A program that uses large amounts of RAM, perhaps due to a memory leak, can slow you down.

Always start with a reboot. Sometimes that's all it takes, especially if the issue is memory. If not, start looking for processes that are running that aren't as important as your DAW but think they are.

 

Share this post


Link to post
Share on other sites
39 minutes ago, bitflipper said:

A "glitch" is a buffer-starvation issue. IOW, your computer isn't able to fill the output buffers fast enough to maintain uninterrupted output. That's because it's busy doing something else.

If you can't get around it by increasing the buffer size, you need to figure out what other process is monopolizing your CPU. Unfortunately, that can have a great many causes. However, because your project played fine yesterday but not today, you have an important clue. Namely, something is different today. Determine what that is and you've solved the mystery.

Start with Task Manager and see if there are any background processes eating up CPU. If Microsoft is force-feeding updates to your computer, that can certainly do it. If there's a scheduled backup or defrag going on, that'll do it too. Anything that keeps the network interface or your disk drives busy can do it. A program that uses large amounts of RAM, perhaps due to a memory leak, can slow you down.

Always start with a reboot. Sometimes that's all it takes, especially if the issue is memory. If not, start looking for processes that are running that aren't as important as your DAW but think they are.

 

Thank you for your reply!

I tried a lot of things but what fixed the problem was to plug the laptop power supply in. Anyways, it's strange cause I've always worked with the laptop battery.

 

Share this post


Link to post
Share on other sites

I have had battery packs, near the end of their life, spike latency REALLY bad, and those issues went away completely as soon as I removed the battery pack.  Quite a strange thing to happen.  That last occurred for me, back on a 32-bit laptop running XP Pro.

Your Windows Power Management Plan options are different when you are running off battery, versus running plugged into the wall.  Might be worth you taking a spin through your power plan, in Windows, to look at how options are set when the laptop detects it is on battery.  Maybe a clue there.  Perhaps processor Min/Max states could be dropping horsepower, for example (completely guessing at that).

You might also try a quick test of bypassing your project's loaded effects (hitting the 'E' key on your computer keyboard toggles the bypassing of effect On/Off).  Perhaps one or more effects in the project are causing some issues.  A single convolution reverb plugin can pretty much have its buffer needs satisfied at 2048, but perhaps if there are multiple instances of that type of effect, or others that use Look-Ahead processing (linear phase type plugins 'LP-' come to mind), maybe something to look at there - a quick test by bypassing effects to see if issues go away, is easy enough to do.....

Bob Bone

 

Share this post


Link to post
Share on other sites

Your CPU may have been clocking itself down when on battery, as a power-saving measure. When you plugged the laptop in your CPU literally got faster.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...