Jump to content
PcMacsterRace

Kontakt not playing imported/opened midi files

Recommended Posts

Like the title says, whenever I import/open a midi file to a Kontakt Track, it doesn't play anything from the midi file. The thing is that if I were to play notes on the virtual keyboard on the software, in the Piano Roll or playing notes on a midi keyboard, it plays a sound, but when playing it back, no sound from the track with the midi file, even if the midi file plays within TTS-1 within the same project. But, if I were to click on a note from an imported/opened midi track, now the virtual keyboard in the piano roll doesn't work, even if I get a new instance of Kontakt loaded and a midi file is not a part of its track.

Any tips to fix this? Thanks

Share this post


Link to post
Share on other sites

Have you set the channel? Kontakt relies on setting up the channel. Each instrument in Kontakt requires the MIDI channel match for the MIDI to trigger the sound. 

Share this post


Link to post
Share on other sites
1 hour ago, John said:

Have you set the channel? Kontakt relies on setting up the channel. Each instrument in Kontakt requires the MIDI channel match for the MIDI to trigger the sound. 

Slight clarification - when there are multiple instruments loaded into a Kontakt instance, then yes, the midi channels matter, and you have to properly match the Midi Output Channel for each midi track, to the corresponding midi channel for the instrument in the Kontakt instance. So, if the Kontakt instance has Piano, Strings, Organ, and Bass instruments loaded in that order, Kontakt will assign midi channel 1 to the first loaded instrument (Piano), and auto-increment the midi channel for each additional loaded instrument - giving: Piano on midi channel 1, Strings on midi channel 2, Organ on 3, and Bass on 4.  That would then mean that you would need to set the Midi Output Channel for each of the 4 associated midi tracks, to Piano midi track to midi channel 1, Strings midi track to midi channel 2, Organ midi track to 3, and Bass midi track to 4. 

For each of the midi tracks, it is also easiest to simply set them to Omni (None), because whichever midi track is either in focus (and using the Cakewalk default to automatically turn on a midi track's Input Echo to On), it will take any midi-generated data (like from a midi controller), and it will dutifully route that to whatever synth is assigned in the midi track's Output, using either the default of midi channel 1, or the Midi Output Channel setting for that track, and then the Kontakt instance will react according to that incoming midi channel's data, and process that to produce the appropriate output sounds (Piano, Strings, Organ, or Bass). 

If multiple midi tracks have the Input Echo turned On, then the midi data will be transmitted on whatever midi channels are associated with each of those tracks, resulting in a layered sound (not likely desired for some combinations of sound - like piano and bass not likely a good sounding thing - but perhaps piano and strings playing together would be desired).

This is not the case when there is a single instrument loaded into the Kontakt instance, because it will default to using midi channel 1, and when there is no Midi Output Channel set on a midi track pointing at that Kontakt instance, it also defaults to midi channel 1, so no explicit midi channel setting need be done for it all to work.

Bob Bone

 

Share this post


Link to post
Share on other sites
3 hours ago, PcMacsterRace said:

Like the title says, whenever I import/open a midi file to a Kontakt Track, it doesn't play anything from the midi file. The thing is that if I were to play notes on the virtual keyboard on the software, in the Piano Roll or playing notes on a midi keyboard, it plays a sound, but when playing it back, no sound from the track with the midi file, even if the midi file plays within TTS-1 within the same project. But, if I were to click on a note from an imported/opened midi track, now the virtual keyboard in the piano roll doesn't work, even if I get a new instance of Kontakt loaded and a midi file is not a part of its track.

Any tips to fix this? Thanks

Can you please explain in detail, how you have things set for:

For the midi track you have the midi clip loaded into, please tell me what is set for that track's Input and Output.

For the audio track you want to use to hear the sounds from the Kontakt instrument, please tell me what is set for the Input and Output for that track/

For the Kontakt instance, please tell me if you have an instrument loaded, (sorry have to ask), and also whether or not this is the only Kontakt instance in the project.  If you have more than one Kontakt instance in the project, then please tell me the modified name Cakewalk shows in the synth rack for the particular Kontakt instance that has the instrument you are trying to have play the midi data from your midi track.  (if you have 3 Kontakt instances in the project, Cakewalk would display them as Kontakt 1, Kontakt 2, and Kontakt 3).

Each Kontakt instance present in the project gets 'named' in the Synth Rack, with a numerical suffix to uniquely identify it - your first Kontakt instance will get a name of Kontakt 1, and if you were to load an additional instance of Kontakt, it would be named as Kontakt 2, and so on. 

When you are playing connect the dots between a midi track and the target Kontakt instance, and between an audio track and the target Kontakt instance, you have to make sure you assign the correct Kontakt instance, so if you have let's say 2 Kontakt instances in the project (Kontakt 1 and Kontakt 2), and Piano is loaded into the 'Kontakt 1' instance and Strings are loaded into the Kontakt 2 instance, and you are making the midi track and audio track assignments for the Strings instrument in the 'Kontakt 2' instance, you would have to set the Strings midi track Output assignment to be 'Kontakt 2', and you would need to set the Input assignment for the Strings audio track to pick up the 'Kontakt 2' stereo output, in order to be able to properly hear Strings sounds when you have the Strings midi track in focus. (its Input Echo on).

So trying to recap the assignments, you should have:

1) Kontakt instance with some instrument loaded

2) A midi track with its Input set to Omni/None, and its Output set to match the name of the desired Kontakt Instance.

3) An audio track with its Input set to the Kontakt instance's instrument's Stereo Output (Left and Right).

If the above is in place, then when you bring that midi track into focus, by clicking on that midi track's track number - you should see the Input Echo button lit, for that midi track.  Now, if you play your midi controller, (OR, if you have midi data on that track and you hit Play), you should hear sound from the loaded instrument of that Kontakt instance.  (you do need to be playing notes that fall within the playable range of that instrument).

I hope the above makes sense, 

Bob Bone

 

 

Share this post


Link to post
Share on other sites
9 hours ago, PcMacsterRace said:

But, if I were to click on a note from an imported/opened midi track, now the virtual keyboard in the piano roll doesn't work, even if I get a new instance of Kontakt loaded and a midi file is not a part of its track.

Any tips to fix this? Thanks

This sounds like the MIDI clip in question has control messages that are perhaps causing the Kontakt instrument to silence itself.  Open the Event Viewer in CbB and see if there are things other than notes (delete them and then remove and reload the Kontakt instrument to reset it).  You may also want to turn off the option in CbB for Zero Controllers When Play Stops (which is a project level option under Project->MIDI) sometimes when this is on CbB will send 0 controller messages for a lot of controls to the Kontakt instrument settings volumes and filters to 0, which kills the sounds.

Share this post


Link to post
Share on other sites
4 hours ago, Matthew Sorrels said:

Open the Event Viewer in CbB and see if there are things other than notes (delete them and then remove and reload the Kontakt instrument to reset it)

this ^^^^

Share this post


Link to post
Share on other sites
9 hours ago, Matthew Sorrels said:

This sounds like the MIDI clip in question has control messages that are perhaps causing the Kontakt instrument to silence itself.  Open the Event Viewer in CbB and see if there are things other than notes (delete them and then remove and reload the Kontakt instrument to reset it).  You may also want to turn off the option in CbB for Zero Controllers When Play Stops (which is a project level option under Project->MIDI) sometimes when this is on CbB will send 0 controller messages for a lot of controls to the Kontakt instrument settings volumes and filters to 0, which kills the sounds.

This does not work, thanks for the response though.

 

14 hours ago, Robert Bone said:

Can you please explain in detail, how you have things set for:

For the midi track you have the midi clip loaded into, please tell me what is set for that track's Input and Output.

For the audio track you want to use to hear the sounds from the Kontakt instrument, please tell me what is set for the Input and Output for that track/

For the Kontakt instance, please tell me if you have an instrument loaded, (sorry have to ask), and also whether or not this is the only Kontakt instance in the project.  If you have more than one Kontakt instance in the project, then please tell me the modified name Cakewalk shows in the synth rack for the particular Kontakt instance that has the instrument you are trying to have play the midi data from your midi track.  (if you have 3 Kontakt instances in the project, Cakewalk would display them as Kontakt 1, Kontakt 2, and Kontakt 3).

Each Kontakt instance present in the project gets 'named' in the Synth Rack, with a numerical suffix to uniquely identify it - your first Kontakt instance will get a name of Kontakt 1, and if you were to load an additional instance of Kontakt, it would be named as Kontakt 2, and so on. 

When you are playing connect the dots between a midi track and the target Kontakt instance, and between an audio track and the target Kontakt instance, you have to make sure you assign the correct Kontakt instance, so if you have let's say 2 Kontakt instances in the project (Kontakt 1 and Kontakt 2), and Piano is loaded into the 'Kontakt 1' instance and Strings are loaded into the Kontakt 2 instance, and you are making the midi track and audio track assignments for the Strings instrument in the 'Kontakt 2' instance, you would have to set the Strings midi track Output assignment to be 'Kontakt 2', and you would need to set the Input assignment for the Strings audio track to pick up the 'Kontakt 2' stereo output, in order to be able to properly hear Strings sounds when you have the Strings midi track in focus. (its Input Echo on).

So trying to recap the assignments, you should have:

1) Kontakt instance with some instrument loaded

2) A midi track with its Input set to Omni/None, and its Output set to match the name of the desired Kontakt Instance.

3) An audio track with its Input set to the Kontakt instance's instrument's Stereo Output (Left and Right).

If the above is in place, then when you bring that midi track into focus, by clicking on that midi track's track number - you should see the Input Echo button lit, for that midi track.  Now, if you play your midi controller, (OR, if you have midi data on that track and you hit Play), you should hear sound from the loaded instrument of that Kontakt instance.  (you do need to be playing notes that fall within the playable range of that instrument).

I hope the above makes sense, 

Bob Bone

 

 

I have done everything you said, still no sound when playing the song back

the instrument is Shreddage 3 Jupiter, and it's the only instrument loaded in Kontakt (though any other Kontakt instrument will also produce the same effect). It is also the only Kontakt instrument in the Synth Rack.

I would also like to say it's not project specific, any midi file loaded into any project, or any midi file that is opened, if I put one of the midi tracks into a Kontakt instrument, will produce no sound coming through said Kontakt instrument when playing the song back. Even if it's the only instrument in the Synth Rack. However, if I manually place the notes, it will play the notes I placed, but will not play the notes from the midi file. However, if i click on a note that was made from the midi file, no sound will play from Kontakt when playing back, but the notes I previously placed before clicking on a midi note will play and produce a sound, so I don't think it's a volume issue.

 

Share this post


Link to post
Share on other sites
27 minutes ago, pwalpwal said:

Does it play back OK in a different vst?

Yes, I tried the same track with Ample Guitar M II Lite, and it plays perfectly fine. Same project too

Share this post


Link to post
Share on other sites

Put the CWP file on a file share (Dropbox/Google Drive/etc) and let us take a look at it.  I have Shreddage 3 Jupiter.   Strip the project down to just the problem would be best.

Share this post


Link to post
Share on other sites
32 minutes ago, Matthew Sorrels said:

Put the CWP file on a file share (Dropbox/Google Drive/etc) and let us take a look at it.  I have Shreddage 3 Jupiter.   Strip the project down to just the problem would be best.

Here is the link

Also figured out that some MIDI tracks works, however I know this track doesn't produce any sound when playing back.

Share this post


Link to post
Share on other sites

OK first off, never use a simple instrument track with Kontakt.  That always leads to a ton of issues because you can't easily control things.  In this case if you open the event viewer on your MIDI you'll notice all the notes are set to MIDI channel 3.  And since it is a simple instrument track you can't easily redirect it to MIDI channel 1 like you can with a split track setup.  In fact I'm not even sure how you set the MIDI channel on a simple instrument track (I'd hope there is some way but I have no clue what it is).  In order to hear that MIDI you either need to change the MIDI to channel 1 or change the Kontakt Instrument to channel 3.

tU0eOs.jpg

 

Share this post


Link to post
Share on other sites

So if you change your track filter to show All on a Simple Instrument track and make it tall enough it shows the output MIDI channel and you can change it.  Makes sense now that I looked it up.

MVY5hH.jpg

Yours was set to NONE which means it uses what ever is in the MIDI clip for Channel.  If you change it to 1 that'll also fix the problem.  On split instruments those settings are all in the track mixer panel and don't depend on how large your track is.

Share this post


Link to post
Share on other sites
14 minutes ago, Matthew Sorrels said:

OK first off, never use a simple instrument track with Kontakt.  That always leads to a ton of issues because you can't easily control things.  In this case if you open the event viewer on your MIDI you'll notice all the notes are set to MIDI channel 3.  And since it is a simple instrument track you can't easily redirect it to MIDI channel 1 like you can with a split track setup.  In fact I'm not even sure how you set the MIDI channel on a simple instrument track (I'd hope there is some way but I have no clue what it is).  In order to hear that MIDI you either need to change the MIDI to channel 1 or change the Kontakt Instrument to channel 3.

tU0eOs.jpg

 

And that was the problem, Thanks for the help. BTW, I did manage to find a way to change the midi channel in the event viewer.

Process > Find/Change > Ok > Channel (Under All Non-Special Events) > Set channel Min to channel you want > Ok

I can also just set the Midi channel in Kontakt to Omni and that seems to fix the issue as well.

Again, thanks for the help!

Share this post


Link to post
Share on other sites
2 minutes ago, Matthew Sorrels said:

So if you change your track filter to show All on a Simple Instrument track and make it tall enough it shows the output MIDI channel and you can change it.  Makes sense now that I looked it up.

MVY5hH.jpg

Yours was set to NONE which means it uses what ever is in the MIDI clip for Channel.  If you change it to 1 that'll also fix the problem.  On split instruments those settings are all in the track mixer panel and don't depend on how large your track is.

You can see and change the same parameter (Midi Channel), in the Track Inspector pane, for each of your simple instrument tracks - this parameter is displayed right under the FX bin in each track's channel strip.  Just highlight each track, make sure the Track Inspector is open ('I' on your computer keyboard if it is not being displayed), and you can force each of those tracks to take its midi data and send it to Kontakt on whatever midi channel you assigned in the Midi Channel track parameter.

If you are trying to have Kontakt play more than a single instrument, you would need to load those up, and then get the midi channels for the tracks to match the midi channels for the loaded instruments in your Kontakt instance.  Then you would hear each instrument play through Kontakt.

Bob Bone

Share this post


Link to post
Share on other sites

Are you using the free Kontakt Player, I ask because  it will only play certain sounds. The Full Version Of Kontact plays all 3rd Party  licenced product. 

Edited by Glenn Taylor
Spell correct

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...