Jump to content
CDK

MIDI routing question (Kontakt)

Recommended Posts

Hi all,

MIDI routing question, specifically Kontakt.

I have a few different instances of Kontakt in one project but if I set MIDI input to say, Kontakt MIDI Ch. 1 or Kontakt MIDI Ch. 2 I get no MIDI signal. Why is that? What have I done wrong?

Similarly, if I wanted, say a Trombone and a Tuba in the same instance of Kontakt, to play on MIDI channels 1 & 2, I can't get any MIDI signal happening.

I actually have at least 3 different Kontakt VST options come up in BandLab when I go to insert a soft synth so I'm not sure if maybe I'm selecting the wrong one for what I want to do?

Share this post


Link to post
Share on other sites

If you have more than one instance of Kontakt it will be labeled Kontakt 1 and Kontakt 2. and so on. Be sure you are sending your MIDI to the right one.   

Share this post


Link to post
Share on other sites

The only difference between the  Kontakt plugins is the number of audio outputs. You can see which is each in the Plugin Manager and rename them so it is less confusing. 

Share this post


Link to post
Share on other sites

Hi CDK..

Are you sure you have the echo button on?

If not, click that after you've set your midi outs (midi in should be from your controller).

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Once you create the outputs in Kontakt, I would create a track template in Cakewalk with output assignments for each Audio/Midi track:

konout1.png.4a398264537488ec875422657d8ccf0f.png

When you load an instrument in Kontakt make sure you route it to the correct audio, and midi output:

konout2.png.13217dbde8045c99b95434112dc56c1c.png

Now you should be able to play different Kontakt instruments on each desired track. 

Don't forget to save as a track template to use in all of your projects. 

Edited by S.L.I.P.
  • Like 2

Share this post


Link to post
Share on other sites
11 hours ago, arlen2133 said:

Hi CDK..

Are you sure you have the echo button on?

If not, click that after you've set your midi outs (midi in should be from your controller).

 

Hey, yes echo is on. Clearly I've missed something somewhere else. I'll figure it out!

Share this post


Link to post
Share on other sites
12 hours ago, John said:

If you have more than one instance of Kontakt it will be labeled Kontakt 1 and Kontakt 2. and so on. Be sure you are sending your MIDI to the right one.   

Yep done that. I can't seem to get MIDI input on my controller keyboards where I want it.

Share this post


Link to post
Share on other sites

If you're not getting any MIDI from your keyboard, then the issue has nothing to do with Kontakt. It's either a routing issue, a configuration issue on the controller, or your cat has become entangled with the MIDI/USB cable and unplugged it. 

Record some notes even if you can't hear them, just to make sure Cakewalk is getting MIDI data. If nothing is getting recorded, then make sure the keyboard is sending on channel 1 and the track is set to receive data on channel 1 (or the track input is set to Omni, in which case it doesn't matter what channel the controller is transmitting on). If you still can't get any MIDI to record, check your physical connections and make sure Cakewalk can actually see the device (e.g. it shows up in the dropdown list of input devices).

 

 

  • Like 1

Share this post


Link to post
Share on other sites
On 10/8/2019 at 9:48 PM, bitflipper said:

If you're not getting any MIDI from your keyboard, then the issue has nothing to do with Kontakt. It's either a routing issue, a configuration issue on the controller, or your cat has become entangled with the MIDI/USB cable and unplugged it. 

Record some notes even if you can't hear them, just to make sure Cakewalk is getting MIDI data. If nothing is getting recorded, then make sure the keyboard is sending on channel 1 and the track is set to receive data on channel 1 (or the track input is set to Omni, in which case it doesn't matter what channel the controller is transmitting on). If you still can't get any MIDI to record, check your physical connections and make sure Cakewalk can actually see the device (e.g. it shows up in the dropdown list of input devices).

 

 

If the midi controller doesn't seem to generate midi activity in Cakewalk, but the midi controller can trigger sounds when running outside of Cakewalk - (triggering notes from a stand-alone synth), then it could be that despite seeing the controller in Cakewalk as a valid midi input device, that Cakewalk's internal mapping to the device's USB port has changed, such as if the  controller was plugged into a different USB port.  You can easily test this, by deselecting the midi controller from Midi Input Devices in Preferences, clicking Apply, restarting Cakewalk, and then selecting it again as a Midi Input Device in Preferences.  (it might be possible to do this without the restart of Cakewalk, I am a little foggy on whether or not I did that when I faced this issue in the past, but it only takes a minute to restart Cakewalk, so no harm in doing that).

Bob Bone

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...