Jump to content
Jean-Simon Blanchette

Midi controller for Amp Sim - how to

Recommended Posts

Hi !

I have an old fcb1010 that I want to configure to control my amp sim within my DAW (Bandlab and neural dsp Nolly). Even after reading a lot about the topic, I cant get my head around how this whole relation works between the controller, the DAW and the amp sim.

 

So far, I know that my DAW registers when i press the buttons on the pedalboard...but thats about it. Is there anyone that can provide a simple step by step? I only want to turn on and off effect and change patches honestly.

 

Thanks !

Share this post


Link to post
Share on other sites

You really need to tell us which Amp Simulator plug-in you're using.

Does you Amp Simulator plug-in allow MIDI in to be enabled? 

If so, then enable MIDI in on the Amp Simulator plug-in. Then create a MIDI track and route its output to the Amp Simulator plug-in

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the reply. I did said which plugin it was, Neural dsp archetype nolly to be exact. It has midi capability.

So i need to create a midi track, with the controller added to it (i actually managed to do that) and route it through the audio track where the amp sim is ? 

Share this post


Link to post
Share on other sites
42 minutes ago, Jean-Simon Blanchette said:

Thanks for the reply. I did said which plugin it was, Neural dsp archetype nolly to be exact. It has midi capability.

So i need to create a midi track, with the controller added to it (i actually managed to do that) and route it through the audio track where the amp sim is ? 

Well, not route it to the audio track, but to the Amp sim itself. 

Assuming you have enabled MIDI in on the Amp sim VST itself, when you click on the "Output" of the MIDI track, "Neural DSP Archetype Nolly" should appear on the drop down list of destinations the MIDI track can be sent to.  Simply select "Neural DSP Archetype Nolly". 

Then you select the old fcb1010 as the input of that MIDI track and enable Echo on on that MIDI track.

Now the FCB MIDI data will be routed to the Neural DSP Archetype Nolly via that MIDI track.

Share this post


Link to post
Share on other sites

Thanks Gswitz...but I don't even understand whats going on!

Following everyones comments, heres a few clarifications and questions:

First, even with some readings, im not sure that i understand that piece : do i need to configure the fcb1010 itself BEFORE using to any application ? Not sure if the question is even clear...

The pluging as the ACT function. Not sure how im suppose to use thar though...

My pedalboard is first plugged in my Focusrite 8i6, which has midi in and out. Does that change anything ?

Again, i just want to be able to open Cakewalk, plug my guitar and play with my amp sim and record tracks.

When i create a midi track, i can assign the in and out to respectively focusrite in and focusrite out. Then i can add a new drum map (?). My plugin is nowhere to be found. Theres a menu within the vst where i can select and click midi, but that doent seem to do anything

Finally, I think it's important to know that I have a standalone version as well of this amp sim. According to the information I gathered, configuring the midi learn function couldn't be simplier. However, even after following the steps, it doesn't seem to work. Leading me to believe that I may miss some basics of this whole thing

Sorry for my disorganized post, but im really confused at this point....

 

edit : Here's a screenshot of my DAW, along with the amp sim and the midi controller configuration open. I know the routing is not correct, but i cant find the amp sim as an output in the midi track (i cant honestly understand how i could edit the amp sim that way....). Im about to give up

https://imgur.com/a/uGTbFIQ

another thing : here's a simply video on how to configure a midi pedal in the STANDALONE version of the amp sim. I can't even get that piece to work, making me believe that I'm missing a few basic concepts...

 

 

Edited by Jean-Simon Blanchette
Added screenshot

Share this post


Link to post
Share on other sites

I don't use Act with my FCB 1010... I just bring it in on a midi channel and output it to the input on the THU/TH3 amp sim.

You ask if you need to configure your FCB 1010... the answer is maybe. I have no idea how you have it set up. You can make any stomp or expression pedal act however your like. You have 10 banks with 10 stomps and 2 expressions on every bank. If you wanted, you could set every stomp to the same midi note... alternatively you could set them to ascending notes... or controls... you have to decide. I'm sharing a link to directions for importing my settings to your fcb 1010 if you want. You can also back up your settings first if you want. 

Basically, I have every stomp on my FCB 1010 trigger a different midi note. That gives me access to 100 stomps and 20 expression pedals to use within THU. Pretty awesome!! I just have to remember how they are assigned (or not... I could have 1 bank for 10 different rigs). Anyway... here's that info...

https://discuss.cakewalk.com/index.php?/topic/3590-custom-midi-foot-peal/&do=findComment&comment=31040

So, We can't answer for you how your FCB 1010 is set up b/c you are in control of that. We can help you figure out how to set it up and that's what the above link is useful for. I think it's an awesome tool. You don't have to use it with ACT or set it up as a controller if you are going to use it with your Amp Sim.

HTH

Share this post


Link to post
Share on other sites

 

I don't know if these videos may help but many of them involve me using my FCB 1010 with TH3/THU.

 

 

 

 

 

 

 

 

 

Edited by Gswitz

Share this post


Link to post
Share on other sites
1 hour ago, Gswitz said:

I don't use Act with my FCB 1010... I just bring it in on a midi channel and output it to the input on the THU/TH3 amp sim.

 

And that's where I'm stuck. I see that my FCB1010 is sending a signal and that the pc is receiving it because of that piano icon in the taskbar. That's about it.  When I create a midi track, I can select in and out to be the Focusrite midi, but the amp sim is nowhere to be found...and regardless of all the explanations See below. I can't see how it would work that way.

https://imgur.com/a/4ADXkgK

At this point, I don't care what will be the parameters, I just want it to work to begin with...

Edited by Jean-Simon Blanchette

Share this post


Link to post
Share on other sites

The output for the midi track should be set to the input of the amp simulator. This will be available only after you open the vst window for the amp sim and enable midi input.

Share this post


Link to post
Share on other sites
28 minutes ago, Gswitz said:

The output for the midi track should be set to the input of the amp simulator. This will be available only after you open the vst window for the amp sim and enable midi input.

There's a midi button in the VST, but it doesnt seem to respond. With that being said, since you have TH3 and I have it too, I tried as well with TH3. instead. I went into the VST, clicked on midi and try the learn function. I got the following message : "no midi messages has been received during learn". So, even though my PC is clearly seeing my pedalboard, that's the only thing I have working right now with it. I'm missing something basic here I'm sure of it. 

 

and again, even with the standalone version of the amp sim, the pedal board doesn't seem to send anything to the amp sim or VST within Cakewalk

Edited by Jean-Simon Blanchette

Share this post


Link to post
Share on other sites
15 minutes ago, Gswitz said:

You are missing the step to enable midi input or the routing of the midi track to the input.

Make sure your midi input is not assigned to a controller in preferences.

https://www.cakewalk.com/Documentation?product=SONAR X3&language=3&help=Mixing.37.html

I see. Ill try that. However, that wont explain why the standalone version is not registring anything as well....

Share this post


Link to post
Share on other sites

The instructions doesnt seem to fit my version of Cakewalk. 

I already wasted like 3h today with that thing and its getting frustrating. Since the standalone version doesnt even work, i think i will focus on solving the problem with that first since im sure the culprit is OUTSIDE my daw anyway (if it wasnt the case, the standalone version would have worked). Thought? Imagine that i just open the box of a brand new fcb1010, what would you do? Reading and reading and i cant seem to understand what seem to be the basics....

 

Edited by Jean-Simon Blanchette
Spelling

Share this post


Link to post
Share on other sites
1 hour ago, Jean-Simon Blanchette said:

I see. Ill try that. However, that wont explain why the standalone version is not registring anything as well....

If test on standalone TH3, needs set your controller as active at "Active MIDI inputs" in Audio settings on Settings. 

If test on VST plugin, check "Enable MIDI input" in clicking menu the part enclosed in red on the pic below.
Mixing.37.1.png

Edited by HIBI

Share this post


Link to post
Share on other sites

In cakewalk there is a virtual controller you can open up. Can you get it working with that?

If it works with the virtual controller, then I would agree that the next step is to ensure that the signal is coming in properly.

When things weren't working for me once where I was having a hard time figuring it out, I needed to go into Preferences (hit P) > Midi > Control Surfaces and delete a surface I use sometimes but didn't have plugged in at the moment. That surface was steeling my midi input.

Beyond that, things usually work by the book for me. If I add a midi track and step on the FCB 1010 I can see the midi jump on the channel (after hitting the record enable)... next, route it to the input on the VST (which has to be enabled as we've talked about). Other than that, there isn't much left. 

Does the midi meter jump when you step on the stomps for the FCB 1010?

Are you sure your in/out cables are plugged in correctly? have you flipped them to see? I can't read that small print and always go trial and error to get that right.

Edited by Gswitz

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...