Jump to content
Robert Whitaker

Cannot get Cakewalk to output to USB midi device

Recommended Posts

No matter what I do I cannot get CbB to output to a USB midi device (MIDIPLUS S-Engine). All the proper outputs are selected but I simply cannot get any sound. Sending the the Microsoft GS Wavetable Synth works perfectly. I can get output to the USB midi device via other midi players. This is infuriating. When playing in Cakewalk, Windows indicates midi output activity but no signal is reaching the device. I'm not new to this. I've been using Cakewalk/Sonar since the DOS version. Any clues?

Share this post


Link to post
Share on other sites
36 minutes ago, Robert Whitaker said:

Windows indicates midi output activity but no signal is reaching the device.

Seems more likely the issue is that the module isn't responding to MIDI that is, in fact, reaching it. Does the module have a MIDI activity indicator? Can you configure the OUT to be a THRU, and pass MIDI back to Cakewalk? Otherwise, check the usual suspects:

 - Some other app is not releasing the driver.

- Receive channel does not match what Cakewalk is sending.

- Event velocities are too low.

- MIDI volume has been zeroed by track volume or other wayward CC7 message.

- Some other controller, (CC1 Modulation. CC11 Expression) needs to be raised.

- Notes are out of range of the current patch .

- The patch has a very long attack, and notes are not long enough to get the sound to an audible level.

 

Edited by David Baay

Share this post


Link to post
Share on other sites
6 hours ago, Robert Whitaker said:

No matter what I do I cannot get CbB to output to a USB midi device. All the proper outputs are selected but I simply cannot get any sound. Sending the the Microsoft GS Wavetable Synth works perfectly.  I can get output to the USB midi device via other midi players. 

Try de-selecting the Microsoft GS Wavetable and that may solve your issue

Try a different USB cable & What external hardware sound modules are you outputting to? 

Share this post


Link to post
Share on other sites
6 hours ago, David Baay said:

I'm using a GM demo file as a test as I can see the VU meters in the tracks responding, so velocities are okay, and I can see the Midi Input/output activity on the task bar indicating activity.

All midi files and Cakewalk projects exhibit this behavior, even if I create a new project.

I have disabled the Wavetable Synth and have it deselected everywhere.

Here is the most telling symptom: I can put the midi device in drum mode where it generates midi signals internally. It works fine until I launch Cakewalk which kill all volume even the though the midi device continues to generate signals. Even once I exit Cakewalk the sound is still muted. In order to get the sound back, I have to power cycle the midi device. When in Drum mode Cakewalk records the midi output from the device perfectly put I cannot hear it while it's recording nor when it's played back.

It seems clear that Cakewalk is sending some sort of signal to the device that is killing the audio output from the device because everything else behaves as expected.

 

Share this post


Link to post
Share on other sites
1 hour ago, CJ Jacobson said:

Try de-selecting the Microsoft GS Wavetable and that may solve your issue

Try a different USB cable & What external hardware sound modules are you outputting to? 

I have deselected the Wavetable Synth. The hardware module is a MIDIPLUS S-Engine.

Share this post


Link to post
Share on other sites

I found an inconvenient workaround to get it to work...


- Launch Cakewalk.
- Power cycle the midi device.
- Open Edit/Preferences/Midi Devices, deselect the midi device and select the Wavetable Synth. Apply.
- Open Edit/Preferences/Midi Devices, select the midi device, deselect the Wavetable Synth. Apply.

At this point IT WORKS. I can open and close multiple projects and everything works. If I close and re-open Cakewalk it reverts to non-working again. I must complete the steps above to get it to work again.

So why is Cakewalk killing the sound at startup? Why must I go though the steps above to restore it?

Share this post


Link to post
Share on other sites

I went round and round with trying to figure out why Cakewalk or Sonar would not accept midi data from an external USB midi controller, and it turned out to because a friend of mine had accidentally unplugged my USB-connected audio interface, and after I immediately threatened him with bodily harm, he had plugged it back in to a different USB port on the back of the computer.

It took me forever to figure out this had happened, because the midi controller was plugged into a USB on the front of the computer, so I knew IT had not been moved, but it didn't occur to me that he had used a different USB port in the back of the computer for reconnecting the audio interface.

I know you are dealing with midi output - but am wondering if this sort of thing might have happened to you, because Windows internally renumbers USB devices - not by name, so even if the name of the device is the same, in Cakewalk Preferences Midi Devices, it might be known to Windows internally by a different identifier.

Try going into Device Manager in Windows, under Sound, Video, and Game Controllers, then clicking on View and checking the box for showing hidden devices, and see if there is a faint icon on a 2nd entry for your midi device.  If there IS, then it was plugged in, at some point, to a different USB port.  Plugging your midi device into where it was previously connected might help it work again.

Bob Bone

 

Share this post


Link to post
Share on other sites
1 hour ago, Robert Whitaker said:

I'm using a GM demo file as a test

Definitely use your own self-created MIDI. As I'm sure you know, a GM file is likely to be sending a GM/GS Reset and  contain all kinds of controller messages, some of which Cakewalk will migrate into the track header controls as initial settings (e.g. Volume, Pan, Chorus, Reverb). If the MIDI volume widget is showing '(101)' - disabled at default level - try raising it to 127 which will enable it to be sent when play starts and set the output volume on the module to max. Then go into the event list of your self-created MIDI clip, and add CC1 = 127 and CC11 = 127 events. And disable 'Zero Controllers when Play Stops' in case that's silencing the module.

Conversely, you might try deliberately adding a GM/GS Reset to the SysX view  and read through the section on working with GM/GS/XG devices in the Ref. Guide for other ideas.

I believe there may be some messages that Cakewalk sends at startup by default, but I've never had them cause a problem with any of my outboard gear. Or possibly you've actually enabled one deliberately at some point in the past. Check your Cakewalk.INI file against the Ref. Guide for anything that's non-default.

Share this post


Link to post
Share on other sites
43 minutes ago, Robert Bone said:

I went round and round with trying to figure out why Cakewalk or Sonar would not accept midi data from an external USB midi controller, and it turned out to because a friend of mine had accidentally unplugged my USB-connected audio interface, and after I immediately threatened him with bodily harm, he had plugged it back in to a different USB port on the back of the computer.

It took me forever to figure out this had happened, because the midi controller was plugged into a USB on the front of the computer, so I knew IT had not been moved, but it didn't occur to me that he had used a different USB port in the back of the computer for reconnecting the audio interface.

I know you are dealing with midi output - but am wondering if this sort of thing might have happened to you, because Windows internally renumbers USB devices - not by name, so even if the name of the device is the same, in Cakewalk Preferences Midi Devices, it might be known to Windows internally by a different identifier.

Try going into Device Manager in Windows, under Sound, Video, and Game Controllers, then clicking on View and checking the box for showing hidden devices, and see if there is a faint icon on a 2nd entry for your midi device.  If there IS, then it was plugged in, at some point, to a different USB port.  Plugging your midi device into where it was previously connected might help it work again.

Bob Bone

 

Cakewalk is interacting with the USB device in that it accepts input from it and output if I power cycle it as described above after launching Cakewalk. It's a new laptop and I have always used the same USB port for the device. Thanks for the tip though.

Share this post


Link to post
Share on other sites
5 minutes ago, Robert Whitaker said:

Cakewalk is interacting with the USB device in that it accepts input from it and output if I power cycle it as described above after launching Cakewalk. It's a new laptop and I have always used the same USB port for the device. Thanks for the tip though.

The reason I had finally figured out why my device was acting so strangely, was in that when I took it out of my midi devices and added it back in, then it would work, so I thought maybe something similar had happened to you.  AND, it does not matter if the midi device had not moved ports, but it DOES matter if some OTHER device got plugged in to a different USB port.  (in terms of the ports internally getting renumbered, though might not have anything to do with your particular issue).

Bob Bone

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...