Jump to content
OldNick

Plugins: Is it just me?

Recommended Posts

Or is the management of plugins in CWBB (and before) a pedestrian, complex clunky mess? I just downloaded a vst Arpeggiator plugin (cakewalk's does not let you select how many octaves!!!).

I stuck the dll into c:\program files\cakewalk\vstplugins ( a standard CWBB VST lookup folder) and closed and reopened CW. Not there. So I scanned the VST folders. Still not there.

I thought maybe it was the dll, so I dl'd another vst arpeggiator, in case there was something wrong with the first one. Again I placed the dll into c:\program files\cakewalk\vstplugins (BTW I both placed them into c:\program files\cakewalk\vstplugins and also into their own sub-folder....who knows. Scanned the vst folders in the Mangler. Not there. Closed CWBB and opened and scanned again. There...in the Manager.

HOWEVER....Try to insert FX into a MIDI channel. Not listed. Checked that the two were listed in the far right bit of the Manager (I would assume that this meant that it should be available)....not listed in FX.

Maybe they are not MIDI ...try to find them in Audio FX. Nope.

This fight just keeps on happening when I try to use new vst plugins. To me it feels as if the complexity is there to hide the failed functionality.

Edited by OldNick

Share this post


Link to post
Share on other sites

One said it was, the other one I chose the 64 version.

 

And as I say I have this trouble all the time.

Edited by OldNick

Share this post


Link to post
Share on other sites

"vst Arpeggiator plugin" what you say is name of plugin?
Is it really VST plugin, not MIDI FX plugin? 
or Maybe VST instrument, not FX?

Share this post


Link to post
Share on other sites

Try this:

Start CbB with "Run as Administrator".

If still not visible, do a Reset of VSTs.

Share this post


Link to post
Share on other sites

Just curious... cant tell if this is what yiu described or not, 

But theres a list in one of those little box menus where you can select what kind of plugin it is...

I had this with the built in strings/e piano/bass vsts they were showing up as insert effects, found this menu and ticked them as soft synths.

I think you already expressed this, but if not it might be your answer.

Share this post


Link to post
Share on other sites

Ok. Lottsa replies :)

The Arp that I tried was Randarp. It is 64 bit and the page says it's a VST. I am not exactly sure how it works: is it for MIDI or Audio? I finally got to show it up as a soft synth and I am pretty sure that's not right. If I make it a soft synth, it shows up, but sendig it MIDI results in its recognising the note being sent, but there is no sound.

Where should I place the dll to make it a MIDI FX? I tried Shared MIDI Plugins.

The second one I tried was hypercyclic. I chose the 64 bit version. In the plugin _Mangler_ it shows as a VSTi: again probably wrongly. Regardless of that, while it shows in the Mangler and I have added it to the RHS column and saved

I have reset and rescanned until I am sick of it. I opened CWBB as Admin.

All the things I have read so far seem to make this simple..."just do this and (I note _this bit so often) it *should* work"

Share this post


Link to post
Share on other sites

MIDI FX plugins are a Cakewalk/DirectX thing, not VST.  There are very few (almost none) 3rd party plugins that work that way.  The only way to do MIDI effects with VST plugins is by making them into synths.  These MIDI FX synths process MIDI in (like a synth) and then send MIDI out.  They usually have no sounds (but must have an audio channel assigned to work).  The way you set them up is add them as a synth, enable MIDI output on it.  Add a real synth that you want to use for the sounds.  Set the input to the real synth to the output from the MIDI FX synth.  Turn on the track echo.  Then when you play notes on the MIDI FX synth's MIDI track, it gets processed by the MIDI FX synth and sent to the "real synth".

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Kurre said:

My freeware arpeggiator, BlueARP, is a vst instrument.

Thanks. just got it in place....and workiing!!!!!!!!!!!

The laugh was on me...again.  I used Strum Session 2 as the real synth, connected up as suggested Thank you Matthew!) Played some notes in the Piano roll...nothing....set it all up again....of course I had chosen note beyond the scale of SS2 🙄

Share this post


Link to post
Share on other sites
36 minutes ago, Matthew Sorrels said:

MIDI FX plugins are a Cakewalk/DirectX thing, not VST.  There are very few (almost none) 3rd party plugins that work that way.  The only way to do MIDI effects with VST plugins is by making them into synths.  These MIDI FX synths process MIDI in (like a synth) and then send MIDI out.  They usually have no sounds (but must have an audio channel assigned to work).  The way you set them up is add them as a synth, enable MIDI output on it.  Add a real synth that you want to use for the sounds.  Set the input to the real synth to the output from the MIDI FX synth.  Turn on the track echo.  Then when you play notes on the MIDI FX synth's MIDI track, it gets processed by the MIDI FX synth and sent to the "real synth".

Thank you thank you thank you.

What is complicating things is that I somehow have three Layout files of the same name in my layout list, so I can save to the file name, but then have the wrong one selected in the list. Don't know how this has happened. No..I now have four of that same layout and I am missing some of the others that I have saved. NOW I remember why I found it messy before.  I can only find one instance of the actual file and I can see the files that are missing.

Share this post


Link to post
Share on other sites

OK. After a brief honeymoon between me and CWBB, it has dumped me again. I always try to repeat something I have achieved after a struggle.

I thought I had, but it's not working.

I have Strum Session 2 as a Soft synth. I have Blue arp as a soft synth. Blue arp has its MIDI Echo button On, MIDI Out enabled and it is set to transmit on MIDI Channel 1..

SS2's input is Blue arp1 Channel 1. If I switch the SS2 Input back to All Inputs MIDI Omni, I can riffle the piano roll keys and get sounds from SS2.

Put it back to Blue arp1 Channel 1 and riffle the piano roll for SS 2 I get nothing, as expected. But then i try the piano roll for Blue arp and I still get nothing.

Blue arp's arpeggio is visually triggered when I play note. But no sound. The console shows Blue arp MIDI activity when I "play" the piano roll for Blue arp, but no output activity. SS2 shows no activity.

hnh hnh hnh. I had it working.

Please help me here.

 

Share this post


Link to post
Share on other sites

If you're running Windows 10, it may be blocking DLL's you've downloaded from the internet.

To unblock them, right click on them within Windows explorer and select properties, check the "unblock" checkbox, and click Apply followed by OK, e.g.:

image.png.49147e0f052f13cb4f68b4d179fc41b2.png

 

Share this post


Link to post
Share on other sites

Put the "input echo" on for the synth. I don't think it's necessary for the arpeggiator but do it there too.

The synths input should be the arpeggiator and the output should be to the master.

The arpeggiator input should be either midi omni/channel or midi device omni/channel and the output should be none. Some midi generators can produce sound with a little inbuilt synth. In that case the output should go to the master and "input echo" must be on if you want to hear the inbuilt sound together with the synth.

Edited by Kurre
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...