Jump to content
Sign in to follow this  
Giorgio Gabriel

automatic stop playback

Recommended Posts

I don't think so. There is the use of Lopping which will stop playback at a current point, problem is, it will restart at the beginning of the loop.

Would be nice if Markers had advanced options allowing "Stop" "Go to" "Advance".

Share this post


Link to post
Share on other sites

I can see that this feature might be useful.  Perhaps it might go along with a flexible Go To / Song Position Pointer feature (and maybe other Transport Control features--including the use of a standalone wi-fi controller someone requested in another thread).  If it all can be done with markers, that seems like one possible option.  I have not done anything with MCI Commands, and I am not sure if this is even possible, but perhaps if the Cakewalk transport apparatus could be treated as an MCIcmd controllable sequencer (or perhaps if it could have a sophisticated MIDI/SysEx Control), the automatic stop and related functions would be useful to a wide assortment of DAW users.

Just thinking out loud because it opens up a number of possibilities (assuming it can't already be done).

Steve

  • Like 1

Share this post


Link to post
Share on other sites

I had put in a feature request a few years ago for advanced markers.

My idea was to have a marker view where you could rearrange all clips in that section to play. This would allow ease of use for creating different sequences.

Example- Play verse, bridge, chorus. Then use markers to arrange chorus, verse, verse, bridge.

This would allow us to arrange a song in any fashion to hear parts in different order by simply using the advanced markers Vs. having to copy/paste parts in different places.

Share this post


Link to post
Share on other sites

Temporarily, perhaps you can slip-edit all the tracks to the place you want it to stop.

Share this post


Link to post
Share on other sites

I thought there was a setting where you could have the playback stop at the end of a project. I like that feature, but have been too lazy to go look up how to enable it. Is it still a feature?

Share this post


Link to post
Share on other sites

It's  a long time that we all expect that a project really ends were we want because there are  a few cases where the song does'nt stop at the project end without any note or something else beyond.

Share this post


Link to post
Share on other sites
5 hours ago, lapasoa said:

It's  a long time that we all expect that a project really ends were we want because there are  a few cases where the song does'nt stop at the project end without any note or something else beyond.

You have to set the end of the project or CW won't know when it's over. It's handy when you don't want the play head to keep going after the track is done.

Share this post


Link to post
Share on other sites
On 9/9/2019 at 1:08 PM, razor7music said:

I thought there was a setting where you could have the playback stop at the end of a project. I like that feature, but have been too lazy to go look up how to enable it. Is it still a feature?

 

5 hours ago, lapasoa said:

It's  a long time that we all expect that a project really ends were we want because there are  a few cases where the song does'nt stop at the project end without any note or something else beyond.

Guys, OP wants some sort of Stop Marker before the end of the project.

 

On 9/7/2019 at 4:38 AM, Giorgio Gabriel said:

Dear all,

is there a way to tell CWB to stop playback automatically in a particular moment of a song - not at the end?

Thanks,

Giorgio

I think if one were to experiment with some kind of midi loopback (whether a physical cable or virtual like LoopBe) it may be possible to place a stop command into a midi track. I'm too lazy to do the experiment myself

Share this post


Link to post
Share on other sites
2 hours ago, Base 57 said:

 

Guys, OP wants some sort of Stop Marker before the end of the project.

 

I think if one were to experiment with some kind of midi loopback (whether a physical cable or virtual like LoopBe) it may be possible to place a stop command into a midi track. I'm too lazy to do the experiment myself

I also think that will work. So, some MIDI message (f.e. some CC) which looped back as a Control Surface message (f.e. Generic Surface), with this messages assigned to Stop command. It is not going to be extremely accurate in time...

Share this post


Link to post
Share on other sites

Does anyone tried with the Control Surface trick? I had some success but not 100%.

I have a Frontier Tranzport and I noticed that the STOP button sends a midi note A7 with value 127.

In my system it seems to work (adding a second Frontier Tranzport in the Control Surfaces, setting up a midi track with a A7 somewhere, setting this midi track to "hear" a different midi in, and using a short midi cable for loopback).

Problem is that I need this function in another computer without a Frontier Tranzport installed, so I tried other options in the Control Surface menu but without success.

Thanks,

Giorgio

 

Share this post


Link to post
Share on other sites

Easy peasy!! 😉

Need a midi out and a midi in OR a virtual midi cable.

1. Create a midi track. Record a midi note where you want the song to stop.  Assign the out to your Midi out.

2 Run a Midi cable from the Midi out to your Midi Input. ( Physical or Virtual)

3. Click on the ACT module where it says ‘Select hardware controller/surface’. Click the yellow asterisk thingy to add  ACT controller (select ACT midi controller). Set the input to your midi input and output to none.  Click the ACT module and select the ACT controller you just created then click the controller properties button to open controller properties.

4 Click the Options tab. Just to the Right of ‘Bank 1 and B1’ Click the box and Select ‘Stop with Now Marker’

5 Click the Controllers tab to the left of the options tab. On the bottom Bank 1 Click the B1 button to turn on Midi learn. Now play the part of the song you first recorded a single midi note where you are were wanting to stop.

Now your song will Stop wherever you have that Midi note on that track! Awesome! You’ll have to move beyond or back before the note to be able to play your song.

✌️

  • Thanks 1

Share this post


Link to post
Share on other sites

Or you can use alternative solution:

http://www.azslow.com/index.php/topic,298.0.html

This does not require extra track nor MIDI loopback. But can be a bit "slower" (~0.1 sec delay between marker is reached and stop is executed). But playback/recording can be started immediately after stop, "Stop" is triggered only in case current marker name is changed with transport active.

Share this post


Link to post
Share on other sites
5 hours ago, Blogospherianman said:

Easy peasy!! 😉

Need a midi out and a midi in OR a virtual midi cable.

1. Create a midi track. Record a midi note where you want the song to stop.  Assign the out to your Midi out.

2 Run a Midi cable from the Midi out to your Midi Input. ( Physical or Virtual)

3. Click on the ACT module where it says ‘Select hardware controller/surface’. Click the yellow asterisk thingy to add  ACT controller (select ACT midi controller). Set the input to your midi input and output to none.  Click the ACT module and select the ACT controller you just created then click the controller properties button to open controller properties.

4 Click the Options tab. Just to the Right of ‘Bank 1 and B1’ Click the box and Select ‘Stop with Now Marker’

5 Click the Controllers tab to the left of the options tab. On the bottom Bank 1 Click the B1 button to turn on Midi learn. Now play the part of the song you first recorded a single midi note where you are were wanting to stop.

Now your song will Stop wherever you have that Midi note on that track! Awesome! You’ll have to move beyond or back before the note to be able to play your song.

✌️

Hello,

I tried this solution and YES it works. Thanks a lot.

One only problem: if the computer has ONLY 1 MIDI IN / OUT, and I need to use a cable on those midi ports for loopback, as soon as the the song reaches the midi note for the STOP command, I can see that the midi track seems to go in a midi loop state or something similar (the midi vumeter starts blinking and never stops).

In my system I managed the problem assigning the midi track to a DIFFERENT midi in port, but what can I do if the system has only 1 midi in/out?

BTW I also managed to insert a second command into the ACT module, to jump at the end of the measure, so simply pressing the spacebar the song starts again from that point!!!

Bye,

Giorgio

Share this post


Link to post
Share on other sites
5 hours ago, azslow3 said:

Or you can use alternative solution:

http://www.azslow.com/index.php/topic,298.0.html

This does not require extra track nor MIDI loopback. But can be a bit "slower" (~0.1 sec delay between marker is reached and stop is executed). But playback/recording can be started immediately after stop, "Stop" is triggered only in case current marker name is changed with transport active.

Thanks a lot. This seems very good and I will probably try this solution too.

Regards,

Giorgio

Share this post


Link to post
Share on other sites
3 hours ago, Giorgio Gabriel said:

Hello,

I tried this solution and YES it works. Thanks a lot.

One only problem: if the computer has ONLY 1 MIDI IN / OUT, and I need to use a cable on those midi ports for loopback, as soon as the the song reaches the midi note for the STOP command, I can see that the midi track seems to go in a midi loop state or something similar (the midi vumeter starts blinking and never stops).

In my system I managed the problem assigning the midi track to a DIFFERENT midi in port, but what can I do if the system has only 1 midi in/out?

BTW I also managed to insert a second command into the ACT module, to jump at the end of the measure, so simply pressing the spacebar the song starts again from that point!!!

Bye,

Giorgio

Found the solution setting the Input Echo to OFF (before that disabling Always Echo Current Midi Track into the preferences).

Thanks again,

Giorgio

  • Like 1

Share this post


Link to post
Share on other sites
38 minutes ago, Giorgio Gabriel said:

Found the solution setting the Input Echo to OFF (before that disabling Always Echo Current Midi Track into the preferences).

Thanks again,

Giorgio

Excellent brother! I can see the wheels turning now! 😄👍

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...