Jump to content
Sign in to follow this  
marled

Crossfade/Crop for a Single Take Lane

Recommended Posts

When I use the crossfade or crop function for 2 abutting clips in a TAKE LANE, then all clips in the same track are affected (that have about the same end/start position), although only 2 clips and one lane is selected! Maybe I am dumb and there is really a way to prevent that other clips are included in the operation, but I have not found a solution in the Reference Guide.

Another strange thing:

  1. I have 3 abutting clips
  2. I make a crossfade of the first two
  3. then I move the end of the 2nd clip over the 3rd one (with the tools cursor, resp. crop clip end symbol)
  4. RESULT: The crossfade (in 2.) is changed to a fade out/fade in !???? Is this a bug?

Share this post


Link to post
Share on other sites

I think you'll need to clarify exactly what moves you're making and where. Crossfades are only created automatically when working in the parent track with lanes not showing. If you drag a clip over another in the same lane with lanes showing, the  clip you're not moving will get cropped out of the way, not cross-faded.  And I don't understand what's meant by "the crossfade is changed to a fade out/fade in; that's exactly what crossfade is...?

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, David Baay said:

Crossfades are only created automatically when ...

I do not use automatic crossfades, I prefer to do it manually!

13 hours ago, David Baay said:

I think you'll need to clarify exactly what moves you're making and where.

Clarification what I do (2nd problem with 3 abutting clips):

1. I make manually a crossfade with Ctrl + Smart Tool:

crossf-1.png.d58e737763d66e40f73619db676bebc5.png

2. I move the beginning of the top 3rd clip to the left with the Edit Tool (F8, crop cursor).

3. Then I move the ending of the 2nd clip to the right (because step 2 was too much).

4. Result, although I have done nothing at the end/start where the crossfade was:

crossf-2.png.abd0ba4a1e2641ef9628fba8fbd5c01d.png

 

In the above example the manual crossfade has been performed only in the 1st take lane, because the split on the 2nd one has another position. But if the split positions of other clips are the same or nearly the same, then the crossfade is executed on all those clips (sometimes out of view!) even I have selected only the first take lane and its clips! How can you avoid this?

crossf-3.png.798a03c1df198512faf38cc484f5e876.png

 

Edited by marled
removed a wrong image

Share this post


Link to post
Share on other sites

Hmmm... okay. Not a usual part of my workflow, but I can repro all of that, and it seems buggy. The only thing I can suggest as  a workaround is to use additional lanes:

- Create crossfades at both ends of the middle clip to start.

- Add another lane and drag the middle clip to it, holding Shift to constrain the position.

- Now you can move the split point by dragging the end of either clip at the crossfade, and the fades will move along with the split point to wherever you want it.

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, David Baay said:

Hmmm... okay. Not a usual part of my workflow, but I can repro all of that, and it seems buggy. The only thing I can suggest as  a workaround is to use additional lanes:

- Create crossfades at both ends of the middle clip to start.

- Add another lane and drag the middle clip to it, holding Shift to constrain the position.

- Now you can move the split point by dragging the end of either clip at the crossfade, and the fades will move along with the split point to wherever you want it.

Thanks David for your solution, it works! But I have also found out, that if I first handle the end of the middle clip (move to the right position and crossfade) and then do the crossfade between the first and the middle clip, then it runs properly!

It seems to the other problem there is no solution, i.e. applying a crossfade or split point move only to a selected lane (avoiding that all lanes are affected that have the same split point)?

Share this post


Link to post
Share on other sites
47 minutes ago, scook said:

Noel's reply

 

Sorry scook, but what do you mean with this? The audio import is another issue.

Share this post


Link to post
Share on other sites

I found that moving the the cross-faded clip to another lane eliminated the unexpected linkage with splits in other lanes, but I didn't go through all the possible permutations, and given the nature of this seemingly buggy behavior, there may well be some inconsistencies.

FWIW, I don't think what Steve posted is relevant either.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
12 hours ago, David Baay said:

I found that moving the the cross-faded clip to another lane eliminated the unexpected linkage with splits in other lanes, but I didn't go through all the possible permutations, and given the nature of this seemingly buggy behavior, there may well be some inconsistencies.

FWIW, I don't think what Steve posted is relevant either.

 

I can even not create the first cross-fade without affecting other lanes that have the same split position. And this is very nasty if it is out of view (down or up)! You may miss it! Thus it seems it is not possible to adjust a manual cross-fade only to ONE SINGLE lane, if you want the cross-fades to be different in size! 😡 The only solution I see is to copy the clips to a "work" track, do the editing there and then copy the result back to the comping track. But that is very time intensive and inconvenient!

By the way, the reason why I change to the Edit Tool (crop cursor, F8) to slide the split point, is that this one does not affect other take lanes. Actually this is already a work-around! 😄  I don't know how others do vocal comping, but in my case the split points cannot be made exactly at the same positions, as the cross-fades cannot be always the same. I handle, adjust these things after I have decided which takes to use.

Share this post


Link to post
Share on other sites
Posted (edited)

Couple of thoughts:

If you originally created the splits with the comping, tool that might be part of the problem. I found that manually-created splits only linked up if they were created at exactly the same points by having snap enabled. This is speculation, but it seems that rather than storing comp splits as group/object, Cakewalk is programmed to just look for all splits that are perfectly aligned, no matter how they were created, and keep them together when you move one.

Regarding no being able to use matching split points, ideally you want to  select whole phrases with splits in the near-silent sections between phrases so that crossfades hardly even matter. I'm sure there are cases where this isn't possible, but your example doesn't appear to be one of them.

EDIT: Clip locking can also be used to protect splits/crossfades  on clips or whole lanes that you don't want altered.  If you keybind it, it's not too inconvenient.

Edited by David Baay
  • Great Idea 1

Share this post


Link to post
Share on other sites
3 hours ago, David Baay said:

I'm sure there are cases where this isn't possible, but your example doesn't appear to be one of them.

^^This!!

The example is not from the "real life", I just made it to present the problem!

The thing is that many times when I have small parts that have gone wrong (sometimes only one syllable), then I want to replace that before going on with comping, i.e. I attempt to bounce the result before comping. It is in such cases where I use the split moves and cross-fading; it needs precision work to make it imperceptible!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×
×
  • Create New...