Jump to content
studiodude1

Should Hyperthread be enabled in BIOS?

Recommended Posts

Posted (edited)

I am troubleshooting frequent, random dropouts. I have disabled SpeedStep and SpeedShift. Should Hyperthreading be enabled?

Edited by studiodude1

Share this post


Link to post
Share on other sites

In Windows power options, have you set min and max CPU to 100%.  You might also have to also disable C States in your BIOS

What plugins are you using?  Is your PC fully patched?  Are you using the latest Focusrite Scarlett 18i20 drivers?  Have you disabled your onboard sound?

Share this post


Link to post
Share on other sites
Posted (edited)

CPU min & max is set to 100%. I find nothing saying anything about C States in my BIOS. Typical plugins, mostly Waves stuff. Latest Focusrite drivers. Onboard sound is disabled. All the latest updates from Windows, Dell, Waves, etc.etc.

Edited by studiodude1

Share this post


Link to post
Share on other sites

What version of Cakewalk/Sonar are you using?   BTW, yes, you would want to enable Hyperthreading.

Share this post


Link to post
Share on other sites

Just updated to the latest update. This was also happening before the latest update, as well. I recently completely wiped my C drive and completely reinstalled Windows and everything else to try to help but, it didn't.

 

Share this post


Link to post
Share on other sites
Posted (edited)

Make a copy of your AUD.ini file.   This is important so you can revert

This file can be found here:

%APPDATA%\cakewalk\Cakewalk Core

Then go into Cakewalk , Preferences | Audio | Configuration file.

Try the following changes (This is assuming you have enabled hyperthreading)

EnableSetThreadIdealProcessor=0

MixThreadCount=7

ExtraPluginBufs=16

DropoutMsec=-8

Don't forget to restart Cakewalk once done.

Edited by Promidi
Need to add detail

Share this post


Link to post
Share on other sites
Posted (edited)

Promidi - I tried the settings in AUD.INI and it did not help. I just reset it to default.        

Also, I have my Paging File set to "None". Not sure if that's good or not?

Edited by studiodude1

Share this post


Link to post
Share on other sites
28 minutes ago, studiodude1 said:

Promidi - I tried the settings in AUD.INI and it did not help.

Also, I have my Paging File set to "None". Not sure if that's good or not?

Just to confirm that DropoutMsec=-8  .  Did you notice that the value is minus 8

Also with your page file, You should at least set it to something. 

I have 16 gig ram and three physical disks (C:\  D:\  and  S:\)  My page file is set to 1000meg and it's only on D:\.  The rest are set to zero.  I have no clicks or pops, even while playing with a project running a few synth VSTs and effects

In the old days the (unwritten) rule was your paging file should be 1.5 (or was it 2.5, I can't remember) times your physical ram.  But that no longer applies.  I mean I am not comfortable with a 24gig paging file.

Share this post


Link to post
Share on other sites
Posted (edited)

Yes, I did catch the "minus 8".

I will reset my paging file. You only have the paging file set on your audio drive? I have always only had it set on my C drive. Is that wrong?

I noticed my playback and record I?O buffer sizes were set to 256. I raised them to 512. I'll see if that makes any difference.

Also, I noticed I have something called Intel Rapid Storage Technology running. It appears to do something to try to conserve energy on the hard drives???? Should I uninstall this?? I know nothing about it.

Edited by studiodude1

Share this post


Link to post
Share on other sites
22 minutes ago, studiodude1 said:

Also, I noticed I have something called Intel Rapid Storeage Technology running. It appears to do something to try to conserve energy on the hard drives???? Should I uninstall this?? I know nothing about it.

You might want to leave this installed.  This is basically Intel's hard drive controller.  If you uninstall it, your machine will use Microsoft's hard drive controller driver.  I think I would rather let Intel's driver handle that.   Also, if you need to reinstall it you will have to hunt the correct version for your chipset.

Note: I also have Intel Rapid Storage Technology installed - In fact, I just updated it.  It does not negatively impact my system or Cakewalk in any way.

Have you heard of a tool called Latencymon.  That may help in working out what is causing the pops and clicks on your PC

https://www.resplendence.com/latencymon

Share this post


Link to post
Share on other sites

I have run Latency Mon quite a bit. It always tells me everything is good and my system should handle realtime audio just fine. Except when a dropout happens then, it lights up red and tells me I cannot run realtime audio. I have never been able to figure out if it's giving me any clues as to what the problem is or not. I guess I don't understand it.

Share this post


Link to post
Share on other sites
12 minutes ago, studiodude1 said:

I have run Latency Mon quite a bit. It always tells me everything is good and my system should handle realtime audio just fine. Except when a dropout happens then, it lights up red and tells me I cannot run realtime audio. I have never been able to figure out if it's giving me any clues as to what the problem is or not. I guess I don't understand it.

Latencymon should tell you the highest reported ISR routine execution time (us) and highest reported DPC routine time (us)

When the red light comes up hopefully this will tell you the process causing the hiccup,

Also, have a look at the driver tab and sort by ISR count and DPC count (to put the highest at the top)

That may give you some clues.

Note: the latest version of Latencymon is 6.71

Share this post


Link to post
Share on other sites
48 minutes ago, studiodude1 said:

So, should the Paging File be on the audio drive, not the C drive? 

At the end of the day it probably doesn't really matter - especially if you have SSDs drives all round. 

If you have enough ram, then the page file should not even be touched.  It's just that some programs require one to be actually present even if it's not utilised.

You signature says "16 ghz RAM" I'm assuming that is actually 16gig ram so in your case your page file would not be utilised even if it's present.

Share this post


Link to post
Share on other sites
1 hour ago, studiodude1 said:

I have run Latency Mon quite a bit. It always tells me everything is good and my system should handle realtime audio just fine. Except when a dropout happens then, it lights up red and tells me I cannot run realtime audio. I have never been able to figure out if it's giving me any clues as to what the problem is or not. I guess I don't understand it.

Beautiful! It is giving you clues. Ok. Watch it until it turns red. Look in the system and application event logs within a minute of the drop out. What do you see?

You can practice away while running latency mon. This will likely turn up some event that is at the heart of your problem.

Make sure wifi is disabled and disable select suspend on usb. Usually intermittent problems come down to your system powering down some device some time after it had been idle. 

The place you will likely find it is in device manager .

 

 

Share this post


Link to post
Share on other sites

So, if I'm reading this correctly, Kernel Mode Driver Framework  Runtime is the culprit?? Unfortunately, it says it's a part of Windows so, what can be done about that? Or, am I interpreting it incorrectly?

1598777449_latmon1.png.4ce27423dd1f792ef5b95b79d582e70d.png133646763_latmon2.png.b324b9a1de70c6f324bcae2471f1e725.png

latmon 3.png

Share this post


Link to post
Share on other sites
49 minutes ago, studiodude1 said:

So, if I'm reading this correctly, Kernel Mode Driver Framework  Runtime is the culprit?? Unfortunately, it says it's a part of Windows so, what can be done about that? Or, am I interpreting it incorrectly?

 

 

Unfortunately the screenshots are too small to read (The forum reduces the size). 

However, what video card do you have....if it's an Nvidia, have you disabled its audio.  Might be worth uninstalling and reinstalling your video driver.  When reinstalling, do a clean install.

Also, for what it's worth, disable your wifi card (if you have one) and see if that makes a difference.

I have an Nvidia GTX960 with the latest Nvidia drivers (as of 14 Aug, 2019 version 431.60).  I do not have a wifi card.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×