Jump to content
Bill Phillips

Audio Device Disconnection Dialog [Solved]

Recommended Posts

Posted (edited)

I change display power settings (form Never to 10-min) when I walk away from my DAW for a while but don't want to shut down.  I do this just to give the display a rest. When I come back I see the Audio Device disconnection message in one of the screenshot attachments. I can't understand why. I also included sound device settings screenshot attachments to show that all are disabled except for the Focusrite USB audio interface. I also verified that the Focusrite audio interface is the only one listed in Cakewalk audio device settings. So why does Cakewalk display this message?

2019-08-10 (2).png

2019-08-10 (1).png

2019-08-10.png

Edited by Twisted Fingers

Share this post


Link to post
Share on other sites

The device may be in aud.ini. This file is in %appdata%\Cajkewalk\Cakewalk Core

If the device is referenced in the file. The easiest fix is rename the file. When CbB starts up it will recreate the file based on the devices found.

Also there is a new option to suppress these messages in preferences called Show Audio/MIDI Device Change Notifications

  • Thanks 1

Share this post


Link to post
Share on other sites

May want to check if the device is enabled in Windows Device Manager under "Sound, video and game controllers." If it is, disabled it there.

  • Thanks 1

Share this post


Link to post
Share on other sites

If your only concern is the display, you can set its power-down time separately. Go to system settings -> display -> power & sleep.

  • Thanks 1

Share this post


Link to post
Share on other sites
21 hours ago, scook said:

The device may be in aud.ini. This file is in %appdata%\Cajkewalk\Cakewalk Core

If the device is referenced in the file. The easiest fix is rename the file. When CbB starts up it will recreate the file based on the devices found.

Also there is a new option to suppress these messages in preferences called Show Audio/MIDI Device Change Notifications

Thanks. So the message is inconsequential  and suppressing it is ok?

I didn't any AMD references in aud.ini.

21 hours ago, scook said:

May want to check if the device is enabled in Windows Device Manager under "Sound, video and game controllers." If it is, disabled it there.

None of the audio devices are disabled in Device Manager but all except for the Focusrite USB are either disabled or not plugged in Sound settings. (see screenshots) Is that not enough?

Share this post


Link to post
Share on other sites

This has happened to me more than once in the past.

In every case, the cause has been a bad USB cable.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Twisted Fingers said:

Thanks. So the message is inconsequential  and suppressing it is ok?

What do you do about the messages today?

 

1 hour ago, Twisted Fingers said:

None of the audio devices are disabled in Device Manager but all except for the Focusrite USB are either disabled or not plugged in Sound settings. (see screenshots) Is that not enough?

Disabling in sound settings means Windows won't use the devices. Keeping the devices enabled in the Device Manager means OS still loads the drivers making them available for application like CbB. Disabling in the Device Manager should prevent CbB from finding the drivers.

Share this post


Link to post
Share on other sites

Only just noticed this message is for your on-board audio device.

@scook is correct - disable it within Device Manager.

 

Share this post


Link to post
Share on other sites
2 hours ago, scook said:

What do you do about the messages today?

I've clicked "Yes", "No",  the "X" to close and always continue on with Cakewalk. Cakewalk seems to be unaffected  because it's not using that device. 

3 hours ago, scook said:

Disabling in sound settings means Windows won't use the devices. Keeping the devices enabled in the Device Manager means OS still loads the drivers making them available for application like CbB. Disabling in the Device Manager should prevent CbB from finding the drivers.

I see. I'd missed that. I thought that the device was no longer available .

I think I've tried skipping the audio drivers in the graphics card install but something happened that convinced me to include them.

Share this post


Link to post
Share on other sites
2 hours ago, msmcleod said:

Only just noticed this message is for your on-board audio device

I don't think so. The message is for the AMD graphics card HDMI audio. My ASUS motherboard has Realtek drivers.

Share this post


Link to post
Share on other sites
5 hours ago, Twisted Fingers said:

I don't think so. The message is for the AMD graphics card HDMI audio. My ASUS motherboard has Realtek drivers.

Ah ok. There's been issues in the past raised about HDMI audio devices causing issues with other audio interfaces.

Follow @scook's advice and disable it within Device Manager.

  • Great Idea 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...