Jump to content
bitman

Save as MIDI file Format 0 only one of many midi tracks?

Recommended Posts

I have a song with a midi drum track and a midi melody guide track.

I needed to "export" the melody guide track so I dragged it to the desktop. I then learned that the tempo map does not come along with the midi when doing it that way and that I need to save the project as a midi file. This works in so much as the midi data and tempo map are preserved.

However, there are other midi tracks in the project such as the drums, that I don't want to hear or be present in the saved .mid file. I tried muting the drums, that didn't do the trick so I (gasp), deleted the drum midi track. Now I just have the melody guide track in the .mid file.

How do I exclude unwanted midi tracks from sounding in the saved .mid file without deleting them?

TIA!!!¬† ūüėä

 

Share this post


Link to post
Share on other sites

I guess you could always delete the unwanted items, then save a copy of the file, while preserving the original file.

Share this post


Link to post
Share on other sites
Posted (edited)

Don't know how without deleting. Maube if you hide the tracks?

I would probably save the project as a copy and then delete all unnecessary tracks. Then export.

Maybe as a final try to undo the track delete?

Edited by Kurre
Addition.

Share this post


Link to post
Share on other sites

If you don't overwrite the original MIDI file you can open it in Cakewalk and delete the tracks you don't want and export that with a different name.  Don't save the edited file and the original will be preserved.  Or if you want simply save it with a different name too.  Cakewalk, Sonar and Pro Audio are non destructive DAWs.

Share this post


Link to post
Share on other sites

^^ this is what I do.

You may also try if archiving tracks could work for you. I didn't check it.

Share this post


Link to post
Share on other sites

Export as MIDI type 1


Try setting Continuous Controller 7 (track volume) to zero.

Sometimes CC7 is used during the song for transient volume changes instead of CC11 which is supposed to be for that function, so that could be a problem. If so look to see if CC11 is used anywhere, if not, set that to zero at the beginning of the track.

I think that would be what I'd try first.

If it works and you really need MIDI type 0, go ahead and save as MIDI 0 and the changes should stick.

Insights and incites by Notes

Edited by Notes_Norton
addition - afterthought

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

√ó
√ó
  • Create New...