Jump to content

Recommended Posts

If I copy a clip the copied clip doesn't draw until the end like the source clip does. The copied clip ends at end of the last note event in the clip. See the yellow circle in the picture.

Clip.jpg.988f4a92eb95f466eac1337e1e0c9dc9.jpg

Share this post


Link to post
Share on other sites

This is normal midi copy/paste behavior. Midi clips are not solid in form like audio clips, the "clip ends" only show if data is present.

You can "heal" the clips by selecting both clips and choosing "Bounce to clips".

Unless im misunderstanding your question. You may have snap enabled to 1/2 notes and some data cant be picked up.

Share this post


Link to post
Share on other sites

Thank you for your answer. But bouncing is not the solution. 

In my picture, the length of the original clip is 4:00:00 . The clip length of the copied clip is 3:03:240. Yes, this behaviour of Cakewalk is only a problem for my eyes. But perhaps it can be fixed in one of the next versions.

Share this post


Link to post
Share on other sites

This is the behavior for midi clips. Enable snap to drag it to the measure mark... Ctrl L to enable looping. Drag it out.

  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, JayCee99 said:

But perhaps it can be fixed in one of the next versions.

There's nothing to be fixed.

Im not sure how you are missing 57 seconds off your clip but the yellow circle you are showing in the photo is less than one second (between 7:04 and 8:01).

Share this post


Link to post
Share on other sites
Posted (edited)

@Chuck E Baby

I think he is pointing out that midi clip ends are defined by events not the time range. This can be confusing at first.  

Honestly, i think if we can help him use the tool successfully, he will not mind that default behavior.

Maybe I'll make a video to show what i think is bugging him and show why it doesn't bug me.

Edited by Gswitz

Share this post


Link to post
Share on other sites

I think pasted MIDI clip will be same length of original clip even if data is not present at the "clip ends".
How did you copy the clip? Did you select notes of the clip with dragging on the time ruler? or selected with clicking the original clip on the track view? I think you are selecting notes of the original clip with dragging on the time ruler. Probably the clip was selected partially not full length.

Share this post


Link to post
Share on other sites
2 hours ago, Gswitz said:

I think he is pointing out that midi clip ends are defined by events not the time range.

The yellow circle is one thing, the :57 seconds is another. Im not sure these 2 things are related.

 

17 minutes ago, HIBI said:

I think pasted MIDI clip will be same length of original clip even if data is not present at the "clip ends".

I believe you might be correct.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, HIBI said:

I think pasted MIDI clip will be same length of original clip even if data is not present at the "clip ends".
How did you copy the clip? Did you select notes of the clip with dragging on the time ruler? or selected with clicking the original clip on the track view? I think you are selecting notes of the original clip with dragging on the time ruler. Probably the clip was selected partially not full length.

I did select and copy the original clip and then inserted it in another position.

Edited by JayCee99

Share this post


Link to post
Share on other sites
6 minutes ago, JayCee99 said:

I did select and copy the original clip and then inserted it in another position.

The measurment is done by beats not by time.  So there are around two seconds missing in the clip. 

Share this post


Link to post
Share on other sites
10 minutes ago, JayCee99 said:

I did select and copy the original clip and then inserted it in another position.

How did you copy/paste ?

Using the CNTRL+C/CNTRL+V or using the copy/paste menu ?

I would try again but this time, make sure you are selecting the whole clip from Beat A to Beat B. Make sure Snap is enabled.

Share this post


Link to post
Share on other sites

I guess a cause is the way what you did to select the clip.

How did you select the original clip?

  • with clicking the MIDI clip?
  • with mouse dragging on the time ruler?
  • or other way?

Anyway, you can select all of the original MIDI clip with just clicking it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...