Jump to content
  • 0

Recording Latency and related Audio and MIDI Settings

Salim Reza Newton


Hello community,

As a newbie I use a USB midi (Casio CTK 6200) without any audio interface. While recording I get a lot of latency. On the track that I record, MIDI notes are off-grid. The first note is almost on the second note grid.  So, I'm stuck. I've a few queries. I'm giving the details below. Please help me.




A. I'm working on an Asus Tuf Dash F15 gaming laptop with Windows 11.

B. Its Device Specifications are given below:

Device name: LAPTOP-H6RQDLVH
Processo: 11th Gen Intel(R) Core(TM) i5-11300H @ 3.10GHz   3.11 GHz
Installed RAM: 8.00 GB (7.68 GB usable)
System type: 64-bit operating system, x64-based processor

C. My Windows Specifications are here:

Edition: Windows 11 Home Single Language
Version: 22H2
Installed on: 12/‎21/‎2022
OS build: 22621.1555
Experience: Windows Feature Experience Pack 1000.22640.1000.0

D. Let me now  inform you about my laptop's Storage situation with the screenshot below:


E. My laptop's  Audio Input and Output Devices are shown in the screenshot below:


F. Besides these devices, my laptop's Sound, Video and Game Controllers are shown in another screenshot below.





1. The Audio -- Devices  section in my Cakewalk's Preferences show my Realtek (r) Audio in a dimmed manner. It doesn't let me select them. On the other hand, it shows only the Asus Utility with check marks ON which are not dimmed. These are shown in the screenshot below. Are these settings okay for me?



2. Next thing is about Audio -- Driver Settings. It only shows Asus Utility, not the Realtek (R) Audio. Please see the screenshot below. I've done nothing here. All the setting are automatically selected. Are these settings okay for me?



3. The next big thing is about setting proper Driver Mode in my Cakewalk's Audio Playback and Recording Settings. I selected WASAPI Shared as the Driver Mode. Please see the attached screenshot below. Are all the settings okay here?



4. Now about MIDI Input and Output Devices settings. Please see the screenshot below. Here, Casio USB -MIDI is the midi I'm using. It's connected to my laptop while I use Cakewalk. I've checked them to ON status as my MIDI Input and Output Devices. I've also checked Microsoft GS Wavetable Synth. Should have I done this or should I uncheck it?



5. The next question is about MIDI Playback and Recording settings. Please see the screenshot below. The Driver Mode is set up to MME automatically. Should I change it to UWP? What about the other settings here? Are they okay for me?


Please help me regarding the settings, and suggest me how I could get rid of the Latency Issue while recording from my Casio USB-MIDI.

Thank you.


Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

if the ASUS ones are actual line level IO, you should turn off any and all effects and sounds. the realtek looks like it's the built in mic only. so, per reginaldStJohn - invest in a decent IO unit with MIDI IO as well (Focusrite etc make decent units for a very reasonable price and you'll be able to have lower latency and real MIDI IO).

Link to comment
Share on other sites

  • 0
On 4/18/2023 at 12:49 AM, reginaldStjohn said:

... but I would suggest trying the realtek ones instead of the ASUS entries and see if that works any better ...

Thanks, reginaldStjohn for responding.

The problem is Devices  section in my Cakewalk's Preferences show my Realtek (r) Audio in a dimmed manner. It doesn't let me select them. It won't let me manipulate it.

Do you have any idea why it is dimmed?

How do I know what my Sound Card on board is and what driver in Cakewalk I should use?

Edited by Salim Reza Newton
Link to comment
Share on other sites

  • 0
49 minutes ago, Salim Reza Newton said:

How do I remove all the NVidia audio devices? I'm a newbie. Please tell me how.

You don’t need to remove them, you can disable them and see if that helps your situation. Navigate on your computer to Device Manager, then open the “Sound, video, and game controller”drop down. You should see a list of the sound devices that are installed on your computer. You can right click on various ones and disable them. If you do that and it doesn’t help, removing them completely won’t make any difference either. Troubleshoot it this way, but I have a feeling you’re going to continue to have problems with this until you invest in a dedicated audio interface. Cakewalk is a professional level DAW, and works best with optimized and dedicated ASIO sound drivers. Also, an external interface running the sound will free up your system resources and help with latency. You can get a basic interface like a Presonus Audiobox for $100.

Edited by Ross Smithe
  • Like 2
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...