Jump to content

Toontrack Routing Issue

Recommended Posts

Using Toontrack Drums. I have the proper drum maps installed and Cakewalk pointed to them.

1. Insert 1st synth instance (DFH), route, select map, works great.

2. Insert 2nd synth instance do the same - select Latin Percussion - route appropriately, Check on the Construct Page to make sure audio reports correctly.  Works great.

However, after adding a midi clip, it works only on Superior Drummer 2-2 (ie no map).  But if I select the Latin Percussion Map, then that midi (LP) reports to 1st instance midi track (DFH). All I get are cymbals clashing.

Again, checking the Construct page, audio reports correctly. Checked and double-checked Drum Map Manager. Seems correct. I'm sure it is something simple I'm overlooking.

SD - DFH Settings.png

SD - LP Settings.png

Link to comment
Share on other sites

Sounds like the Drum map is pointing to a specific instance of the synth. Open the Latin Percussion drum map and change the output to point to the 2nd instance of SuperiorDrummer.


NOTE: if you select all the entries (Ctlr-A) and hold shift or control or one of those down, then when you change one columns entry they all will change to the same thing.

Edited by reginaldStjohn
Link to comment
Share on other sites


That was exactly the prob. I always assumed Cakewalk was smart enough the see this.

So, the lesson - if you want to used multi instances, you have to manually reset the outputs every time. Got it.

*** Ctl+A or any version did not work for me. Manul every line. Sure there is a way trhough.

Thank you for your help.


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...