Jump to content
yapweiliang

Control Surface, behaviour when not plugged in

Recommended Posts

(I am new to control surfaces, but in any case I have a Zoom R16, and it works as a control surface once set-up)

(I think the Zoom/Driver combination presents a USB MIDI Port for CbB to use)

What I have noticed however, is, when the Zoom is not plugged in, CbB then chooses another available MIDI Port (in my case, it chooses the digital piano).  What this means is that on starting up CbB, it sends a loud MIDI note to the piano (which duly produces the sound, a high 'A' note).  It only happens on starting up CbB, and not subsequently (e.g. when open/close project files).

What I am asking is whether - CbB can remember the Control Surface device, and, disable the control surface if the device is not plugged in, rather than choosing another MIDI port?

(It does remember the correct MIDI port, when the Zoom is subsequently plugged in).

Thank you

 

(Using latest Zoom driver, latest (not Early Release) CbB, Windows 10, MOTU micro express, MOTU 828 mkII USB)

Share this post


Link to post
Share on other sites

I get this a lot when unplugging MIDI gear, and usually has me scratching my head for 1/2 hour wondering why my keyboard doesn't work only to find out the control surface has "stolen" its MIDI port.

As a workaround, I always make sure that:

  1. I have at least one other spare MIDI device (either hardware or loopback MIDI device) installed that I don't use
  2. The "spare" MIDI device is second last on the list of devices, and the control surface is the last

This means that if the control surface isn't plugged in, it'll fall back to the spare device and leave my other devices alone.

 It's pretty easy to order the MIDI output devices within preferences, but the order of the MIDI IN ports can be specified by editing TTSSEQ.INI directly ( stored in %APPDATA%\Cakewalk\Cakewalk Core\ )

So in the example below, my nanoKONTROL Studio is my controller and is last on both lists. If it's not plugged in, it'll fall back to my 6i6's MIDI IN/OUT ports which I rarely use:

[MIDI Input Devices]
0=microKEY-61
1=Focusrite USB MIDI
2=nanoKONTROL Studio
MaxInPort=2
[MIDI Output Devices]
0=microKEY-61
1=Focusrite USB MIDI
2=nanoKONTROL Studio
MaxOutPort=2

 

Share this post


Link to post
Share on other sites

Thank you for your thoughts.  In my situation, when the control surface device (the Zoom) is unplugged, the control surface thingmy on CbB defaults to the first rather than the last device.  (And when it is plugged in, it is already set as the last device).

Your post has also prompted me to try the following, unfortunately didn't work

1 - with Zoom unplugged, set the output device to a 'spare' device (i.e. not my digital piano)

2 - save settings

3 - quit CbB

4 - plug in Zoom

5 - start CbB

6 - set output device to Zoom

7 - save settings

8 - quit CbB

9 - unplug Zoom

10 - start CbB ..... unfortunately same problem as initially described. (I was hoping it would remember a 'plan b' setup)

 

I notice that my TTSSEQ.INI also has a [MIDI Out Device Map] heading which may or may not be in your TTSSEQ.INI.   I'm not sure what this headings are for (MIDI In Device Map, and MIDI Out Device Map) these headings do not include my Zoom; however the [MIDI Output Devices] and [MIDI Input Devices] do include the Zoom.

I'm going off on holiday soon, so probably will do the tinkering when I return, and try to learn what the Device Map is for.

If you have any further thoughts it will be appreciated.

 

Thanks,

Wei Liang

 

Share this post


Link to post
Share on other sites

Hello,

I've been tinkering, and it does seem no matter what I do, that when the control surface (Zoom R16) is unplugged, that CbB goes for the first rather than the last device.  Any other suggestions?   

Below is the equivalent snippet from my TTSSEQ.INI.  I also deleted and re-created the TTSSEQ (the [MIDI In Device Map] /[MIDI Out Device Map] does not seem relevant.)

[MIDI Input Devices]
0=Port 1 on Micro
1=Port 2 on Micro
2=Port 3 on Micro
3=Port 4 on Micro
4=ZOOM R16_R24 Audio Interface
MaxInPort=4
[MIDI Output Devices]
0=Port 3 on Micro
1=Port 6 on Micro
2=Port 5 on Micro
3=Port 2 on Micro
4=Port 4 on Micro
5=ZOOM R16_R24 Audio Interface
MaxOutPort=5

 

Thanks in advance,

Wei Liang

Share this post


Link to post
Share on other sites

OK thanks I'll stop here for now.  Having a different midi device as the first device then changes the order of the rest of my MIDI devices which is inconvenient when re-opening previous projects.

However having a loopback device permanantly installed and 'looped' to the Control Surface will work, but it shifts the problem to the loopback device to remember to re-connect to the Control Surface.

Hopefully at some stage there will be a way for CbB to 'remember' disconnected USB MIDI devices

Thanks for your time Mark.

Wei Liang

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×