Jump to content
Gerry 1943

Audio dropout. SOLVED

Recommended Posts

Posted (edited)

I am presently working on a project with both Midi and Audio tracks. 

2 audio guitar tracks the balance, midi tracks.

In the last couple of weeks, after working on the project for a period of time I get an AUDIO DROPOUT. 

This has been happening on a regular basis.

How can I remedy the problem? As I mentioned this is only happening recently but on a regular basis.

What could be the problem?  Am I doing something wrong or is it the system?

 

Thank you in advance for any help. It's getting frustrating. 

 

Gerry

Edited by Gerry 1943

Share this post


Link to post
Share on other sites

Just raise your ASIO buffers or go into your Aud.ini file and raise the setting for the dropout.

But i would raise your ASIO drivers first, as that will work

Share this post


Link to post
Share on other sites

Might want to list the hardware you're using and which MIDI devices or soft synths -- and how many -- you are recording and playing back.

Share this post


Link to post
Share on other sites

Unfortunately my system, for one reason or other runs on MME not ASIO.

I am mainly using Toontrack EZ Keys and EZ drums as Midi.

PreSonus audio box USB unit.

Two guitar audio tracks.

Still having the problem.

Thank you for any help. Much appreciated.

 

 

 

Share this post


Link to post
Share on other sites

No, I have not tried WASAPI. I have two..which one should I try.....Exclusive and Shared.

These are also other set-up that I have noticed: I am running Cakewalk  in 64 -bits.  However  the MME indicates 32-bits and also my audio drive indicates 64-bits.

An other issue that came up yesterday in recording the guitar:  when I strike the first note of the guitar I do not hear it instantly....but all subsequent notes are heard properly. 

But like I said earlier, this thing about the Dropout just started happening in recent weeks.....never had it before?

Thank you in advance for any help......getting frustrated...I am not totally new at this but definitely no expert either.

Regards

 

Gerry

 

Share this post


Link to post
Share on other sites

The AudioBox should be able to run in ASIO mode. Make sure the driver is current. The latest driver was released a few days ago. If this does not work try all the other driver modes. MME is the poorest performer.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

`I suggest switching to a driver mode of ASIO, with a setting for the ASIO Buffer Size of 128 (reasonable balance that should work for recording, without running the CPU too hard).

Make sure you don't have any effects loaded during recording, that are really meant for mixing/mastering, such as a convolution reverb (uses look-ahead processing and needs a huge ASIO Buffer Size to work best - these are meant to be used during mixing), or effects that use Linear Phase processing.

You can try testing whether or not your effects are causing issues, by temporarily bypassing them.  Hit the letter 'E' on your computer keyboard - this is a shortcut key in Cakewalk, that toggles either On or Off, the bypassing of loaded effects.  If your project plays back properly with the effects bypassed, but not when the effects are allowed to engage, then that is a big clue that one or more of the effects need(s) to be swapped out for some other one(s) until you move on to the mixing phase of your project's workflow.  Hitting the 'E' key again toggles the effects back on again, so doing this test is not going to hurt anything in the project - it just gives you a quick idea on whether or not you have to make some adjustments in what effects you use during recording, and which ones you need to wait to use, until you start mixing.

Also, for the rest of time - you will want a reasonably small ASIO Buffer Size during recording - I suggest 128 samples, which is small enough to where you won't hear any lag when recording, yet large enough to where you aren't going to tax the CPU too much.  (The smaller the ASIO Buffer Size, the more work the CPU has to do, but if the buffer size is set too large - during recording, then when you play a note and there are other tracks playing, you will hear a lag between playing the note and actually hearing it, and that will prevent proper syncing between new notes and existing tracks).  When you finish recording, and move to mixing, I always change my ASIO Buffer Size to either 1024 or 2048, which is huge, but this will give any of the more 'needy' effects enough room to properly do what they do, such as the convolution reverb and/or linear-phase effects.

As noted in an earlier post, most folks get the best performance using a driver mode of ASIO - the other stuff I mention may also help you.

Bob Bone

Edited by Robert Bone
I dropped my keyboard after my butt typed a couple of errant characters of gibberish, so I edited into a proper post. :)

Share this post


Link to post
Share on other sites

Thank you Bob an Scook. I will try these solutions.

However, I seem to remember that this problem started happening after I installed the latest version/build that came out a mount or two ago.

Is this possible? I have kept the previous version/build. So could I revert back to the previous version/build?

Thank you guys again...much appreciated.

Gerry.

Share this post


Link to post
Share on other sites
9 minutes ago, Gerry 1943 said:

could I revert back to the previous version/build?

I am not sure. IIRC, Presonus made some firmware changes a while back when they dropped VSL support. These changes may prevent using older software. Not sure if it affects your device. This would be a question for Presonus support.

Share this post


Link to post
Share on other sites

In my previous post I was referring to the Cakewalk  version/builds, not the Presonus versions...

 

Regards

 

Gerry

Share this post


Link to post
Share on other sites

Also for one reason or other,  don't know if it is a sound card or Presonus issue, but I only get sound when using MME. 

I seem to have resolved the recording issue by following Robert's advise and reducing the buffer form 256 to 128..

The dropout issue is still there.

Thank you

Regards 

Gerry.

 

Share this post


Link to post
Share on other sites

If you can list as much of your system specifications as possible, as I have done in my signature, it would be most helpful. OS, processor, audio interface, disk(s), RAM, etc.

In this case, I'd like to know what kind of disk(s) you have and how you have them set up. SSD? Spinny? 7200RPM? One single drive? Projects on one, system and programs on the other? We don't know what operating system you are using. Windows 7, 8, 10? How much RAM?

Since you mention that the problem has gotten worse over time, it suggests to me that it might be helped by defragmenting the hard drive where your projects are stored, if the drive is not an SSD.

Your PreSonus AudioBox is a fine interface and should be able to run in ASIO mode, and since that is the optimum mode for it, my first order of business would be to get it working in ASIO mode. If you can't get it working in ASIO or WASAPI mode, it indicates that there are problems elsewhere that need to be corrected before you proceed.

MME is a "last resort" to be used for legacy and oddball hardware, not currently supported products like your AudioBox. You won't get full capacity from your interface running it in MME mode. It's like running your car with half of the spark plugs removed.

  • Like 1

Share this post


Link to post
Share on other sites

In reply to Straship Krupa ( by the way any relation to Gene the great drummer? ) her goes.

I am using Windows 10....Intel core i3-6100t cpu...3.2 Ghz ...8.00 RAM...system type 64 bits.

Sound card..Realteck ALC 3661

Cakewalk by Bandlab 2019-05 B31

Presonus Audio box USB 3.1.0.

As mentioned before I only get sound when using MME nothing else.

And by the way, when recording the guitar,  I am still having the issue that the 1st note played......A) is not heard instantly and....B) is not recorded at the proper level.

All following noted played are heard instantly and at the proper recording/recorded level.

As this is my first attempt at recording guitar, I am wondering what I may be doing incorrectly.  But  as I said above it seems that it is only the first note causing the issue.

The dropout issue is also still there.

 

Thank you in advance for any help. Greatly appreciated.

Gerry

Share this post


Link to post
Share on other sites

I doubt that you will ever get MME to perform well for recording or using anything in the DAW real-time. ASIO is the preferred driver mode for pro audio.

I would disable your Realtek audio, and use the AudioBox exclusively. Are your speakers connect to the AudioBox outputs, or to the computer's on-board Realtek audio jack? I'm asking this because you said you only get sound while using MME.

This PreSonus page indicates that the interface is ASIO compatible: https://www.presonus.com/products/AudioBox-USB/tech-specs

And these images show the 2 main outputs on the AudioBox that you should have your speakers connected to: https://www.presonus.com/products/AudioBox-USB/media

Share this post


Link to post
Share on other sites

My speakers are presently connected into my computer.

Are you saying that my speakers should be connected directly to my PreSonus Audiobox rather than directly into my computer?

If so, what will happen when I want to listen to music or anything coming from the computer, ie......music from YouTube?

Thank you

Gerry

Share this post


Link to post
Share on other sites
Posted (edited)

Windows audio and your DAW will both play through your AudioBox if that is the only audio interface enabled on your PC. Doing so will also make setting up the driver mode much more straightforward in Cakewalk.

But you really, really, don't want to be monitoring your DAW through your on-board PC audio output!

 

 

Edited by abacab

Share this post


Link to post
Share on other sites
5 minutes ago, Gerry 1943 said:

My speakers are presently connected into my computer.

Are you saying that my speakers should be connected directly to my PreSonus Audiobox rather than directly into my computer?

If so, what will happen when I want to listen to music or anything coming from the computer, ie......music from YouTube?

Thank you

Gerry

I use a Mackie BigKnob Passive for this purpose, so I can switch between my internal sound card when watching YouTube tutorials, and my Focusrite audio interface when using Cakewalk.

On the rare occasions that I need to hear both, I just set Windows to use my Focusrite as its primary audio device.

Share this post


Link to post
Share on other sites

Thank you everyone for your input.

Like a good little/old boy I did as I was told and am now in ASIO. However the issue of Audio Dropout has not gone away. It is still there.

So I guess MME vs ASIO has nothing to do with the issue.

I guess I will have to live with the problem!

 

Regards and thank you to all for your inputs.

Gerry.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×