Jump to content
Keni

[Solved] FR: Single button to enable/disable PRV snap (entire snap on/off)

Recommended Posts

It is still currently necessary to enable disable both global snap as well as PRV snap when working in PRV to turn snap on/off. If you simply disable PRV snap, the system reverts to using the global snap. A bit of a pain most of the time for me as I essentially never want to use my global values in the PRV. If I turn of PRV snap, I mean for snap to be off completely.

 

It would be nice. Maybe an option for off vs revert to global?

Edited by Keni

Share this post


Link to post
Share on other sites

When I am editing, I typically have the Track View snap interval set fairly coarse, such as one measure, and the Piano Roll View (PRV) snap interval fairly fine, such as 1/16 note. I start with snap enabled for both Track View and Piano Roll View, but they are set to different snap intervals, and they respond accordingly.

To toggle snap on or off, I use the N key, which is assigned to Snap Toggle Extended (I think that was actually the original default). The N key simultaneously toggles snapping for both Track View and PRV, even if they are set to separate snap intervals. I never use the PRV control to disable snapping. Whether I am editing in the Track View or PRV, the N key is my single keystroke to toggle snapping on or off. Is this the functionality you are looking for?

Share this post


Link to post
Share on other sites
25 minutes ago, Tim Elmore said:

When I am editing, I typically have the Track View snap interval set fairly coarse, such as one measure, and the Piano Roll View (PRV) snap interval fairly fine, such as 1/16 note. I start with snap enabled for both Track View and Piano Roll View, but they are set to different snap intervals, and they respond accordingly.

To toggle snap on or off, I use the N key, which is assigned to Snap Toggle Extended (I think that was actually the original default). The N key simultaneously toggles snapping for both Track View and PRV, even if they are set to separate snap intervals. I never use the PRV control to disable snapping. Whether I am editing in the Track View or PRV, the N key is my single keystroke to toggle snapping on or off. Is this the functionality you are looking for?

Mine are typically the same and I too use the n key to enable/disable snap. But when I’m editing in the PRV snd hit the n key, PRV snap disables and the track is snapping to my global so I must manually disable that each time as well.

 

I work with my snap pretty light so I can usually do my tweaks without doing this, but sometimes...

Share this post


Link to post
Share on other sites
2 hours ago, Keni said:

But when I’m editing in the PRV snd hit the n key, PRV snap disables and the track is snapping to my global so I must manually disable that each time as well.

Strange, here it disables both snaps when I press the N key. But maybe there is a setting that is different in my CbB?

Share this post


Link to post
Share on other sites
15 hours ago, Keni said:

It is still currently necessary to enable disable both global snap as well as PRV snap when working in PRV to turn snap on/off. If you simply disable PRV snap, the system reverts to using the global snap. A bit of a pain most of the time for me as I essentially never want to use my global values in the PRV. If I turn of PRV snap, I mean for snap to be off completely.

 

It would be nice. Maybe an option for off vs revert to global?

Turn off your "follow global snap" setting in the PRV - under the file tab. I'm really lazy to make video right now, sorry | or | read the doucumentation how to disable this setting. 

Everyone working in the PRV should know where to locate this. 

Edited by Will.
  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Will. said:

Turn off your "follow global snap" setting in the PRV - under the file tab. I'm really lazy to make video right now, sorry | or | read the doucumentation how to disable this setting. 

Everyone working in the PRV should know where to locate this. 

Thanks Will...

I'll find it. I even remember seeing that setting before...

Share this post


Link to post
Share on other sites

OK... Frustated in my search.

 

I do remember seeing such an item (follow global snap) somewhere... But for the life of me I've been unable to fine it in any drop down menu, Nor in Preferences snap settings,  so I've also looked elsewhere such as in keyboard shortcuts, but it's not there either...

 

I guess I'm going blind faster than my eyes.... my brain too!

 

Can anyone offer any pointers?

 

Thanks! I'd love for this issue to go away. I do a lot of midi editing...

 

According to the help docs,

Note: The Inline Piano Roll always obeys the global snap resolution.

The only option seems to be to enable/disable PRV snap which overrides it... Again, I'm still stuck with multiple switches to totally enable/disable snap while in PRV...

 

Maybe what was being referred to was the grid follows snap resolution? Nah, that didn't change it either... It's plain and has been for quite some time on my machine. If there is a way to solve this, I still can't find it.

 

Using the N key only toggles global snap... not prv snap. That requires a mouse click away in the upper corner of the prv where the snap settings reside...

 

...goin' back to looking more for what I'm missing.

 

I tried adding "FollowGlobalSnap" to the cakewalk.ini with either a 0/1 setting... no change there either.PRV always requires mouse toggle separately from the N key which is set to toggle snap...

 

Still can't find any other options but I continue to search... Somebody please stop me if they know there currently is no way to do this...

Thanks...

 

 

 

 

Edited by Keni

Share this post


Link to post
Share on other sites

I think we've been through this a couple times before. Per the documentation:

"The Piano Roll view always obeys the global Snap to Grid on/off setting, even if you specify an independent snap resolution in the Piano Roll view."

What this is saying is that if Global Snap is off, PRV snap will also be off.

'N' is bound to 'Snap Toggle Extended' by default. If you've changed this default binding to 'Global Snap On/Off'  the PRV snap on/off status will not follow the Global snap on/off.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
9 minutes ago, David Baay said:

I think we've been through this a couple times before. Per the documentation:

"The Piano Roll view always obeys the global Snap to Grid on/off setting, even if you specify an independent snap resolution in the Piano Roll view."

What this is saying is that if Global Snap is off, PRV snap will also be off.

'N' is bound to 'Snap Toggle Extended' by default. If you've changed this default binding to 'Global Snap On/Off'  the PRV snap on/off status will not follow the Global snap on/off.

Very likely... It's been frustrating me for a long time... This is some new news to me though and I will investigate. Thanks David

I did change the binding so I will see how that affects things. I changed it I'm sure, because it wasn't toggling snap in some manner...

 

OK... Why can't I find such a variable in either global or PRV keyboard bindings???

Edited by Keni

Share this post


Link to post
Share on other sites

You can't explcitily bind to 'Snap Toggle Extended'; you just have to clear any non-default binding you have and the default will be restored.

  • Thanks 1

Share this post


Link to post
Share on other sites

Can anyone suggest a place I can download the default bindings for CbB? I have only old Sonar bindings saved not thinking when I installed and updated to my customized bindings... Foolish human! 😉

 

Share this post


Link to post
Share on other sites
3 minutes ago, David Baay said:

You can't explcitily bind to 'Snap Toggle Extended'; you just have to clear any non-default binding you have and the default will be restored.

OK... That sounds easy... Doing it now! Thanks again!

 

Excellent! That worked at last!

I now remember that in some update N got assigned to something entirely different. That's when I reassigned it to N...

 

Edited by Keni

Share this post


Link to post
Share on other sites

Another new benefit I'm finding related to this...

When snap is disabled, the grid continues to be visible. Excellent!

I use them as visual reference points while editing and always disliked how they disappeared when snap (set at grid follows snap) was disabled... This too will be a help to me. I hope it's not just something snagged due to the change of shortcut binding? I only unbound the single entry...

Share this post


Link to post
Share on other sites

Yes, the grid should continue to show because youre just disabling snap without disabling the PRV snap grid.

Share this post


Link to post
Share on other sites
1 hour ago, David Baay said:

Yes, the grid should continue to show because youre just disabling snap without disabling the PRV snap grid.

Ha!

 

You say that as if anything can be expected? I started talking about this years ago. So I’ve been suffering needlessly? This must have changed somewhat recently? It’s logical, but until now, disabling snap caused screen to lose time based grid lines.

 

What a relief!

Share this post


Link to post
Share on other sites

Yes, we had a number of conversations about this back around 2013/2014 (!) when this actually broke in X3b. It was fixed in X3c but you continued to report it not working. Possibly we never figured out that it was because you had changed the default binding but I thought we had.

Edited by David Baay

Share this post


Link to post
Share on other sites
1 hour ago, David Baay said:

Yes, we had a number of conversations about this back around 2013/2014 (!) when this actually broke in X3b. It was fixed in X3c but you continued to report it not working. Possibly we never figured out that it was because you had changed the default binding but I thought we had.

Yup... very possible. No wonder it never got "fixed". 👽

Right now, I’m just thrilled to have a few long-awaited fixes resolved at last! 🎸

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...