Jump to content
Arkmedi

Strange midi sound starts randomly playing during playback..

Recommended Posts

Idk if I'm the only one but, for some reason every time I play a track or other tracks some midi which I didn't put starts playing randomly in different sections. ( Yes I did check to see if I put some random midi but, still didn't find anything). I even tried installing the new cakewalk update and it still appears which is annoying. What's also annoying is that when I exported the track The same random midi sound still appears.😑

 

Idk if anyone knows how to solve this but, hope it gets fixed🤞

Share this post


Link to post
Share on other sites

Hi illuse and welcome to the Cakewalk forums.

Can you tell us what plug-in(s) you are using?  if you could also tell us your specs/setup, that would be helpful.

Kind regards,

tecknot

Share this post


Link to post
Share on other sites
12 hours ago, tecknot said:

Hi illuse and welcome to the Cakewalk forums.

Can you tell us what plug-in(s) you are using?  if you could also tell us your specs/setup, that would be helpful.

Kind regards,

tecknot

My System: Windows 11 (64bit)

AMD Ryzen 3 3200U with Radeon Vega

237 GB memory

Here are the plugins: SINE player (2x), Jamstix4, sforzando, DSK asian dreamz

I dont think Jamstix was affected by it but, the rest yes.

The bug only occurs if I hover on a track that has it. If I hover on a different track it plays normally. Strange...

 

Screenshot 2022-08-19 221811.jpg

Share this post


Link to post
Share on other sites

By default, CbB will "Enable MIDI output" for any synth plug-in capable of sending MIDI data.

Jamstix4 likely has "Enable MIDI Output" enabled.

dT8GULq.png

If this is the case, any instrument or MIDI track input set to omni will receive the MIDI data from Jamstix. If the track has input echo enabled, the data from the Jamstix track will play.

Track one in this image 

Screenshot 2022-08-19 221811.jpg

shows

  • input echo has been automatically set because Always Echo Current MIDI Track is enabled in preferences and
  • the input was likely set to None prior to giving the track focus.

As a result, track one is now setup to play the data in the Jamstix track.

Here is a similar thread

 

  • Like 2

Share this post


Link to post
Share on other sites

If you're using Jamstix with anything other than its built-in drum sounds ( e.g. you're using Jamstix to control Addictive Drums 2), then you need to enable MIDI output.

When doing this however, you need to make sure your other MIDI / Instrument tracks, have a specific MIDI input set rather than the default "None", as this will switch to Omni when that track is active. Omni means they'll receive MIDI input from any current MIDI output, including Jamstix.  Also avoid setting them to "All Inputs" as this will also mean they receive MIDI from Jamstix.

You can do this by selecting all your other MIDI tracks,  then from the Track's view "Tracks" menu, choosing "Selected Track Inputs".  You can then pick a MIDI controller keyboard from the MIDI inputs, e.g.:

image.png.ed0ec0f61dd4bd84dd146ae14f95a350.png

This means that those MIDI tracks will only receive MIDI information from the clips on that track, or notes played on the microKEY2.

Alternatively, you can choose "All External Inputs",  which will mean they ignore MIDI data from any soft synths, and only listen to external controllers.

Obviously the drum synth track you're using with Jamstix should have it's MIDI input set to Jamstix's MIDI output.

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

So I disable the output from jamstix and omg it worked thank you so much bro. I dont know anything about the ''input and output'' stuff 😅

 

Edit: Forgot to quote your reply scook but, thanks!

Edited by illuse
  • Like 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...