Jump to content
  • 0
Beraca Music

I clip on the first beat of the first bar How to solve it

Question

hello, it happens to me that when I work with midi the first beat of my first measure, as I put some things, it clips that first beat, how do I solve it? I grab the arrangers and play it from the second bar and it fixes itself, but I would like to know how I can remove this annoyance once and for all

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 1
1 hour ago, Beraca Music said:

hello, it happens to me that when I work with midi the first beat of my first measure, as I put some things, it clips that first beat, how do I solve it?

Never start on Measure 1.  Most synths need time to initialise (especially if there is CC info or Sysex for external synths) - which they may not have time to do if the first note is on Measure 1

I always start actual notes on the 2nd (or even 3rd) measure. The space before is used to selected patches, set volumes, pan, filters, etc

  • Like 2

Share this post


Link to post
Share on other sites
  • 1

Even if I was actually using “programs like Studio One, FL studio, Ableton”, I still would not put any MIDI events right at the start.  I would still leave a gap at the start for synths to initialise.

You have your solution.

 

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

but if you think about programs like studio one, fl studio, ableton and more, they don't have that problem, the truth is that I've only noticed it on cakewalk :(

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Way way back in 1984 when I first used an Atari and played midi tracks live we quickly learned to leave that 1 st measure space to avoid stuck notes and let all our hardware set up properly. So all my ancient midi files start on 2nd measure. Prg changes and stuff start on beat 2.

Zero is never a good idea with midi and even audio for that matter. 
 

Edited by John Vere
  • Like 2

Share this post


Link to post
Share on other sites
  • 0

"Zero is never a good idea with midi and even audio for that matter. "

Agreed - I still do the same.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Other software may have a pre roll feature. Not sure though, I only use Cake.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, RBH said:

Other software may have a pre roll feature. Not sure though, I only use Cake.

I think this is it. It's been a feature request for a long time. Mostly it's people who use notation that complain.  There's no way to have your measures properly counted out and a pick up in the intro. You can set the metronome to count in but I'm not sure if that solves the other issues with synths waking up and going... " Oh! you want me to make sound? Just hold on a sec and I'll be right with you." 

Share this post


Link to post
Share on other sites
  • 0

I start pretty much all my projects at 1:01:000 unless they start with a partial 'pick-up' measure, and have only ever encountered a few specific issues with external hardware synths needing time to process a patch change or MIDI tracks with a positive (early) Time Offset entered. It shouldn't be a problem in general.

The OP mentioned using the Arranger which makes me think this might be related ('Select Events with Sections' option):

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...