Jump to content
Tubeydude

Asio4all driver

Recommended Posts

3 hours ago, kevmsmith81 said:

I have one of the low end Behringer interfaces which uses Asio4all, and I have to say I've had no issues with it.  Latency is extremely low even with a relatively humble CPU and the sound quality is good.

Yes, I know a interface with a dedicated ASIO driver would have been better, but it was what I could afford at the time and I've had exceptional value from it.

That said, am I reading this correctly in that the Windows 10 WASAPI drivers also offer low-latency recording as well?  As if it does, I may well have to give that a try and see how it stacks up.

"Extremely low" latency has Presonus Quantum under extreme settings (only). (1-2ms)

"Low" latency have some interfaces with extreme settings and RME with normal settings. (3-5ms)

"Good" latency have most interfaces with dedicated ASIO drivers.  (6-9ms)

Other interfaces have "Reasonable" latency, can be achieved by WASAPI, ASIO4ALL and sometimes WDM/KS. There are cases when WASAPI is on the level of dedicated ASIO (when the later is not specially optimised).  (10-15ms, with a bit of luck can be down to "good", but I have not observed "low" range reports. Note that reported by the DAW numbers in these modes are not real).

For testing latency, use  WASAPI exclusive. WASAPI shared normally has significant latency penalty.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, kevmsmith81 said:

I have one of the low end Behringer interfaces which uses Asio4all, and I have to say I've had no issues with it.  Latency is extremely low even with a relatively humble CPU and the sound quality is good.

Yes, I know a interface with a dedicated ASIO driver would have been better, but it was what I could afford at the time and I've had exceptional value from it.

That said, am I reading this correctly in that the Windows 10 WASAPI drivers also offer low-latency recording as well?  As if it does, I may well have to give that a try and see how it stacks up.

It's not that. I mean, if they explicitly state that their devices don't have native ASIO drivers, I wouldn't have a problem, for some people that's not a bad trade off to save a few dollars. The issue I have is that they didn't, so we have situations like this where people buy a low end Behringer product, thinking that they're getting native ASIO drivers with them, and then having that nasty surprise sprung onto them.

Edited by LadyFuzztail
  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, azslow3 said:

"Extremely low" latency has Presonus Quantum under extreme settings (only). (1-2ms)

"Low" latency have some interfaces with extreme settings and RME with normal settings. (3-5ms)

"Good" latency have most interfaces with dedicated ASIO drivers.  (6-9ms)

Other interfaces have "Reasonable" latency, can be achieved by WASAPI, ASIO4ALL and sometimes WDM/KS. There are cases when WASAPI is on the level of dedicated ASIO (when the later is not specially optimised).  (10-15ms, with a bit of luck can be down to "good", but I have not observed "low" range reports. Note that reported by the DAW numbers in these modes are not real).

For testing latency, use  WASAPI exclusive. WASAPI shared normally has significant latency penalty.

We're getting into semantics here, I think.

For me, latency is low when I can record live without any noticable latency.  I consider this entirely acceptable.

What you show as being defined as extreme would obviously be very nice, but sadly I don't have Presonus Quantum kind of money.

Share this post


Link to post
Share on other sites
4 hours ago, kevmsmith81 said:

We're getting into semantics here, I think.

For me, latency is low when I can record live without any noticable latency.  I consider this entirely acceptable.

What you show as being defined as extreme would obviously be very nice, but sadly I don't have Presonus Quantum kind of money.

Sorry, I had no offensive intentions :)

The problem is that many beginners read posts with "low latency" verbatim.  And then wonder why they do not get 3ms with under $100 interface.

The big part of this thread is about latency (there is no reason to even try ASIO4ALL otherwise, WDM/WASAPI always works way more stable).

I am not a pro and I understand you. Most of the time I use  10ms+ interfaces which are permanently connected to my comp and gear and have no problems.

But if I want hear myself throw the DAW without dry signal mixed in, that is no go. Also no go for e-drums (throw soft). For many soft amps (which have big latency on there own) that is inconvenient.

Quantum is not extra expensive, but it requires quite expensive computer to deliver minimum latency. RME is "a bit" more expensive then Quantum, but works with any hardware. There are also ZOOM (UAC) for $200  and several under $200 interfaces. I mean low latency does not mean expensive, just not "the cheapest on the market"...

Edited by azslow3
  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Warren Postma said:

Other models show the proper drivers. I think this is a mistake on Behringer's website.

It doesn't make any sense to me.

 

Behringer produce different audio interface solutions (electronically). Some are more advanced (and so more expensive) then other. No mistake here.

And common... the whole discussion remind me about "20Hz-20HZ headphones for $1".

$40 interface is not the same as $60 (especially when produced by the same company), and it is not the same as $120, $200, $500, $700...

  • Like 2

Share this post


Link to post
Share on other sites

UPDATE...

He figured it out.  His computer's screen resolution was set such that the audio preferences window was too large.  The apply and ok buttons were both out of view.  He ported his video to a larger screen using an hdmi cable and presto, there were the buttons.  Now he can select the proper driver and all is well.  He was switching the driver mode to ASIO before, but it would not stick as he was not selecting apply or ok.

Just thought I'd let you all know.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I had posted here that I replaced ASIO4ALL with WASAPI, but it turns out WASAPI introduced a slight latency into the recording process.  I literally had to nudge my clips a tiny bit to the left to make them correct. Back to ASIO4ALL and it's correct.

 

 

Edited by Barry Seymour

Share this post


Link to post
Share on other sites

All "proper ASIO" solutions for low end Behringer interfaces are using the driver mentioned by msmcleod directly (without redirection links) on the first page. My post from the time when Behringer has switched ASIO drives on there download page: http://forum.cakewalk.com/FindPost/3294586

The "driver" is still the same, from year 2009... It works with many audio interfaces and Xenyx mixers and it still works with Windows 10 (as most drivers for Windows versions before 8). It provides ASIO and WDM, but not WASAPI (which was introduced later). What this driver really is (and how "true ASIO" it is) can be speculated, some people guess it is tuned generic WDM/ASIO (ASIO4ALL is not the only one, but widely known since "free").

At the time of Windows XP... the latency around 10ms was "good". This driver can go down to ~8ms, with some "ultra" settings (since hardware overhead is high) and so the computer has to be audio optimized to work on such settings (modern interfaces/drivers at the same latency are more "forgiving").

So, it is possible to buy an audio interfaces (as new or used) with 10+ years old technologies and related software and still use that on modern system and get original results. That results depends from the original quality (back it time) and so the price (back in time). But all companies was not sitting doing nothing last 10 years, related hardware and software are not the same.

Everyone decide for himself, but in many cases "who try to save pay many times". I took the long route, started with Behringer Xenyx. Once (after 4 other "cheap" solutions) I have got "real" interface, I have understood my mistake 🙂

 

Share this post


Link to post
Share on other sites
Posted (edited)

I bought a portable interface for my old laptop, it was sometime back in 2010 (Alesis I o2). I was unimpressed to find out their driver download link was for ASIO4ALL. I used it sparingly for travel purposes and was able to get passable results that were not bad but not as good as my in home studio unit (Focusrite 18I8). I did find several oddities with the driver though, causing conflicts with other hardware, sometimes random crashes, loud bursts of white noise and even oscillation due to my onboard PC speakers (even though not used for DAW).  

I think its important when buying a device to make sure the manufacturer has a good reputation with not only its current drivers but also its updating drivers. I know some have mentioned Focusrite driver updates have given them some issues but i've been rock solid with that unit for almost 7 years now.  

Edited by chuckebaby

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, azslow3 said:

All "proper ASIO" solutions for low end Behringer interfaces are using the driver mentioned by msmcleod directly (without redirection links) on the first page. My post from the time when Behringer has switched ASIO drives on there download page: http://forum.cakewalk.com/FindPost/3294586

The "driver" is still the same, from year 2009... It works with many audio interfaces and Xenyx mixers and it still works with Windows 10 (as most drivers for Windows versions before 8). It provides ASIO and WDM, but not WASAPI (which was introduced later). What this driver really is (and how "true ASIO" it is) can be speculated, some people guess it is tuned generic WDM/ASIO (ASIO4ALL is not the only one, but widely known since "free").

At the time of Windows XP... the latency around 10ms was "good". This driver can go down to ~8ms, with some "ultra" settings (since hardware overhead is high) and so the computer has to be audio optimized to work on such settings (modern interfaces/drivers at the same latency are more "forgiving").

in the busb2902.INF I see:

Provider="usb-audio.de"

so it seems that the driver is made by Ploytec, I'm using Ploytec ASIO driver with my ART Dual Tube Pre and it works great

Edited by chris.r

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...